Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

NAT problem on Cisco Router 1841....

I have Cisco Router 1841. Recently We got 10 MBPS leased Line from ISP.  and also get following Ip Address :

WAN IP : 172.2.2.2 255.255.255.252

LAN IP  : 200.211.180.0/27

I have to configuer many to one translation ie Internal network 192.168.2.0/24 and public IP 200.211.180.0/27 . All internal hosts will be translated to public address ie Overloading or port address translation PAT.

All bove address are not actual Ip address. these are dummy.


Internal IP address is : 192.168.1.0/24

I configured Cisco Router 1841 with above IP. But while configuring NAT it gives problem .I think that there is problem while configuring NAT.

interface fa0/0

ip address 192.168.2.196 255.255.255.0

ip nat inside

interface fa0/1

ip address 200.211.180.1 255.255.255.224 secondary

ip address 172.2.2.2  255.255.255.252

ip nat outside

ip nat pool ABC 200.211.180.1 200.211.180.1 prefix-length 27

ip nat inside source list 1 pool ABC overload

access-list 1 permit 192.168.2.0 0.0.0.255

Can any body guide help me to solve this NAT problem

Thanks

3 REPLIES
Hall of Fame Super Blue

Re: NAT problem on Cisco Router 1841....

What problem is it giving ie. what are you seeing that is wrong ?

Jon

Community Member

Re: NAT problem on Cisco Router 1841....

Hi Jon,

Problem is that users do not get internet connectivity. Is above NAT configuration is correct ?

I also check by using SHow ip nat stat / tran command.

but it dispaly nothing.

Thanks

Hall of Fame Super Blue

Re: NAT problem on Cisco Router 1841....

Raju_Talele wrote:


I configured Cisco Router 1841 with above IP. But while configuring NAT it gives problem .I think that there is problem while configuring NAT.

interface fa0/0

ip address 192.168.2.196 255.255.255.0

ip nat inside

interface fa0/1

ip address 200.211.180.1 255.255.255.224 secondary

ip address 172.2.2.2  255.255.255.252

ip nat outside

ip nat pool ABC 200.211.180.1 200.211.180.1 prefix-length 27

ip nat inside source list 1 pool ABC overload

access-list 1 permit 192.168.2.0 0.0.0.255

Can any body guide help me to solve this NAT problem

Thanks

On your fa0/1 interface why is the 200.211.180.1 address the secondary. For it to work with NAT it needs to be the main IP.

If it was the main IP then you would'nt need the NAT pool ie. your config could just be -

ip nat inside source list 1 interface fa0/1 overload

Jon

2306
Views
0
Helpful
3
Replies
CreatePlease to create content