Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

NAT Throughput issue?

I recently decided to do away with my trusty Linksys WRT54G and switch to a Cisco. My requirements are minimal (basic NAT for now) which I got working with the following config:

!
interface Ethernet0
description WAN Interface
ip address dhcp
ip nat outside
full-duplex
!
!
interface FastEthernet0
description LAN Interface
ip address 10.100.1.1 255.255.255.0
ip nat inside
speed 100
full-duplex
!
ip nat inside source list 7 interface Ethernet0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 dhcp
!
!
access-list 7 permit 10.100.1.0 0.0.0.255

The physical configuration is:

[Internet] -- [Cable Modem] -- [Nortel 470 # 1] -- [Cisco] -- [Nortel 470 # 2] -- [PC]

To my dismay, the throughput seems to be significantly lower with the Cisco. I have a 9Mbs connection and could usually get about 8Mbs with my Linksys, but once I had swapped it out for the Cisco I found the throughput down to about 3.5Mbs-4Mps consistently, although latency didn't seem to be affected. At first I assumed this was because I was using a small Cisco 1721 so I switched to a 2621XM (dual fast Ethernet interfaces, etc) with the same results. I've triple-checked all port speed and duplex settings (all good), turned on cef (no change), checked the switches and cisco for packet errors (none) and checked the ip nat stats on the Cisco (looked fine). Is this normal? Have I missed something?

2 REPLIES

Re: NAT Throughput issue?

Seems to be normal if there is no collisions and overruns. What is you show processes cpu history during throughput tests? Show us sh int E0, sh int Fe0

Please rate if this helps,

Eugene.

New Member

Re: NAT Throughput issue?

Hello,

I am almost happy to see I'm not the only one with this problem! For months now I've been searching the internet for a similar issue.

I tested with a lot of routers already, always thinking I was upgrading; chronologically: 1721, 3640, 2620, 2651XM.

I always thought the main issue was that I was doing VLAN tagging, so I bought 2 NM-1FE modules for the 3640. Lol this has cost me too much already.

The issue always was the CPU being loaded at nearly 100%, seemed to be caused by interrupts. I read almost all the documentation I could find. Traffic overloading must be it, altough the docs mention other symptoms, mainly the throttling counters. My throttling is 0, the tx/rx load is < 10/255.

Now I'm determined to find a solution. What I find particularly interesting is that the poster also has a 2651XM. His line is 9mbit, while mine is 25 (and yes I can reach it; average speed is 2,9mb/s). I do get about 20mbit with -only- NAT applied, so I'm curious to see his cpu consumption with the 2651XM. I also checked things like CEF, duplex, ...

Am I too overlooking something? Why in hell do these things have two 100mbit interfaces if they can't even perform nat at 1/4 of the speed?

Thanks and happy holidays!

UPDATE: I'm sorry I see now that the poster tried with a 2621XM instead of a 2651XM. Now as I already mentioned, I tried with a 2620 --with a single interface, not using nat-on-a-stick but vlan tagging!-- and I achieved about the same throughput as with the 2651XM that is ONLY performing nat. What strikes me, is that the 1721 had a very large conf applied with also things like dhcp, dns, ddns, ... and again, vlan tagging (because I hadn't noticed the problem), and was still able to reach ~1,7mb/s while a 3640 and 2651XM with two FE interfaces only reach 500kb/s more.

Message was edited by: Frederic Kinnaer

2033
Views
0
Helpful
2
Replies