Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

NAT with Secondary IP address on interface

I have a pretty simple router config and want to do something a little strange.


For interface F0/0 I want to add a secondary IP address of 10.125.0.1/24.  Both the current 192.168.1.1 and the 10.125.0.1 networks will be on VLAN 1 for a while.


Will I be able to NAT the 10.125.0.0/25 IPs the same way I am NAT'ing the 192.168.1.0/16 IPs? If so, what do I need to add besides the secondary IP address on F0/0?

interface FastEthernet0/0

ip address 192.168.1.1 255.255.0.0

ip nat inside

duplex auto

speed auto

arp timeout 60

!

!

interface FastEthernet0/1

ip address 10.23.63.7 255.255.255.128

ip nat outside

duplex auto

speed auto

arp timeout 60

ip nat inside source static 192.168.32.20 10.23.63.17

ip nat inside source static 192.168.1.250 10.23.63.12

ip nat inside source static 192.168.1.150 10.23.63.10

ip nat inside source static 192.168.1.10 10.23.63.8

ip nat inside source static 192.168.1.22 10.23.63.11

ip nat inside source static 192.168.1.25 10.23.63.13

ip nat inside source static 192.168.1.23 10.23.63.14

ip nat inside source static 192.168.20.32 10.23.63.18

ip nat outside source static 192.168.20.32 10.23.63.17

ip classless

ip route 0.0.0.0 0.0.0.0 10.23.63.1

no ip http server

ip pim bidir-enable

!

access-list 101 deny tcp 200.200.10.0 0.0.0.255 200.199.11.0 0.0.0.255 eq ftp

access-list 101 permit ip any any


Any help would be appreciated!

James

Everyone's tags (3)
1 REPLY

NAT with Secondary IP address on interface

You can nat out on the secondary address just like you're doing now with no issues....

HTH, John *** Please rate all useful posts ***
3146
Views
0
Helpful
1
Replies