Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

NAT with two Default route ?

Hi ,

I have 2 internet connections and cisco 1841 is doing NATing , Now I need to add second connection (ADSL via Ehternet int),  How can i tell router to use  second connection

interface FastEthernet0/0
description *****LAN Connection to Switch*****
ip address 10.0.0.254 255.255.0.0
ip nat inside

interface Dialer0
ip address negotiated
ip nbar protocol-discovery
ip nat outside
ip virtual-reassembly
encapsulation ppp

ip nat inside source list 2 interface Dialer0 overload

!
ip route 0.0.0.0 0.0.0.0 Dialer0

If I just add second default route to new connection nothing flows via that interfce, I have tired putting two NAT  interface Dialer0 overload command but only once commands stays and overwirte the previous command.

New  route is something like 0.0.0.0 0.0.0.0 fastherethernet0/0 ( conncted to ADSL modem via ethernet)

If I do that  router is not sharing that connection  and every thing is going via Dialer 0 , Do I neet to modify NAT statments to make it work and how.

Thanks for the advise

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: NAT with two Default route ?

Hi,

Well you can configure your router 1841 to do policy based routing. First of all, you must define what kind of traffic goes where. You can compine policy based routing with object tracking, so you can use both interfaces to route packets and the one backup for the other. I am sending a sample configuration with one primary FastEthernet Interface and the secondary ADSL interface.

Hope this help you!

3 REPLIES
New Member

Re: NAT with two Default route ?

Hi,

Well you can configure your router 1841 to do policy based routing. First of all, you must define what kind of traffic goes where. You can compine policy based routing with object tracking, so you can use both interfaces to route packets and the one backup for the other. I am sending a sample configuration with one primary FastEthernet Interface and the secondary ADSL interface.

Hope this help you!

New Member

Re: NAT with two Default route ?

Hi  Jon ,

Thanks for the help. Sample config is great.

Regards

New Member

Re: NAT with two Default route ?

In the configuration above I assume that all the traffic comes in the Inside Ethernet Interface has already public IP Address. If not you can add another Static NAT for all traffic and add the command "ip nat outside" in the Ethernet Public Interface.

573
Views
0
Helpful
3
Replies
CreatePlease to create content