Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Native ios config on 6509

hi,

We are trying to convert our Cat OS to Native and we are in the process of converting the configuration. On QoS configuration i am not getting the equelent command in IOS. After searching on Cisco i got one doc which exactly matches with my scenario.

i am pasting that example conf from cisco here.

Boris(config)#mls qos

Boris(config)#interface range fastethernet 2/1-48

Boris(config-if)#mls qos vlan-based

Boris(config-if)#exit

Boris(config)#ip access-list extended Mission_critical

Boris(config-ext-nacl)#permit ip any host 10.10.10.20

Boris(config)#ip access-list extended Voice_traffic

Boris(config-ext-nacl)#permit ip any any

Boris(config)#class-map voice

Boris(config-cmap)#match access-group Voice_traffic

Boris(config)#class-map Critical

Boris(config-cmap)#match access-group Mission_critical

Boris(config)#policy-map Voice_vlan

Boris(config-pmap)#class voice

Boris(config-pmap-c)#set ip dscp 46

Boris(config)#policy-map Data_vlan

Boris(config-pmap)#class Critical

Boris(config-pmap-c)#set ip dscp 32

Boris(config)#interface vlan 100

Boris(config-if)#service-policy input Data_vlan

Boris(config)#interface vlan 101

Boris(config-if)#service-policy input Voice_vlan

and link is http://www.cisco.com/warp/public/473/173.html

Here my problem is we doing this configuration for access(6509) switch and we are not creating the vlan interfaces at access switch.(we just added the vlan's in vlan DB). We have applied the QoS on vlan based at Cat OS, so same way here also we wants it on vlan based.

Any idea how we can apply the QoS on vlan if i am not configuring any vlan int on a Native IOS switch.

Also i tried to convert the Cat OS conf to IOS through the Cisco tool(http://www.cisco.com/cgi-bin/Support/CatCfgConversion/catcfg_xlat.pl), but QoS part its skipping.

Jaison

2 REPLIES
Silver

Re: Native ios config on 6509

When you add a switch's ports to the database, the available interfaces will include the ports and any VLANs that are configured on the switch. A VLAN includes several of the switch's ports. In order to deploy a policy defined on a VLAN to all its associated ports, you must add each port to the database and define the QoS style as VLAN-based (as opposed to port-based). See Defining the QoS Style for a Switch's Ports, for further information.Refer the following URL for more info

http://www.cisco.com/en/US/products/sw/cscowork/ps2064/products_user_guide_chapter09186a008007ff79.html

New Member

Re: Native ios config on 6509

Hi ,

Thanks for your reply and reference. But i use cli to configure the switch not through cisco works . Your point is clear but my question is if i wants to define a vlan based QoS on L2 switch , after defining the policy where do i needs to apply the same. On my above post i got the reference from Cisco but it says i needs to apply it on Vlan interfaces. But on a L2 switch i am not creating the vlan interfaces , but ony i am adding it in Vlan database.

Jaison

146
Views
0
Helpful
2
Replies