Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Native VLAN mismatch Problem

hi , plz i face this problem and i cant solve it , so i need ur heelp to solve it ...

i have router (R1 taza)  and Switch and  betwen the R1 and Switch  link wireless  and from the Switch Trunk cable going to Mikrotik Router .. this appear to me in error mess.

Description: Native VLAN mismatch discovered on GigabitEthernet2/0/5 (14), with R1 GigabitEthernet1/0/6 (20).

Explanation:  CDP discovered a mismatch of native-VLAN configuration 

Recommended Action:  Configure the interfaces to the same native VLAN.

then this  become appear to me

Description: Native VLAN mismatch discovered on GigabitEthernet2/0/5 (14), with R1 GigabitEthernet1/0/6 (1).

Explanation:  CDP discovered a mismatch of native-VLAN configuration 

Recommended Action:  Configure the interfaces to the same native VLAN.

plz note , i set the two port in the two side on the same VLAN 14 ..

So why this appear to me ... plz advice me to we can solve this problem ..

Untitled.png

regards

  • WAN Routing and Switching
Everyone's tags (1)
5 REPLIES
New Member

Re: Native VLAN mismatch Problem

Seems like you didn't, because it's appearing that one side has VLAN 14 as the native and the other side has VLAN 1 (the default) as the native VLAN. You will need the "switchport trunk native vlan " on both sides in order to match the native VLAN and stop from receiving the CDP message.

Elvin

Native VLAN mismatch Problem

thanks for ur help , but i set this two port Switch port access ... not trunk and i am sure the two port on same VLAN 14 this is the configuration for the two port side

Switch#sh ru int gi2/0/5

Building configuration...

Current configuration : 136 bytes

!

interface GigabitEthernet2/0/5

switchport access vlan 14

switchport mode access

power inline never

end

R1 TAZA#sh ru int gi1/0/6

Building configuration...

Current configuration : 118 bytes

!

interface GigabitEthernet1/0/6

switchport access vlan 14

switchport mode access

end

regards ..

Re: Native VLAN mismatch Problem

Plz all , Any Update ??

Purple

Native VLAN mismatch Problem

Hi,

post following outputs on the switch and router :

-sh int trunk

-sh int g2/0/5 switchport

Regards.

Alain

Don't forget to rate helpful posts.
New Member

Native VLAN mismatch Problem

Hi Buddy, not sure if you solved the problem since this was asked back in 2012, but ill try to answer it anyway:

You are interchanging your configurations. You are executing the cmds for the switch on your router and the commands for the router on your switch

Have a closer look at your diagram.

7616
Views
0
Helpful
5
Replies
This widget could not be displayed.