Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Natting in LAB

Hai all,

Sorry to ask very basic quiestin ...how implement natting in LAB ..if i ve two router in labs how can i perform the same ...it wud be better if some one cud pase the config

Pls forgive if this is rubbish quistion

Thanks in advance

Lijesh.N.c

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Natting in LAB

Lets consider a topology like this

loopback R1 Serial -- serial R2

loopback - 20.20.20.1/24

R1 serial - 10.10.10.1/24

R2 serial - 10.10.10.2/24

R1 config

interface Loopback1

ip address 20.20.20.1 255.255.255.0

ip nat inside

interface serial 2/0

ip address 10.10.10.1 255.255.255.0

ip nat outside

ip nat inside source static 20.20.20.1 interface serial 2/0

R2

interface s2/0

ip address 10.10.10.2 255.255.255.0

clock rate 64000

Now ping the serial interface of R2 from R1 sourcing from loopback1

ping 10.10.10.2 source loopback1

You should see the response even though you do not have a route for the loopback from R2

To verify the NAT, do a sh ip nat translations and you should see something like this

R1#sh ip nat translations

Pro Inside global Inside local Outside local Outside global

icmp 10.10.10.1:1 20.20.20.1:1 10.10.10.2:1 10.10.10.2:1

--- 10.10.10.1 20.20.20.1 --- ---

The serial connection between the routers cn be substituted with an ethernet connection if you have the required interfaces

HTH

Narayan

2 REPLIES

Re: Natting in LAB

Lets consider a topology like this

loopback R1 Serial -- serial R2

loopback - 20.20.20.1/24

R1 serial - 10.10.10.1/24

R2 serial - 10.10.10.2/24

R1 config

interface Loopback1

ip address 20.20.20.1 255.255.255.0

ip nat inside

interface serial 2/0

ip address 10.10.10.1 255.255.255.0

ip nat outside

ip nat inside source static 20.20.20.1 interface serial 2/0

R2

interface s2/0

ip address 10.10.10.2 255.255.255.0

clock rate 64000

Now ping the serial interface of R2 from R1 sourcing from loopback1

ping 10.10.10.2 source loopback1

You should see the response even though you do not have a route for the loopback from R2

To verify the NAT, do a sh ip nat translations and you should see something like this

R1#sh ip nat translations

Pro Inside global Inside local Outside local Outside global

icmp 10.10.10.1:1 20.20.20.1:1 10.10.10.2:1 10.10.10.2:1

--- 10.10.10.1 20.20.20.1 --- ---

The serial connection between the routers cn be substituted with an ethernet connection if you have the required interfaces

HTH

Narayan

New Member

Re: Natting in LAB

Hai Narayan,

Thanks alot for the same surey i am going to exicute the same ....thanks one again ..

i had spoken to you hope you rem.

you mean to say i can use eth interface instead of serial ..right ..

Lijesh.N.C

Airtel Blr

115
Views
0
Helpful
2
Replies
CreatePlease to create content