Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Natting LAB (http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&for

Hai,

I was goin tru the notes (http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Network%20Infrastructure&topic=WAN%2C%20Routing%20and%20Switching&topicID=.ee71a06&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40%5E1%40%40.2cbee68c/0#selected_message)

i had tried to config the same but giving the error message

R2(config-if)#ip nat inside

*Mar 1 00:58:01.083: %LINEPROTO-5-UPDOWN: Line protocol on Interface NVI0, chan

ged state to up

% NBAR ERROR: parsing stopped

% NBAR Error : Activation failed due to insufficient dynamic memory

% NBAR Error: Stile could not add protocol node

%NAT: Error activating CNBAR on the interface Loopback1

R2(config-if)#

R2(config-if)#

*Mar 1 00:58:06.131: %SYS-2-MALLOCFAIL: Memory allocation of 10260 bytes failed

from 0x813AD218, alignment 0

Pool: Processor Free: 25548 Cause: Memory fragmentation

Alternate Pool: I/O Free: 9712 Cause: Not enough free memory

-Process= "Exec", ipl= 0, pid= 3, -Traceback= 0x8082C268 0x8000A2C4 0x80011ACC

0x81AF96AC 0x813AD21C 0x813AD39C 0x8138BD6C 0x8138BC00 0x8138BC2C 0x8138BC2C 0x

8138BC2C 0x8138BC4C 0x8138C634 0x81389880 0x81389924 0x813899AC

*Mar 1 00:58:06.135: %NBAR-2-NOMEMORY: No memory available for StILE lmalloc,

-Traceback= 0x8082C268 0x813AD24C 0x813AD39C 0x8138BD6C 0x8138BC00 0x8138BC2C 0x

8138BC2C 0x8138BC2C 0x8138BC4C 0x8138C634 0x81389880 0x81389924 0x813899AC 0x813

C12A8 0x813CF9E0 0x813B8D00

is this the problem with insufficiant router memory ..i using 2 1700 series router

can some one help on this

Lijesh.N.C

26 REPLIES

Re: Natting LAB (http://forum.cisco.com/eforum/servlet/NetProf?p

can u post ur config please

Community Member

Re: Natting LAB (http://forum.cisco.com/eforum/servlet/NetProf?p

hai,

Thanks for the reply.I was about the do this config

Lets consider a topology like this

loopback R1 Serial -- serial R2

loopback - 20.20.20.1/24

R1 serial - 10.10.10.1/24

R2 serial - 10.10.10.2/24

R1 config

interface Loopback1

ip address 20.20.20.1 255.255.255.0

ip nat inside

interface serial 2/0

ip address 10.10.10.1 255.255.255.0

ip nat outside

ip nat inside source static 20.20.20.1 interface serial 2/0

R2

interface s2/0

ip address 10.10.10.2 255.255.255.0

clock rate 64000

Now ping the serial interface of R2 from R1 sourcing from loopback1

ping 10.10.10.2 source loopback1

but when giving the command under interface (ip nat inside) ... immidtly getting error

R1(config-if)#ip nat insi

R1(config-if)#ip nat inside

*Mar 1 01:49:42.871: %LINEPROTO-5-UPDOWN: Line protocol on Interface NVI0, chan

ged state to up

% NBAR ERROR: due to memory problem, parsing stopped

% NBAR Error : Activation failed due to insufficient dynamic memory

% NBAR Error: Stile could not add protocol node

%NAT: Error activating CNBAR on the interface FastEthernet0

R1(config-if)#

*Mar 1 01:49:48.075: %SYS-2-MALLOCFAIL: Memory allocation of 10260 bytes failed

from 0x813AD218, alignment 0

Pool: Processor Free: 21404 Cause: Memory fragmentation

Alternate Pool: I/O Free: 9712 Cause: Not enough free memory

-Process= "Exec", ipl= 0, pid= 3, -Traceback= 0x8082C268 0x8000A2C4 0x80011ACC

0x81AF96AC 0x813AD21C 0x813AD39C 0x81388CD8 0x81388D88 0x81388E44 0x81388DA8 0x

81388E44 0x81388DA8 0x81388E44 0x8138998C 0x813C12A8 0x813CF9E0

*Mar 1 01:49:48.075: %NBAR-2-NOMEMORY: No memory available for StILE lmalloc,

-Traceback= 0x8082C268 0x813AD24C 0x813AD39C 0x81388CD8 0x81388D88 0x81388E44 0x

81388DA8 0x81388E44 0x81388DA8 0x81388E44 0x8138998C 0x813C12A8 0x813CF9E0 0x813

B8D00 0x813D9828 0x813D9B80

R1(config-if)#no ip nat inside

% NBAR Error: Interface could not found

%NAT: Error deactivating CNBAR on the interface FastEthernet0

ALSO I NOTICED (NVI0 UNASND UP UP ) ---WHAT DOES THIS MEANS

R1#show ip int brief

Interface IP-Address OK? Method Status Prot

ocol

FastEthernet0 10.10.10.1 YES manual up up

NVI0 unassigned NO unset up up

ALSO RUNNING CONFIG IS GETTING ERRASED

R1#S RUN

R1#

R1#

R1#

R1#

*Mar 1 02:01:19.947: %SYS-2-MALLOCFAIL: Memory allocation of 14844 bytes failed

from 0x80BE0B7C, alignment 0

Pool: Processor Free: 24728 Cause: Memory fragmentation

Alternate Pool: I/O Free: 9712 Cause: Not enough free memory

-Process= "Exec", ipl= 0, pid= 3, -Traceback= 0x8082C268 0x8000A2C4 0x80011ACC

0x81AF96AC 0x80BE0B80 0x8083AF9C 0x808950BC 0x808954CC 0x80873924 0x80899230 0x

803F4B54 0x803F831C

R1#

Lijesh.N.C

Re: Natting LAB (http://forum.cisco.com/eforum/servlet/NetProf?p

try to disable nbar on that interface

go to the interface where u geting error

enter the interface config mode then issue the following command:

no ip nbar protocol-discovery

good luck

Community Member

Re: Natting LAB (http://forum.cisco.com/eforum/servlet/NetProf?p

Hai,

Thanks for the reply.Even i am also still in R&D.i ve given the command on ethernet as well as Loopback ...still the same result

R1(config-if)#ip address 20.20.20.1 255.255.255.0

R1(config-if)#no ip nbar protocol-discovery

R1(config-if)#exit

R1(config)#int l1

R1(config-if)#ip nat inside

*Mar 1 01:37:21.459: %LINEPROTO-5-UPDOWN: Line protocol on Interface NVI0, chan

ged state to up

% NBAR ERROR: due to memory problem, parsing stopped

% NBAR Error : Activation failed due to insufficient dynamic memory

% NBAR Error: Stile could not add protocol node

%NAT: Error activating CNBAR on the interface Loopback1

R1(config-if)#

*Mar 1 01:37:26.991: %SYS-2-MALLOCFAIL: Memory allocation of 10260 bytes failed

from 0x813AD218, alignment 0

Pool: Processor Free: 22284 Cause: Memory fragmentation

Alternate Pool: I/O Free: 9712 Cause: Not enough free memory

-Process= "Exec", ipl= 0, pid= 3, -Traceback= 0x8082C268 0x8000A2C4 0x80011ACC

0x81AF96AC 0x813AD21C 0x813AD39C 0x81388CD8 0x81388D64 0x81388E44 0x8138998C 0x

813C12A8 0x813CF9E0 0x813B8D00 0x813D9828 0x813D9B80 0x80E045F4

*Mar 1 01:37:26.995: %NBAR-2-NOMEMORY: No memory available for StILE lmalloc,

-Traceback= 0x8082C268 0x813AD24C 0x813AD39C 0x81388CD8 0x81388D64 0x81388E44 0x

8138998C 0x813C12A8 0x813CF9E0 0x813B8D00 0x813D9828 0x813D9B80 0x80E045F4 0x80E

06368 0x80873924 0x80899230

Lijesh.N.C

Re: Natting LAB (http://forum.cisco.com/eforum/servlet/NetProf?p

i think not sure it is an issue with ur ios

if u can upgrade it will be fine

Community Member

Re: Natting LAB (http://forum.cisco.com/eforum/servlet/NetProf?p

hai,

thanks let me try that also in the worst case

CAN SOME ONE TELL ME WHAT DOES THIS SECOND LINKE MEANS (NVI0)

R2#s ip int bri

Interface IP-Address OK? Method Status Prot

ocol

FastEthernet0 10.10.10.2 YES manual up up

NVI0 unassigned NO unset up up

Lijesh.N.c

Community Member

Re: Natting LAB (http://forum.cisco.com/eforum/servlet/NetProf?p

hai,

anyone help in this regard,

even i ve changed the router also ...but still the same error

Lijeh.N.C

Hall of Fame Super Bronze

Re: Natting LAB (http://forum.cisco.com/eforum/servlet/NetProf?p

hai,

anyone help in this regard,

even i ve changed the router also ...but still the same error

Lijeh.N.C

Please post your config.

__

Edison.

Community Member

Re: Natting LAB (http://forum.cisco.com/eforum/servlet/NetProf?p

Hai Ediosn,

Thanks for the reply.There is no config at all.Connected two router back to back via Ethernet (1700 series).Ip address given to Fa/0 able to ping both ip's.

Created a Loopback (L1),when giving the command in loopback interface (ip nat inside) immidtly getting the mentiond error.Even changed the router also.

Lijesh.N.C

Hall of Fame Super Bronze

Re: Natting LAB (http://forum.cisco.com/eforum/servlet/NetProf?p

CAN SOME ONE TELL ME WHAT DOES THIS SECOND LINKE MEANS (NVI0)

R2#s ip int bri

Interface IP-Address OK? Method Status Prot

ocol

FastEthernet0 10.10.10.2 YES manual up up

NVI0 unassigned NO unset up up

That's a NAT Virtual interface:

http://www.cisco.com/en/US/docs/ios/12_3t/12_3t14/feature/guide/gtnatvi.html

__

Edison.

Community Member

Re: Natting LAB (http://forum.cisco.com/eforum/servlet/NetProf?p

Hai,

Thanks a lot for the information,('NAT Virtual interface')....

Lijesh.N.C

Community Member

Re: Natting LAB (http://forum.cisco.com/eforum/servlet/NetProf?p

hai,

when i am disabling NBAR getting the error

R2(config-if)#no ip nbar protocol-discovery

R2(config-if)#ip nat enabl

R2(config-if)#ip nat enable

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR

*Mar 1 00:36:29.487: %SYS-2-MALLOCFAIL: Memory allocation of 10260 bytes failed

from 0x813AD218, alignment 0

Pool: Processor Free: 17768 Cause: Memory fragmentation

Alternate Pool: I/O Free: 9712 Cause: Not enough free memory

-Process= "Exec", ipl= 0, pid= 3, -Traceback= 0x8082C268 0x8000A2C4 0x80011ACC

0x81AF96AC 0x813AD21C 0x813AD39C 0x81388CD8 0x81388E98 0x81388F40 0x813C11A4 0x

813CF9E0 0x813B8D00 0x813D9828 0x813D9B80 0x80E045F4 0x80E06368

*Mar 1 00:36:29.487: %NBAR-2-NOMEMORY: No memory available for StILE lmalloc,

-Traceback= 0x8082C268 0x813AD24C 0x813AD39C 0x81388CD8 0x81388E98 0x81388F40 0x

813C11A4 0x813CF9E0 0x813B8D00 0x813D9828 0x813D9B80 0x80E045F4 0x80E06368 0x808

73924 0x80899230 0x803F4B54ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR ERROR: symbol addition

% NBAR Error : Activation failed due to insufficient dynamic memory

% NBAR Error: Stile could not add protocol node

%NAT: Error activating CNBAR on the interface FastEthernet0

R2(config-if)#

Hall of Fame Super Bronze

Re: Natting LAB (http://forum.cisco.com/eforum/servlet/NetProf?p

Can you please post the following output:

show version

and

dir /all

From the troubled router.

__

Edison.

Community Member

Re: Natting LAB (http://forum.cisco.com/eforum/servlet/NetProf?p

Hai Edison,

I think u ask a valied point...Here is the requested one

R2#sh ver

Cisco IOS Software, C1700 Software (C1700-ADVSECURITYK9-M), Version 12.4(11)T, R

ELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2006 by Cisco Systems, Inc.

Compiled Sat 18-Nov-06 13:50 by prod_rel_team

ROM: System Bootstrap, Version 12.2(7r)XM2, RELEASE SOFTWARE (fc1)

R2 uptime is 2 minutes

System returned to ROM by power-on

System image file is "flash:c1700-advsecurityk9-mz.124-11.T.bin"

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to

export@cisco.com.

Cisco 1721 (MPC860P) processor (revision 0x500) with 62176K/3360K bytes of memor

y.

Processor board ID FOC09493N71 (2287621199), with hardware revision 0000

MPC860P processor: part number 5, mask 2

1 FastEthernet interface

2 Serial(sync/async) interfaces

32K bytes of NVRAM.

32768K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

R2#dir/all

% Hostname must be 2-63 characters of length, alphanumeric only.

% Hostname must be 2-63 characters of length, alphanumeric only.

% Hostname must be 2-63 characters of length, alphanumeric only.

% Hostname must be 2-63 characters of length, alphanumeric only.% Unknown comman

d or computer name, or unable to find computer address

R2#

Hall of Fame Super Bronze

Re: Natting LAB (http://forum.cisco.com/eforum/servlet/NetProf?p

Lijesh.N.C

The DRAM requirement for c1700-advsecurityk9-mz.124-11.T.bin is 96MB DRAM and you only have 64MB DRAM.

The following image should fit your router

c1700-advsecurityk9-mz.124-21.bin

HTH,

__

Edison.

Please rate helpful posts

Community Member

Re: Natting LAB (http://forum.cisco.com/eforum/servlet/NetProf?p

Hai Edison,

Wah ....great ,,,, thanks alot ..that was a valiable one ....great once again thanks ..let me try using

c1700-advsecurityk9-mz.124-21.bin

Lijesh.N.C

Hall of Fame Super Bronze

Re: Natting LAB (http://forum.cisco.com/eforum/servlet/NetProf?p

Lijesh.N.C

Please let us know how it works out and mark the thread as resolved if the recommendation fixed your problem.

__

Edison.

Community Member

Re: Natting LAB (http://forum.cisco.com/eforum/servlet/NetProf?p

Hai Edison,

Thanks once again ..will do ASAP

Lijesh.N.C

Community Member

Re: Natting LAB (http://forum.cisco.com/eforum/servlet/NetProf?p

Hai Edison,

I am trying to rate this post i am not able to do ...i am so sorry ... dont knw what is happening ...when i am submitting it not taking ... this has resolved my issue ... let me keep on trying ..

thanks a lot once again

Re: Natting LAB (http://forum.cisco.com/eforum/servlet/NetProf?p

THEN i was right when i said in the begining u need to change the ios image !!

cool at least it worked for u now espeacilly with very nice help from Edison

Community Member

Re: Natting LAB (http://forum.cisco.com/eforum/servlet/NetProf?p

hai Marwi,

Thanks a lot for ur help ... ..tooo ....(appolze the late reply )

Lijesh.N.C

Re: Natting LAB (http://forum.cisco.com/eforum/servlet/NetProf?p

u welcome..

Please Rate the Helpful Posts

and good luck

Community Member

Re: Natting LAB (http://forum.cisco.com/eforum/servlet/NetProf?p

hai Marwi,

I am trying to rate the post but not taking any one is facing the same issue .???????

Lijesh.N.C

Hall of Fame Super Bronze

Re: Natting LAB (http://forum.cisco.com/eforum/servlet/NetProf?p

Community Member

Re: Natting LAB (http://forum.cisco.com/eforum/servlet/NetProf?p

Hai Edison,

Ihd been trying to rate for your reply cz it hd solvd my issu ...but unfrtnatly it not taking

MY RATING FOR YOU 5 +

Thanks a lot

Lijesh

Community Member

Re: Natting LAB (http://forum.cisco.com/eforum/servlet/NetProf?p

hai

THanks marvi i am not able to rate ..its not taking

My rating for you 5

Thanks a lot

Lijesh.N.C

2051
Views
0
Helpful
26
Replies
CreatePlease to create content