Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

NBAR with URL

hello, somebody know how can i filter url in my router with nbar ?, i have a lab but i can't see the packets mark or match,only i can see in class-default

class-map match-all PBR

match protocol http url "cisco"

match protocol http url "192.168.1.1"

match protocol http url "192.168.1.2"

match protocol http host "192.168.1.1

policy-map uzziel

class PBR

set ip dscp cs1

!

interface FastEthernet0/0

description "LAN"

ip address 192.168.1.1 255.255.255.0

ip nbar protocol-discovery

duplex auto

speed auto

service-policy input uzziel.

Thanks.

  • WAN Routing and Switching
3 REPLIES

Re: NBAR with URL

Hello.

The problem is you have 'class-map match-all'

This means that traffic will have to match ALL your statements under this class-map, which it will never do as traffic cannot have url 192.168.1.1 AND 192.168.1.2.

You need to change your class-map to:

class-map match-any PBR

Simon

Re: NBAR with URL

Thanks, i have configure as:

class-map match-any PBR

match protocol http url "/archive/flash:home/html"

match protocol http url "/archive/flash:home/html_aux.shtml"

policy-map uzziel

class PBR

set ip dscp cs1

interface FastEthernet0/0

description "LAN"

ip address 192.168.1.1 255.255.255.0

ip nbar protocol-discovery

duplex auto

speed auto

service-policy input uzziel

-------------------------------------

Nbar_PBR#SH POLIcy-maP INterface

FastEthernet0/0

Service-policy input: uzziel

Class-map: PBR (match-any)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: protocol http url "/archive/flash:home/html"

0 packets, 0 bytes

5 minute rate 0 bps

Match: protocol http url "/archive/flash:home/html_aux.shtml"

0 packets, 0 bytes

5 minute rate 0 bps

QoS Set

dscp cs1

Packets marked 0

Class-map: class-default (match-any)

5109 packets, 469615 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: any

im simulate in lab match traffic http destination "/archive/flash:home/html"

but i can see the matchs

regards

Re: NBAR with URL

Hello

I think you need a * to wildcard the rest of the URL

"*/archive/flash:home/html*"

Simon

314
Views
0
Helpful
3
Replies
This widget could not be displayed.