Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Need assistance in EIGRP Leak Maps

I tried to implement eigrp leak-maps and did not work ..need your help

_______________________________________________

DMVPN Spoke router

 

interface Tunnel1
description XXXXX
bandwidth 1024
ip address 10.13.0.212 255.255.0.0
no ip redirects
ip mtu 1400
ip nhrp authentication 111
ip nhrp map multicast dynamic
ip nhrp map 10.13.0.1 205.204.2.251
ip nhrp map multicast 205.204.2.251
ip nhrp network-id 101
ip nhrp nhs 10.13.0.1
ip summary-address eigrp 1 10.60.4.0 255.255.252.0 5 leak-map leak
delay 10
cdp enable
tunnel source FastEthernet4
tunnel mode gre multipoint
tunnel key 111
tunnel protection ipsec profile ocbackupvpn
end

apbjnwbr1#show run int vl 1
Building configuration...

Current configuration : 244 bytes
!
interface Vlan1
description Beeijing-OCV Mangement VLAN 23_May_2009
ip address 10.60.4.61 255.255.255.192
standby 1 ip 10.60.4.62
standby 1 timers 1 3
standby 1 priority 101
standby 1 preempt
standby 1 name hsrp_netw_mgmt_vlan_gw
end

route-map leak permit 10

match ip address 10

access-list 10 permit 10.60.4.0 0.0.0.63

apbjnwbr1#show ip route 10.60.4.61
Routing entry for 10.60.4.0/26
  Known via "connected", distance 0, metric 0 (connected, via interface)
  Redistributing via eigrp 1
  Routing Descriptor Blocks:
  * directly connected, via Vlan1
      Route metric is 0, traffic share count is 1

_________________________________________________

I checked on the hub router and could not find the specific routes...


HUB#show ip eigrp topology  | b 10.60.4.0
P 10.60.4.0/22, 1 successors, FD is 58112, tag is 65000
        via 100.140.50.84 (58112/55552), GigabitEthernet0/0
        via 10.13.0.212 (1711616/28160), Tunnel2

HUB#show ip eigrp topology  | i 10.60.4.0
P 10.60.4.0/22, 1 successors, FD is 58112, tag is 65000
GRVVPNCR2#

               

Regards Vinayak
Everyone's tags (1)
3 REPLIES
Cisco Employee

Need assistance in EIGRP Leak Maps

Did you see hits in 'sh access-lists 10'. To me, the config looks good for a leak to occur. Can you post the dmvpn hub tunnel's interface config and EIGRP config on the hub. Are we learning 10.60.4.0/26 on the hub via any other protocol?

Bronze

Re: Need assistance in EIGRP Leak Maps

Please supply the output of "show ip eigrp topo 10.60.4.0/26" on the spoke router.

Sent from Cisco Technical Support iPad App

New Member

Re: Need assistance in EIGRP Leak Maps

Thanks for checking..this morning i re-implemented and it started working..

After applyig leak, i could see /26 along with /22..../26 is an external route because we have another routing source advertising the same prefix and an admin distance tweked on hub to prefer external over internal..

HUB#show ip route | i 10[.]60[.]4
D       10.60.48.0/26 [210/1709312] via 10.13.0.234, 08:05:54, Tunnel2
D EX    10.60.40.0/22 [171/58112] via 100.140.50.84, 1w4d, GigabitEthernet0/0
D       10.60.4.0/26 [210/1711616] via 10.13.0.212, 00:01:19, Tunnel2
D EX    10.60.4.0/22

After removing the leak-map

HUB#show ip route | i 10[.]60[.]4
D       10.60.48.0/26 [210/1709312] via 10.13.0.234, 08:06:07, Tunnel2
D EX    10.60.40.0/22 [171/58112] via 100.140.50.84, 1w4d, GigabitEthernet0/0
D EX    10.60.4.0/22

Regards Vinayak
243
Views
0
Helpful
3
Replies
CreatePlease login to create content