Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Need help. Cable modem to 2811 router to switch

                   Hi all,

Im going a bit insane. I cant seem to get my internet working when im going from my rogers cable modem to my 2811 router then to my switch. I have tried so many different configs and nothing has worked. Im sure its just something really simple. Here are some configs from my router

version 12.4

service config

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$u2yV$MIbSd1JXvXTQDfPTatF.f0

!

no aaa new-model

!

resource policy

!

memory-size iomem 15

ip subnet-zero

!

!

ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.1.1 192.168.1.3

!

ip dhcp pool DATA

   import all

   network 192.168.1.0 255.255.255.0

   default-router 192.168.1.1

   dns-server 4.2.2.2 2.2.2.5

   domain-name cody

!

!

!

voice-card 0

no dspfarm

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address dhcp

ip nat outside

duplex full

speed 100

!

interface Service-Engine0/0

ip address dhcp

!

interface FastEthernet0/1

ip address 192.168.1.1 255.255.255.0

ip nat inside

duplex auto

speed 100

!

ip default-gateway 192.168.0.1

ip classless

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

!

ip http server

ip nat source list 1 interface FastEthernet0/0 overload

!

access-list 1 permit 192.168.1.0 0.0.0.255

!

!

!

control-plane

!

!

!

!

!

!

!

!

line con 0

password cisco login

line aux 0

line 194

no activation-character

no exec

transport preferred none

transport input all

transport output all

line vty 0 4

password cisco

login

!

scheduler allocate 20000 1000

!

end

I gave my interface 0/0 dhcp which is from my cable modem should I just be using the single public Ip  the gave me 99.248.230.X 

Please help Trying to move on to my cisco voice but this stupid little problem is holding me back thanks

1 ACCEPTED SOLUTION

Accepted Solutions

Need help. Cable modem to 2811 router to switch

So did the ISP give you the static 99.248.230.x IP or is that what you are seeing the router get from DHCP?

3 REPLIES

Need help. Cable modem to 2811 router to switch

So did the ISP give you the static 99.248.230.x IP or is that what you are seeing the router get from DHCP?

Need help. Cable modem to 2811 router to switch

In addition to what Collin is asking, when you had it configured for dhcp, do you get an address at all? If so, can you ping anything past the provider like 4.2.2.1?

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Need help. Cable modem to 2811 router to switch

Hey sorry I finally got it working and decided it was time to leave my room. The problem I was having was I forgot to put inside nat as followed:

Ip nat inside source list 1 interface 0/0 overload

Or something like that I'm on my phone so hard to type. I appreciate tha responses though thanks for your help

143
Views
0
Helpful
3
Replies