Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Need help interface is down when ever I connect fiber line to 1921 Series router

Hello Admins,

I need your help. Looks like a funny scenario to me. We purchased one public IP and I am configuring it but still the interface is in Shutdown State. I also removed the ISP line from cisco router and tested on my laptop. It is working fine and perfect. Here is the configuration. What could be the problem? Please help. Thank you,

FAREAZ#show run

Building configuration...

Current configuration : 5531 bytes

!

! Last configuration change at 18:27:47 UTC Tue Jul 30 2013 by cisco

! NVRAM config last updated at 18:27:48 UTC Tue Jul 30 2013 by cisco

! NVRAM config last updated at 18:27:48 UTC Tue Jul 30 2013 by cisco

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname XYZ

!

boot-start-marker

boot-end-marker

!

!

logging buffered 51200 warnings

!

no aaa new-model

!

no ipv6 cef

ip source-route

ip cef

!

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.0.51 192.168.0.70

!

ip dhcp pool data

network 192.168.0.0 255.255.255.0

default-router 192.168.0.50

dns-server 86.51.34.17 86.51.35.18

lease 7

!

!

no ip domain lookup

ip domain name xyz.com

ip name-server 86.51.34.17

ip name-server 86.51.35.18

multilink bundle-name authenticated

!

crypto pki token default removal timeout 0

!

crypto pki trustpoint TP-self-signed-365255817

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-365255817

revocation-check none

rsakeypair TP-self-signed-365255817

!

!

crypto pki certificate chain TP-self-signed-365255817

certificate self-signed 01

  30820229 30820192 A0030201 02020101 300D0609 2A864886 F70D0101 05050030

  30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 33363532 35353831 37301E17 0D313330 31313031 39313634

  325A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F

  532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3336 35323535

  38313730 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100

  C4E1FC5A CE882EEA C9EDC873 AD4A6A9A 8737E917 0C52DC89 90CEE320 01DC3BB9

  DDEA1929 CBAB5891 1E81C436 FF326C41 C929A394 33CDD3E9 3A100ED2 4FA9D79B

  69C80E64 913D255F 62993510 1EE86716 26948A58 942BE51C B1573FB7 8FAEA893

  1D82877B 1D653C6F 7810C1F7 35E52D05 CAD08F01 3381BE45 1E9342B9 C3F06ADB

  02030100 01A35330 51300F06 03551D13 0101FF04 05300301 01FF301F 0603551D

  23041830 16801473 A4466562 EAE1BF11 E9FB8794 E6E8141C 7608F730 1D060355

  1D0E0416 041473A4 466562EA E1BF11E9 FB8794E6 E8141C76 08F7300D 06092A86

  4886F70D 01010505 00038181 000F09D1 C6E5D640 E8D06B4F 38BC7A66 F7634D84

  36D3DBE2 31E6EC36 153FD72D 4EA8E465 77D92927 6525CEF6 02D39203 F6779D94

  950957D4 4240D012 311EAE5F 6486FE82 9F429477 0BA257B1 4A6507D4 ECF03DAF

  702E4B22 118CFA3D 2766EDB7 2FA46916 F83C4986 9D1474FE D1C2442B 0CF0581F

  A33125A4 CC77FAC0 15CC3A93 30

        quit

license udi pid CISCO1921/K9 sn FCZ1702C1TW

!

!

username cisco privilege 15 secret 4 tnhtc92DXBhelxjYk8LXrpb4RFmfqY

!

!

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

description LOCAL-LAN

ip address 85.192.55.122 255.255.255.252

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 192.168.0.50 255.255.255.0

ip nat inside

ip virtual-reassembly in

ip tcp adjust-mss 1452

duplex auto

speed auto

!

ip forward-protocol nd

!

ip http server

ip http authentication local

no ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip nat inside source list 10 interface GigabitEthernet0/0 overload

ip route 0.0.0.0 0.0.0.0 85.192.55.121

!

access-list 10 permit 192.168.0.0 0.0.0.255

!

!

!

control-plane

!

!

line con 0

login local

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

privilege level 15

login local

transport input telnet ssh

line vty 5 15

access-class 23 in

privilege level 15

login local

transport input telnet ssh

!

scheduler allocate 20000 1000

end

Note: IPs and password are edited. Also look at the IP Int br.

Interface                  IP-Address      OK? Method Status                Protocol

Embedded-Service-Engine0/0 unassigned      YES NVRAM  administratively down down

GigabitEthernet0/0        85.192.55.122   YES manual down                  down

GigabitEthernet0/1         192.168.0.50    YES manual up                    up

NVI0                       unassigned      YES unset  administratively down down

Also let me know what is NVI0. It should also has to be up? Let me know. Thank you.

Everyone's tags (3)
8 REPLIES
Hall of Fame Super Silver

Need help interface is down when ever I connect fiber line to 19

I have looked at the config that you posted and it looks reasonable. I do not see major issues with it. The output of show ip interface brief is helpful because it show that interface Gig0/0 is down. With this interface down you certainly will not be accessing the Internet. Note that the Embedded Service Engine is in administrative shutdown state and that interface Gig0/0 is not shutdown but is down down. This is usually more an indication of some physical connection issue.

You tell us that you connected the ISP line to your laptop. Was your laptop configured for static IP or configured to use DHCP to learn an address?

HTH

Rick

New Member

Need help interface is down when ever I connect fiber line to 19

Hello Rick,

I connected the cable from ISP to my latop and configured IP statically. Connection is working fine and awesome. But when ever I connect cable to any interface of Router, Interface will go down in shutdown mode. I assigned Public IPs on both Interfaces and I checked. Interface goes into shutdown mode. However, link is working fine with my laptop when I connect directly.

New Member

Need help interface is down when ever I connect fiber line to 19

Hello Richard,

Funny story what I did was I changed duplex setting. Actually it was a VSAT connection with ISP.

I applied these commands problem solved.

duplex full

speed 100

Hall of Fame Super Silver

Need help interface is down when ever I connect fiber line to 19

I am glad that you have solved the problem. Thank you for posting back and telling us that is is solved and how you solved it.

That is very interesting that the problem turned out to be problems with speed and duplex. I am surprised that it worked on on your laptop but not on your router. But the important thing is that now it is working.

Perhaps you can mark this question as answered so that others will realize that a solution has been found?

HTH

Rick

New Member

Re:Need help interface is down when ever I connect fiber line to

Nvi is nat virtual interface and is an ios way of nating addresses rather than using the legacy ip nat inside command you would use ip nat enable. Look it up.


Sent from Cisco Technical Support Android App

New Member

Need help interface is down when ever I connect fiber line to 19

Hello Brooks,

Could you please tell me is that NAT Inside and outside command is giving me headaches. Shall I go ahead and have to configure IP nat enable on both interfaces. If NVI0 port doesn't assign IP automatically the another Gigabit Ethernet port will also go down in shutdown state. However I don't have problem with Private address. I only have problem with Public IP.

Re: Need help interface is down when ever I connect fiber line t

Hi,

Could you try configuring the MAC address of your laptop under the 1921 WAN interface?

int g0/0
mac-address xxxx.yyyy.zzzz



Sent from Cisco Technical Support iPhone App

New Member

Need help interface is down when ever I connect fiber line to 19

Hello John,

Sure, I will do that thank you. Could you please share some knowledge what happens with MAC address if I configure on

GigabitEthernet0/0   ?

945
Views
0
Helpful
8
Replies
CreatePlease to create content