Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Need help on 2921 router

  Hi,

We have a cisco 2921 at a remote site ,when i type a command it takes 15 sec to show output .

i chekced the cpu processes -it is normal

very minimal config on the router.

i am accessing the router over mpls cloud.

any help why this is responding slowly.

9 REPLIES

Need help on 2921 router

What are your ping times to the router? You said when you type a command it's slow....what about typing in general? Can you post your config?

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Need help on 2921 router

Hi John,

please see the responses below

tying in general is at normal speed.

ping X.X.X.X

Pinging X.X.X.X with 32 bytes of data:
Reply from X.X.X.X: bytes=32 time=57ms TTL=252
Reply from X.X.X.X: bytes=32 time=47ms TTL=252
Reply from X.X.X.X: bytes=32 time=46ms TTL=252
Reply from X.X.X.X: bytes=32 time=51ms TTL=252

Ping statistics for X.X.X.X:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 46ms, Maximum = 57ms, Average = 50ms

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2014.01.28 00:50:35 =~=~=~=~=~=~=~=~=~=~=~=

User Access Verification


MPLSRTR02#term le 0
MPLSRTR02#sh run
Building configuration...

Current configuration : 4046 bytes
!
! Last configuration change at 07:29:50 UTC Sun Jan 26 2014 by xxxx
! NVRAM config last updated at 08:46:01 UTC Sun Jan 26 2014 by xxxx
! NVRAM config last updated at 08:46:01 UTC Sun Jan 26 2014 by xxxx
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname MPLSRTR02
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 #############
!
no aaa new-model
!
no ipv6 cef
!
!
!
!
!
ip domain name #######
ip cef
multilink bundle-name authenticated
!
!
!
key chain eigrpkey
key 1
  key-string 7 ######################
crypto pki token default removal timeout 0
!
!
license udi pid CISCO2921/K9 sn XXXXXXXXXXX
!
!
username xxxx privilege 15 password 7 ###############
!
!
!
!
!
!
interface Loopback0
ip address X.X.X.X 255.255.255.255
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.29
encapsulation dot1Q 29
ip address X.X.X.X 255.255.255.252
!
interface GigabitEthernet0/1
description LAN #To Firewall#
ip address X.X.X.X 255.255.255.248
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
!
router eigrp 100
network X.X.X.X 0.0.0.7
redistribute bgp XXXX metric 10000 1000 255 1 1500
!
router bgp XXXX
bgp log-neighbor-changes
network X.X.X.X mask 255.255.255.0
network X.X.X.X mask 255.255.255.0
network X.X.X.X mask 255.255.255.255
network X.X.X.X mask 255.255.255.248
neighbor X.X.X.X remote-as XXXX
neighbor X.X.X.X send-community both
neighbor X.X.X.X soft-reconfiguration inbound
neighbor X.X.X.X distribute-list 10 in
neighbor X.X.X.X route-map ATT-LOC-PREF_IN in
neighbor X.X.X.X route-map ATT_BGP_OUT out
!
ip forward-protocol nd
!
ip bgp-community new-format
ip community-list 1 permit XXXX:10
ip community-list 2 permit XXXX:10
ip community-list 3 permit XXXX:20
ip community-list 4 permit XXXX:20
ip community-list 5 permit XXXX:30
ip community-list 6 permit XXXX:30
ip community-list 7 permit XXXX:100 -
ip community-list 8 permit XXXX:100
ip community-list 9 permit XXXX:200 -
ip community-list 10 permit XXXX:200
ip community-list 11 permit XXXX:300
ip community-list 12 permit XXXX:300
ip community-list 13 permit XXXX:100 -
ip community-list 14 permit XXXX:200
ip community-list 15 permit XXXX:300
ip community-list 16 permit XXXX:10 -
ip community-list 17 permit XXXX:20
ip community-list 18 permit XXXX:40
ip community-list 19 permit XXXX:40
ip community-list 20 permit XXXX:40
ip community-list 21 permit XXXX:50 -
ip community-list 22 permit XXXX:50
ip community-list 23 permit XXXX0:60
ip community-list 24 permit XXXX:60 -
ip community-list 25 permit XXXX0:70
ip community-list 26 permit XXXX0:100
ip community-list 27 permit XXXX:70
ip community-list 28 permit XXXX:10
ip community-list 29 permit XXXX:20
no ip http server
no ip http secure-server
!
ip route X.X.X.X 255.255.255.0 X.X.X.X
ip route X.X.X.X 255.255.255.0 X.X.X.X
!
!
ip prefix-list EBGP_ADVERTISE seq 10 permit X.X.X.X/24
ip prefix-list EBGP_ADVERTISE seq 20 permit X.X.X.X/24
ip prefix-list EBGP_ADVERTISE seq 30 permit X.X.X.X/29
access-list 10 deny   0.0.0.0
access-list 10 permit any
!
route-map ATT-LOC-PREF_IN permit 10
match community 7 9 13 16 21 24
set local-preference 400
!
route-map ATT-LOC-PREF_IN permit 20
!
route-map ATT_BGP_OUT permit 10
match ip address prefix-list EBGP_ADVERTISE
set community XXXX:10
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
privilege level 15
login local
transport input all
line vty 5 15
privilege level 15
login local
transport input all
!
scheduler allocate 20000 1000
end

Need help on 2921 router

What commands are taking 15 seconds to show output for? I'm assuming that this is after you hit enter...

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Need help on 2921 router

any show command infact ,yes after hitting enter.

Need help on 2921 router

What version of IOS?

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Need help on 2921 router

Here it is

c2900-universalk9-mz.SPA.152-1.T4.bin

Thank You

Kalyan.

Need help on 2921 router

I can't find any bugs related to the version. Has this always been slow or just started? If it just started, I'd suggest a reload. Something may have created a memory leak that's causing the router to run slow.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Need help on 2921 router

we have another router with exact same version of ios at the site  but on different mpls cloud and its response time is good.

is there any specific commands to investigate memory issues on the device.

Need help on 2921 router

Show proc mem will show you what's being used. I don't think the ISP has anything to do with this. The show commands are run locally on the router, and if your ping times and traffic seem fine, it's not a provider issue.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
263
Views
0
Helpful
9
Replies
CreatePlease login to create content