Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Need help setting up this WAN.

I have been assigned to setup this wan and ive got very far into it but im struggling with the next part which i think maybe down to the way that it is worded. There are very specific instructions for this on the pkt file, is it possible for somebody to take alook at this for me please?

Thanks in advance.

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Blue

Re: Need help setting up this WAN.

Paul

On each router you haven't added under the RIP config the subnet used to connect the two routers together. With RIP/EIGRP/OSPF the network command under the router config tells the router which interfaces to run on and because you haven't included them RIP is not running on those interfaces. So on each router -

router rip

network 200.100.85.0

Can you modify your configs and then see if you are seeing routes on gateway2 received from the gateway router.

Jon

14 REPLIES
Hall of Fame Super Blue

Need help setting up this WAN.

Paul

A lot of us don't use PT and therefore can't read those files. If you upload a screenshot of the topology plus a problem description then you may find a lot more people can help.

Jon

New Member

Re: Need help setting up this WAN.

Well some people may use it, i hope somebody who uses it comes into this thread.

How do i upload a picture, this website is terrible for hosting picture links that ive tried to upload.

Hall of Fame Super Blue

Re: Need help setting up this WAN.

Paul

Well some people may use it

they do and if you want to wait to see if anyone responds then that's fine.  I was simply trying to make sure you got the help you needed.

Save the screenshot as a jpg/png and upload.

Jon

Purple

Need help setting up this WAN.

Hi,

Which task are you stuck at ?

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Re: Need help setting up this WAN.

help 2.PNG

Thanks guyshelp.PNG

Ok here are my configs, im trying to ping gateway and gateway 2, there both routers from the public server. I can ping gateway from the public server but not gateway2

I have also used ripv2 by using configure terminal, router rip,version 2.(in the cisco IOS commandline within the router)

Here is my pictures, ive been on this for a couple of hours now and im stuck, it should be simple but its not working

help 3.PNG

Hall of Fame Super Blue

Need help setting up this WAN.

Paul

gateway2 obviously doesn't have a route back to the public server.

Can you post -

1) the IP of the server

2) the configs for both routers

Jon

New Member

Re: Need help setting up this WAN.

The ip of the server is 172.16.100.10/255.255.255.252

When you say the configs for both routers do you mean the show run command?

cheers

Hall of Fame Super Blue

Need help setting up this WAN.

Paul

Yes, the configs would be the "sh run" command.

If you do a "sh ip route 172.16.100.0 255.255.255.252" on gateway2 can you see a route for it pointing to the gateway router ?

If not that is the issue and it may be because of the RIP config but it would be handy to see the interface configurations as well so we can see the IP addressing being used for all the links.

Jon

New Member

Re: Need help setting up this WAN.

Gateway show ip route

Gateway# show  ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

       * - candidate default, U - per-user static route, o - ODR

       P - periodic downloaded static route

Gateway of last resort is 200.100.85.1 to network 0.0.0.0

     172.16.0.0/24 is subnetted, 1 subnets

C       172.16.100.0 is directly connected, FastEthernet0/0

C    192.168.1.0/24 is directly connected, FastEthernet0/1.1

C    192.168.10.0/24 is directly connected, FastEthernet0/1.10

C    192.168.20.0/24 is directly connected, FastEthernet0/1.20

C    192.168.30.0/24 is directly connected, FastEthernet0/1.30

C    192.168.40.0/24 is directly connected, FastEthernet0/1.40

C    192.168.50.0/24 is directly connected, FastEthernet0/1.50

C    192.168.100.0/24 is directly connected, FastEthernet0/1.100

     200.100.85.0/30 is subnetted, 2 subnets

C       200.100.85.0 is directly connected, Serial0/3/0

C       200.100.85.8 is directly connected, Serial0/3/1

S*   0.0.0.0/0 [1/0] via 200.100.85.1

Gateway#

Gateway show run

Gateway#

Gateway#show run

Building configuration...

Current configuration : 1984 bytes

!

version 12.3

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Gateway

!

!

!

!

!

!

!

!

!

!

!

!

ip ssh version 1

no ip domain-lookup

!

!

spanning-tree mode pvst

!

!

!

!

interface FastEthernet0/0

description Public Web Server

ip address 172.16.100.2 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface FastEthernet0/1.1

encapsulation dot1Q 1 native

ip address 192.168.1.1 255.255.255.0

!

interface FastEthernet0/1.10

encapsulation dot1Q 10

ip address 192.168.10.1 255.255.255.0

!

interface FastEthernet0/1.20

encapsulation dot1Q 20

ip address 192.168.20.1 255.255.255.0

!

interface FastEthernet0/1.30

encapsulation dot1Q 30

ip address 192.168.30.1 255.255.255.0

!

interface FastEthernet0/1.40

encapsulation dot1Q 40

ip address 192.168.40.1 255.255.255.0

!

interface FastEthernet0/1.50

encapsulation dot1Q 50

ip address 192.168.50.1 255.255.255.0

!

interface FastEthernet0/1.100

encapsulation dot1Q 100

ip address 192.168.100.1 255.255.255.0

!

interface Serial0/3/0

description Serial link to "Internet"

ip address 200.100.85.2 255.255.255.252

ip access-group 199 in

clock rate 250000

!

interface Serial0/3/1

ip address 200.100.85.10 255.255.255.252

clock rate 250000

!

interface Vlan1

no ip address

shutdown

!

router rip

version 2

passive-interface Serial0/3/0

network 172.16.0.0

network 192.168.10.0

network 192.168.20.0

network 192.168.30.0

network 192.168.40.0

network 192.168.50.0

network 192.168.100.0

default-information originate

!

ip classless

ip route 0.0.0.0 0.0.0.0 200.100.85.1

!

!

access-list 199 permit tcp any eq www 192.168.0.0 0.0.255.255 established

access-list 199 deny tcp any 192.168.0.0 0.0.255.255 eq www

access-list 199 deny tcp any 192.168.0.0 0.0.255.255 eq telnet

access-list 199 permit ip any any

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

password cisco

login

!

!

!

end

Gateway#

Gateway2 show ip route


Router#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

       * - candidate default, U - per-user static route, o - ODR

       P - periodic downloaded static route

Gateway of last resort is not set

     200.100.85.0/30 is subnetted, 1 subnets

C       200.100.85.8 is directly connected, Serial0/3/1

Router#

Router#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

       * - candidate default, U - per-user static route, o - ODR

       P - periodic downloaded static route

Gateway of last resort is not set

     200.100.85.0/30 is subnetted, 1 subnets

C       200.100.85.8 is directly connected, Serial0/3/1

Router#

Gateway2 show run

Router#show run

Building configuration...

Current configuration : 607 bytes

!

version 12.3

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Router

!

!

!

!

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface Serial0/3/0

no ip address

!

interface Serial0/3/1

ip address 200.100.85.9 255.255.255.252

!

interface Vlan1

no ip address

shutdown

!

router rip

version 2

!

ip classless

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end

Router#

Here are my GUI pictures of gateway and gateway2 showing RIPv2

rip 2.PNG

rip3.PNG

I have noticed that the GUI for gateway is preconfigured where gateway2 is not. Could this be the reason for no ping?

I did enter the commandline within each router and enter the command config t, router rip, version 2.

I though this was enough...? Why do i need to enter in the GUI also as shown here??

Thankyou for helping i appreciate it as im stuck, im quite new to cisco and thought i was doing well up to this point.

Hall of Fame Super Blue

Re: Need help setting up this WAN.

Paul

On each router you haven't added under the RIP config the subnet used to connect the two routers together. With RIP/EIGRP/OSPF the network command under the router config tells the router which interfaces to run on and because you haven't included them RIP is not running on those interfaces. So on each router -

router rip

network 200.100.85.0

Can you modify your configs and then see if you are seeing routes on gateway2 received from the gateway router.

Jon

New Member

Re: Need help setting up this WAN.

When you say router rip do you mean do this from the commandline within cisco? or add from the GUI as its shown above?

Paul

Hall of Fame Super Blue

Need help setting up this WAN.

Paul

Sorry i was talking about the CLI (command line). I don't have any experience with PT but i believe you can telnet/ssh to the actual device and configure it that way.

Jon

New Member

Re: Need help setting up this WAN.

Hi Jon.

Sorry for late reply as been busy with family etc.

Yes it worked once i added this to the routers GUI (RIP)

router rip

network 200.100.85.0

Ive rated your post as helpful and there maybe more questions to come in the future.

Thanks again

Paul.

Hall of Fame Super Blue

Re: Need help setting up this WAN.

Paul

No problem, glad to have helped and thanks for using the rating system to let us know it worked. 

Please feel free to post anytime you need to, there are always people who can help out with any issues.

Jon

364
Views
0
Helpful
14
Replies
CreatePlease to create content