Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Need help with ADSL

Hello

I have cisco SOHO97 (software version 12.4) and I can not connect to ADSL, I try with this configuration but it doesn't work :

ATM protocol: PPPoE
Ip Address: dynamic
VPI/VCI: 8/35

!
vpdn enable
!
vpdn-group pppoe
  request-dialin
   protocol pppoe
!
interface Dialer1
  mtu 1492
  ip address negotiated
  ip nat outside
  encapsulation ppp
   dialer pool 1
  ppp authentication pap callin
  ppp pap sent-username <username> password <password>
!
interface ATM0
  no ip address
  no ip mroute-cache
   no atm ilmi-keepalive
  dsl operating-mode auto
  pvc 8/35
   encapsulation aal5snap
   pppoe-client dial-pool-number 1
  no shutdown
  !
interface Ethernet0
  ip address <IP> <mask>
  ip nat inside
  no ip mroute-cache
  ip tcp adjust-mss 1452
  no shutdown
!
ip nat inside source list 1 interface Dialer1 overload
!
access-list 1 permit any
!

I set my PC gateway to Ethernet0 IP

Please help me

5 REPLIES

Re: Need help with ADSL

can try adding a static default route: ip route 0.0.0.0 0.0.0.0 Dialer1

also, may i suggest using extended ACL and add PAT command below:

access-list 101 permit ip any

ip nat inside source list 101 interface Dialer1 overload

New Member

Re: Need help with ADSL

Now I know what is the problem. I configure my soho97 like this:

        
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 8/35
  encapsulation aal5snap
  pppoe-client dial-pool-number 1

      
interface Dialer0
mtu 1492
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
no cdp enable
ppp authentication pap callin
ppp pap sent-username xxx password xxx

and when I enable ATM0 a get these messages:

*Mar 1 00:03:56.635: %LINK-3-UPDOWN: Interface ATM0, changed state to up
*Mar 1 00:03:57.635: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0, chan
ged state to up
*Mar 1 00:03:57.947: %DIALER-6-BIND: Interface Vi1 bound to profile Di1
*Mar 1 00:03:57.975: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state t
o up
*Mar 1 00:04:00.431: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di1
*Mar 1 00:04:00.435: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state t
o down
*Mar 1 00:04:23.591: %DIALER-6-BIND: Interface Vi1 bound to profile Di1
*Mar 1 00:04:23.595: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state t
o up
*Mar 1 00:04:26.063: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di1
*Mar 1 00:04:26.067: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state t
o down

What can be problem ???

New Member

Re: Need help with ADSL

Milos, You can use "debug ppp negotiation" and "debug dialer events" to check whether the ISP is acknowledging your authentication.

rgds, dsu

New Member

Re: Need help with ADSL

Ok now I know what is the problem. I try with another username and pass ( with 7 characters ) and it works, but when I enter my username and pass (with 15 characters) it say Access Denied. 

New Member

for me, it was the password,

for me, it was the password, i got the same error message and it didn't go away until i fixed the mistyped password :)

2149
Views
0
Helpful
5
Replies