Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Need help with Cisco 2600 and cable internet connection

Overview: I have an internet connection that when connected directly to my pc, or through an abitrary SOHO wireless router, I can go to speedtest.net and pull down 11.5 Mbps and 3.0 Mbps up.

When I put the cisco router in between my laptop and the cable modem, I only get ~about~ 1.5 Mbps in either direction.

Is there something I don't know about max bandwidth/throughput for this device?

More info:

I noticed the problem on site at a customer location. They had cable internet, but were only pulling about .6 down and .8 up. By accident when performing a test on a another piece of equipment that circumvented the router, I noticed they were getting over 8.0 down. I ended up replacing the router in that location with an 1800 series and now they get their full speed and everything is great. However, I now have another location with the same issue; we just upgraded their internet to 6Mbps wireless, but they can only get a little under 1 going through the router. It is also a 2600. I brought the old router from the first location home, redid the config for my personal set up, and am experiencing the issue described above.

Here is the config as it was in the original location:

RT-KSHD#show run
Building configuration...

Current configuration : 2010 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log uptime
service password-encryption
!
hostname RT-KSHD
!
enable secret 5 y
!
username x password 7 y
username x password 7 y
username x password 7 y
ip subnet-zero
!
!
!
chat-script DialOut ABORT ERROR "" "AT" OK "ATDT \T" TIMEOUT 60 CONNECT \c
!
!
!
interface Loopback0
ip address 10.255.255.4 255.255.255.255
!
interface Tunnel0
description GRE Tunnel to HQ
ip address 10.11.254.30 255.255.255.252
tunnel source Ethernet0/0
tunnel destination 172.16.0.254
!
interface Ethernet0/0
description "Ethernet connection to GTA firewall 172.16.0.12/30"
ip address 172.16.0.14 255.255.255.252
full-duplex
!
interface Ethernet0/1
description "x LAN 192.168.2.0/24"
ip address 192.168.2.1 255.255.255.0
full-duplex
!
interface Async65
no ip address
encapsulation ppp
dialer in-band
dialer pool-member 10
async mode dedicated
ppp authentication chap callout
!
interface Dialer10
ip address 10.100.100.26 255.255.255.252
encapsulation ppp
no ip route-cache
no ip mroute-cache
dialer pool 10
dialer remote-name x
dialer idle-timeout 300
dialer string x
dialer-group 1
ppp authentication chap
!
router ospf 1
log-adjacency-changes
passive-interface Dialer10
network 10.11.254.28 0.0.0.3 area 0
network 192.168.2.0 0.0.0.255 area 0
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.0.13
ip route 1.1.1.1 255.255.255.255 Dialer10
ip route 10.11.0.0 255.255.255.0 Dialer10 190
no ip http server
ip pim bidir-enable
!
dialer-list 1 protocol ip permit
snmp-server community public RO
!
line con 0
login local
line aux 0
script dialer DialOut
modem InOut
modem autoconfigure type usr_sportster
transport input all
autoselect ppp
stopbits 1
speed 115200
flowcontrol hardware
line vty 0 4
login local
transport input pad v120 telnet rlogin udptn
!
no scheduler allocate

end

And here is the config as I have modified it to work at home connected directly to my cable modem:

router#show run
Building configuration...

Current configuration : 951 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log uptime
service password-encryption
!
hostname router
!
enable secret 5 y
!
username x password 7 y
username x password 7 y
ip subnet-zero
!
!
no ip domain-lookup
ip name-server x
ip name-server y
ip name-server z
!
!
!
!
interface Ethernet0/0
 description "Connection from cisco to belkin"
 ip address dhcp
 ip nat outside
 full-duplex
!
interface Ethernet0/1
 description "laptop only network"
 ip address 192.168.3.1 255.255.255.0
 ip nat inside
 full-duplex
!
ip nat inside source list 1 interface Ethernet0/0 overload
ip classless
no ip http server
ip pim bidir-enable
!
access-list 1 permit 192.168.3.0 0.0.0.255
!
line con 0
 login local
line aux 0
 flowcontrol hardware
line vty 0 4
 login local
 transport input pad v120 telnet rlogin udptn
!
end

Show Ver:

Version 12.2(10r)1

cisco 2611

In both instances, the core issue is the same. The bandwidth I can get is no where near what I can get when the router is not in play. Any suggestions?

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: Need help with Cisco 2600 and cable internet connection

Joshua

It might provide helpful information if you would post the output of show ip interface from your router. One thing I am wondering about is whether the router is process switching packets or if one of the better switching paths is being used.

I would observe that the version of IOS that you are running is old. I wonder if a more recent  version of IOS would have corrected some bugs and might have improved performance. But from your description of the history of the router I also wonder if a code upgrade is feasible (do you have a maintenance contract for this router)?

I also wonder about the possibility of duplex mismatch causing poor performance. I notice that both of your interfaces are hard coded for full duplex. This prevents any negotiation of duplex on both interfaces. It is possible that whatever you are connected to (on either or both interfaces) was not able to negotiate and defaulted to half duplex. Duplex mismatch such as I have described will certainly impact performance. I would suggest changing the configuration of both interfaces to enable negotiation of duplex. Give it a try and let us know if things get better.

HTH

Rick

3 REPLIES
Hall of Fame Super Silver

Re: Need help with Cisco 2600 and cable internet connection

Joshua

It might provide helpful information if you would post the output of show ip interface from your router. One thing I am wondering about is whether the router is process switching packets or if one of the better switching paths is being used.

I would observe that the version of IOS that you are running is old. I wonder if a more recent  version of IOS would have corrected some bugs and might have improved performance. But from your description of the history of the router I also wonder if a code upgrade is feasible (do you have a maintenance contract for this router)?

I also wonder about the possibility of duplex mismatch causing poor performance. I notice that both of your interfaces are hard coded for full duplex. This prevents any negotiation of duplex on both interfaces. It is possible that whatever you are connected to (on either or both interfaces) was not able to negotiate and defaulted to half duplex. Duplex mismatch such as I have described will certainly impact performance. I would suggest changing the configuration of both interfaces to enable negotiation of duplex. Give it a try and let us know if things get better.

HTH

Rick

New Member

Re: Need help with Cisco 2600 and cable internet connection

I upgraded to latest IOS 12.3.26 for this model; that itself did not make any difference.

I tried all 4 combinations of changing the duplex of the interfaces. After setting the interface plugged directly into my laptop to half, and the interface plugged into the cable modem at half, I attained the best speeds, about 6.5down and 2.7up. This is a world better than what I was getting and so I would have to say that this is at LEAST the issue with the new (test) configuration, and could have something to do with the way it was configured in original environment. IT also gives me something to go on with the problem I'm facing in new environment. I can not see a way to tell it to duplex auto, the commands appear to put it at duplex half if i tell it anything other than duplex full

show ip interface after making the above changes:

Ethernet0/0 is up, line protocol is up

  Internet address is 174.49.140.155/22

  Broadcast address is 255.255.255.255

  Address determined by DHCP

  MTU is 1500 bytes

  Helper address is not set

  Directed broadcast forwarding is disabled

  Outgoing access list is not set

  Inbound  access list is not set

  Proxy ARP is enabled

  Local Proxy ARP is disabled

  Security level is default

  Split horizon is enabled

  ICMP redirects are always sent

  ICMP unreachables are always sent

  ICMP mask replies are never sent

  IP fast switching is enabled

  IP fast switching on the same interface is disabled

  IP Flow switching is disabled

  IP CEF switching is enabled

  IP CEF Feature Fast switching turbo vector

  IP multicast fast switching is enabled

  IP multicast distributed fast switching is disabled

  IP route-cache flags are Fast, CEF

  Router Discovery is disabled

  IP output packet accounting is disabled

  IP access violation accounting is disabled

  TCP/IP header compression is disabled

  RTP/IP header compression is disabled

  Policy routing is disabled

  Network address translation is enabled, interface in domain outside

  WCCP Redirect outbound is disabled

  WCCP Redirect inbound is disabled

  WCCP Redirect exclude is disabled

  BGP Policy Mapping is disabled

Ethernet0/1 is up, line protocol is up

  Internet address is 192.168.3.1/24

  Broadcast address is 255.255.255.255

  Address determined by non-volatile memory

  MTU is 1500 bytes

  Helper address is not set

  Directed broadcast forwarding is disabled

  Outgoing access list is not set

  Inbound  access list is not set

  Proxy ARP is enabled

  Local Proxy ARP is disabled

  Security level is default

  Split horizon is enabled

  ICMP redirects are always sent

  ICMP unreachables are always sent

  ICMP mask replies are never sent

  IP fast switching is enabled

  IP fast switching on the same interface is disabled

  IP Flow switching is disabled

  IP CEF switching is enabled

  IP CEF Feature Fast switching turbo vector

  IP multicast fast switching is enabled

  IP multicast distributed fast switching is disabled

  IP route-cache flags are Fast, CEF

  Router Discovery is disabled

  IP output packet accounting is disabled

  IP access violation accounting is disabled

  TCP/IP header compression is disabled

  RTP/IP header compression is disabled

  Policy routing is disabled

  Network address translation is enabled, interface in domain inside

  WCCP Redirect outbound is disabled

  WCCP Redirect inbound is disabled

  WCCP Redirect exclude is disabled

  BGP Policy Mapping is disabled

Given what the other poster said about NAT possibly slowing this router down a little because of it being a low end, I wonder if the duplex changes might correct the original location as it was ~8.5Mbs?

Unless there is something else you see here that can help me squeeze a few more Mbs through this old baby. And no, this one doesn't have a contract (it did at one time, but expired).

VIP Super Bronze

Re: Need help with Cisco 2600 and cable internet connection

Hi Joshua,

A 2611 router has only 10Mb interfaces and pretty slow processor (MPC860).  Also, when you add NAT to it the router gets slower and slower, because NAT is process intensive.  So, there is no way to get 11.5 out of a 10Mb interface.  With all that said, I do not know why you only get 1.5Mb out of 10Mb interface. To me somewhere close to 6 or 7Mb would be a reasonable speed. If you had an extra public IP address to use for your PC,  It would be intersting to know how high you go witout NAT.

Maybe you should replace this router with a faster one too and see if it helps.

HTH

Reza

1774
Views
0
Helpful
3
Replies