Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Need Help with Cisco1841 and Dynamic IP ISP

Hello,

  I have a Cisco 1841-SEC/K9 and I need it to connect with my LAN and share Internet with it. My Internet connection is ADSL and it provides 1 valid IP Address but it´s dynamic. So i configured the outside interface to get the IP from the DHCP in the ISP. I configured Dynamic NAT, the static route, and the ACL for my Inside Interface, but i still don´t get any Internet Connection. Also my ip name-server is wrong in this configuration, it says that is 200.44.32.13 and it should be 200.44.32.12 but when i try to erase it and add a new one it doesn't change it. Could you help me? Here´s the config:

router#show run

Building configuration...

Current configuration : 3676 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname router

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

enable secret 5 $1$dAZg$Eh38XcK2BCnc5.dNhiZCb0

enable password tlgo7838

!

no aaa new-model

ip cef

!

!

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

no ip dhcp use vrf connected

!

ip dhcp pool INTERNAL

   network 172.16.1.0 255.255.255.0

   domain-name ###############

   default-router 172.16.1.10

   dns-server 172.16.1.10

   lease 7

!

!

ip domain name yourdomain.com

ip name-server 200.44.32.13

!

!

crypto pki trustpoint TP-self-signed-1252246157

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1252246157

revocation-check none

rsakeypair TP-self-signed-1252246157

!

!

crypto pki certificate chain TP-self-signed-1252246157

certificate self-signed 01

  30820252 308201BB A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 31323532 32343631 3537301E 170D3130 30373033 32333131

  31335A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 32353232

  34363135 3730819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  81009DF9 09651D19 97B81BDE 33F56E1B C10AD162 40B1F05B 23164F10 F7F62760

  3F782DAE 636AE4A7 3BD6B269 37549F7E 4E9F65F9 327A2D34 E37947C3 2CEB7C1C

  0A571693 67B51A5E 154A9AA3 7340E204 9AA13593 4A52311E FB956E47 95912311

  2CDDD687 56FD0112 54B3E3D1 FC483D07 E537C602 00205832 9F997873 3B36FFEE

  61190203 010001A3 7A307830 0F060355 1D130101 FF040530 030101FF 30250603

  551D1104 1E301C82 1A72747A 75707265 696E6361 2E796F75 72646F6D 61696E2E

  636F6D30 1F060355 1D230418 30168014 8C4A3B2F 94F8CF6C 0524F865 DFE96B65

  F2023967 301D0603 551D0E04 1604148C 4A3B2F94 F8CF6C05 24F865DF E96B65F2

  02396730 0D06092A 864886F7 0D010104 05000381 810087C1 1A454892 502D1F14

  4F8A6609 4F7DCD49 3B576122 A34B9411 A86711CF 87CD3F43 BEBF13A0 CB18FE43

  3EA3EC91 4E33D4EA 594D7701 7AA7AE69 DA8A7C02 A2FA1C68 CA6C7E52 C9126D8A

  FEA726B0 E343B909 7CD1AC5B 7F5FE511 3DCE2F82 27350695 DC44234E 67CF7FD1

  9C254015 A89C2296 F1C3F113 39664014 19E7C204 8DFE

  quit

username ######## privilege 15 secret 5 $1$d3/m$o2V1amkT6X39qhliapSy..

username ######### privilege 15 secret 5 $1$32.Z$O23faudyenEZ3S32yFJOq1

!

!

ip telnet source-interface FastEthernet0/1

!

!

!

!

interface FastEthernet0/0

description WAN OUTSIDE

ip address dhcp

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/1

description INSIDE LAN

ip address 172.16.1.10 255.255.255.0

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/0/0

!

interface FastEthernet0/0/1

!

interface FastEthernet0/0/2

!

interface FastEthernet0/0/3

!

interface Vlan1

no ip address

!

no ip classless

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

!

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat inside source list 101 interface FastEthernet0/0 overload

!

access-list 23 permit 10.10.10.0 0.0.0.7

access-list 101 permit ip 172.16.1.0 0.0.0.255 any

!

!

control-plane

!

!

line con 0

password ########

login local

line aux 0

line vty 0 4

access-class 23 in

privilege level 15

password ########

login

transport input telnet ssh

line vty 5 15

access-class 23 in

privilege level 15

password #######

login

transport input telnet ssh

!

scheduler allocate 20000 1000

end

router#

3 REPLIES

Re: Need Help with Cisco1841 and Dynamic IP ISP

You state "My Internet connection is ADSL" but you have no ADSL port in your router.  You are trying to connect via a Fast Ethernet interface - this will not work.

You need to ad an ADSL card.

HTH>

Re: Need Help with Cisco1841 and Dynamic IP ISP

Hi Telelago

In show ip interface brief ,can you see the Dynamic ip on WAN interface if not then try to terminate ADSL connection on laptop & check whether you are able to access the internet.

& Check from router whether you are able to ping 4.2.2.2 ( Global DNS)

Can you post the output of sh ver ( IOS name )

Regards

Chetan Kumar

Cisco Employee

Re: Need Help with Cisco1841 and Dynamic IP ISP

Hello,

Is your modem giving the public IP to the router or is it also acting as a router? If possible, configure your modem to delegate/share the public IP with the router. That will also address your name-server issue.

Hope this helps.

Regards,

NT

2129
Views
0
Helpful
3
Replies
CreatePlease to create content