Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Need help with Routing

Hello,

We are setting up DID SIP Trunk on the PBX server. In this regard we purchased a Cisco Router 880 series and direct line from ISP connected to there MPLS network.

Currently the PBX server is connected to our internal network and it is under vlan 50. The gateway of the server is pointing to switch.

Now we got DID SIP trunk, therefore our PBX server must be reachable to Provider SIP address.

I have configured router

int fastethernet 0

description " connection to ISP Modem

no ip address

switchport access vlan 1

int fastethernet 1

description " connection to LAN Switch

no ip address

switchport access vlan 2

int fastethernet 2

description " connection to Laptop

no ip address

switchport access vlan 2

int vlan 1

ip address 172.x.x.57

ip nat outside

ip virtual reassembly

int vlan 2

ip address 10.1.50.2 255.255.255.0

ip nat inside

ip virtual reassembly

ip route 0.0.0.0 0.0.0.0 172.x.x.58 ( ISP Address)

ip route 10.x.x.68 ( ISP SIP Address) 255.255.255.252 172.x.x.58 ( ( ISP Address)

access-list 110 permit ip 10.1.50.0 255.255.255.0 ( Internal PBX server subnet)

ip nat inside source list 110 “interface fasthernet 0 ” overload

Switch Configuration

int vlan 50

ip address 10.1.50.1 255.255.255.0

PBX server configuration

IP: 10.1.50.3 SM: 255.255.255.0 G/W: 10.1.50.1

My Problem:

- I connected a laptop directly to router ( int fastethernet 2) and assigned the required ip address and gateway pointing to router. But I cannot ping the ISP IP address ( 172.x.x.58) I can ping from router with no issues

- How I can route the traffic on the server to ISP IP Address ( 172.x.x.58) without changing gateway on the server. So it can reach to ISP address

I would highly appreciate any help

Thanks

7 REPLIES
Purple

Need help with Routing

Hi,

ip nat inside source list 110  “ interface fasthernet 0 ” overload

your NAT outside interface is vlan1 not f0 !

So change like this ip nat inside source list 110 interface vlan 1

this will only work for traffic intiated from nat inside interface destined to nat outside but not the other way

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Community Member

Need help with Routing

I have configured the router and switch but still cannot ping from PBX server to ISP IP address

Even from the router I tried

ping 172.x.x.58 255.255.255.252 source vlan 2             not pinging

ping 172.x.x.58 255.255.255.252 source vlan 1                  pinging

Router Configuration

interface Vlan1

ip address 172.X.X.57 255.255.255.252

ip nat outside

ip virtual-reassembly in

!

interface Vlan2

ip address 10.1.50.2 255.255.252.0

ip nat inside

ip virtual-reassembly in

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

ip nat source list 110 interface Vlan1 overload

ip route 0.0.0.0 0.0.0.0 172.x.x.58

!

access-list 110 permit ip 10.1.48.0 0.0.3.255 any

Switch Configuration

int vlan 50

ip address 10.1.50.1 255.255.252.0

ip route 172.x.x.56 255.255.255.252.0 10.1.50.2

PBX Server Config

IP: 10.1.50.4

SM: 255.255.252.0

G/W: 10.1.50.1 ( SWITCH IP)

Please any advise.

Community Member

Need help with Routing

does the isp have a route back to 10.1.48.0/22 network cheers

Community Member

Need help with Routing

hi Sameer,

As cadet alain said your NAT statement is not currect.

apply the command as like

Ip nat inside source list 110 interface vlan 1 overload

Thanks

Gajendra

Community Member

Need help with Routing

I did that but still not working. I pulling my hairs now what wrong with this issue.

Thanks

Community Member

Need help with Routing

I  did this it solved

ip nat inside source list NAT interface Vlan 1 overload
!ip access-list extended NAT

permit ip 10.1.48.0 0.0.3.255 any

Now its pinging from router source vlan 2, from laptop, from PBX server.

But got a last issue

I am trying to ping ISP address from the PBX server I cannot but from the router I can ( source vlan 1 and vlan 2)

I added the route on our core switch

ip route 10.x.x.68 255.255.255.252 10.1.50.2

tracert output from server

C:\Users\Administrator>tracert 10.x.x.69

Tracing route to 10.x.x.69 over a maximum of 30 hops

  1    <1 ms    <1 ms    <1 ms  10.1.48.1    ( Switch gateway)

  2     *        *        *     Request timed out.

  3     *        *        *     Request timed out.

  4     *        *        *     Request timed out.

Any suggestions are welcome.
Thanks
Community Member

Need help with Routing

Hi,

I simulated your topology in GNS 3 , its working  properly . But I used router Instead PBX server and use physical intherface instead Vlan intherface.

I do not understand why you use VLAN in this  Scenario .

Best Regard

Pedram

243
Views
0
Helpful
7
Replies
CreatePlease to create content