Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
wuh
New Member

Need OSPF expert--type 4 lost

thank you first.

4 routers:

R3--R1--S1--S3

R3 and R1 are in Area 3;

R1 and S1 are in Area 0;

S1 and S2 are in Eigrp;

redistribute S3 Lo0 into A0.

When show ip ospf data on any of these three routers that run ospf, there is only type 5, no tpye 4.

why?

2 ACCEPTED SOLUTIONS

Accepted Solutions
Cisco Employee

Re: Need OSPF expert--type 4 lost

Could you paste the routers config please.

Hall of Fame Super Silver

Re: Need OSPF expert--type 4 lost

Hello Han,

please post

sh ip ospf database external 200.200.200.200 you will see that route type is 2 (= O E2)

However, I see the following:

prefix 200.200.200.200 is originated by 10.0.0.2

>> 200.200.200.200 10.0.0.2 2 0x80000009 0x008098 0

a type 4 LSA for 10.0.0.2 exists in your

database:

Summary ASB Link States (Area 3) = LSA tpye 4 for ASBR routers

>> 10.0.0.2 1.1.1.1 2010 0x8000000A 0x0037AB

this should be the LSA type 4 you are looking for.

1.1.1.1 should be the OSPF router-id of ABR between area 3 (the area where R3 is placed) and area 0.

about the fact that you see an O E2 route it is the default type see explanation in my previous post

From this show everything appears normal.

Hope to help

Giuseppe

12 REPLIES
Hall of Fame Super Silver

Re: Need OSPF expert--type 4 lost

Hello Han,

check also with

sh ip ospf border-routers

and what type of area is area 3?

Hope to help

Giuseppe

wuh
New Member

Re: Need OSPF expert--type 4 lost

On, S1, I did this: and Area 3 only consists of 2 routers, r1 and r3. No explicit Stubby area configured.

S1#sh ip os b

OSPF Router with ID (2.2.2.2) (Process ID 200)

Base Topology (MTID 0)

Internal Router Routing Table

Codes: i - Intra-area route, I - Inter-area route

OSPF Router with ID (10.0.0.2) (Process ID 100)

Base Topology (MTID 0)

Internal Router Routing Table

Codes: i - Intra-area route, I - Inter-area route

i 1.1.1.1 [64] via 2.2.2.1, Serial1/0, ABR, Area 0, SPF 5

S1#

VIP Super Bronze

Re: Need OSPF expert--type 4 lost

Hi Han,

You mean S1-S3 right?

The type-4 LSA is generated by an ABR. The purpose of it is simply to inform other areas of next-hop information for the ASBR. In your case you should be able to see the type-4 LSA on S1 router.

In your area 0 router if you issue this command:

sh ip ospf database asbr-summary

You should see this:

Summary ASB Link States (Area 0)

HTH

Reza

wuh
New Member

Re: Need OSPF expert--type 4 lost

When I do sh ip ospf asbr-summary os S1,

I only see

OSPF router with ID(R1)(Process ID 200)

OSPF router with ID(S3)(Process ID 100)

No any other words.

thanks,

Han

wuh
New Member

Re: Need OSPF expert--type 4 lost

Also, Why Can't I see the E1 route of the injected? only E2 with no cost between a router to the ASBR added?

thanks,

Cisco Employee

Re: Need OSPF expert--type 4 lost

Hello Han,

From your outputs, I see you have two OSPF processes running on a single router. Is that so?

It would be helpful if you attached the OSPF configuration of each router here.

Best regards,

Peter

Cisco Employee

Re: Need OSPF expert--type 4 lost

Could you paste the routers config please.

wuh
New Member

Re: Need OSPF expert--type 4 lost

I have to paste it later. Saving the config is a little funny in my lab.

:)

By the way, in OSPF are the following have to be explicitly configured?

1. Stub area,

2. Redistributed E1?

I thought E1 routes are defautly flooded.

thanks,

Hall of Fame Super Silver

Re: Need OSPF expert--type 4 lost

Hello Han,

as Peter has noted you have two OSPF processes.

you don't need to use one OSPF process-id for each area a router is a member of.

OSPF domains and OSPF areas are not the same.

Two different OSPF processes are "ships in the night" and don't communicate unless you configure explicit redistribution between them.

this can be the root cause for all the missing information.

you may be looking in OSPF domain A hoping to find a route injected in OSPF domain B.

stub areas are firewalls for LSA type 5 both E1 and E2.

LSA type 5 are flooded in area 0 and all non stub (any type) areas.

2) E2 is the default type of route injected in OSPF an explicit configuration is needed to generate an O E1 route

see metric-type option in redistribute command or in route-map configuration

O E1 route is preferred over O E2 route within an single OSPF domain regardless of metric value because it is seen as carrying more detailed information because it sums internal costs to seed metric

Hope to help

Giuseppe

wuh
New Member

Re: Need OSPF expert--type 4 lost

this is the show run and show show ip ospf database of R3 on the left 200.200.200.200 is a subnet on s2 and redistributed by S1 from Eigrp. why no Tpye 4 and no E1?

R3#sh run

Building configuration...

Current configuration : 1460 bytes

!

! Last configuration change at 05:43:21 UTC Sun Nov 8 2009

!

!

hostname R3

!

ip source-route

ip cef

!

!

!

!

no ipv6 cef

!

!

interface FastEthernet0/0

no ip address

shutdown

duplex half

!

!

interface Serial1/0

ip address 1.1.1.2 255.255.255.252

serial restart-delay 0

!

!

interface Serial1/1

no ip address

shutdown

serial restart-delay 0

!

!

interface Serial1/2

no ip address

shutdown

serial restart-delay 0

!

!

interface Serial1/3

no ip address

shutdown

serial restart-delay 0

!

!

!

router ospf 500

log-adjacency-changes

network 1.1.1.0 0.0.0.255 area 3

!

end

R3#

======================

R3#sh ip os da

%OSPF: Router process 200 is not running, please configure a router-id

OSPF Router with ID (1.1.1.2) (Process ID 500)

Router Link States (Area 3)

Link ID ADV Router Age Seq# Checksum Link count

1.1.1.1 1.1.1.1 986 0x80000016 0x001F5E 2

1.1.1.2 1.1.1.2 1000 0x8000000E 0x002064 2

Summary Net Link States (Area 3)

Link ID ADV Router Age Seq# Checksum

2.2.2.0 1.1.1.1 2010 0x80000009 0x00836A

Summary ASB Link States (Area 3)

Link ID ADV Router Age Seq# Checksum

10.0.0.2 1.1.1.1 2010 0x8000000A 0x0037AB

Type-5 AS External Link States

Link ID ADV Router Age Seq# Checksum Tag

10.0.0.0 10.0.0.2 2030 0x80000009 0x00FF35 0

200.200.200.200 10.0.0.2 2 0x80000009 0x008098 0

R3#

Hall of Fame Super Silver

Re: Need OSPF expert--type 4 lost

Hello Han,

please post

sh ip ospf database external 200.200.200.200 you will see that route type is 2 (= O E2)

However, I see the following:

prefix 200.200.200.200 is originated by 10.0.0.2

>> 200.200.200.200 10.0.0.2 2 0x80000009 0x008098 0

a type 4 LSA for 10.0.0.2 exists in your

database:

Summary ASB Link States (Area 3) = LSA tpye 4 for ASBR routers

>> 10.0.0.2 1.1.1.1 2010 0x8000000A 0x0037AB

this should be the LSA type 4 you are looking for.

1.1.1.1 should be the OSPF router-id of ABR between area 3 (the area where R3 is placed) and area 0.

about the fact that you see an O E2 route it is the default type see explanation in my previous post

From this show everything appears normal.

Hope to help

Giuseppe

wuh
New Member

Re: Need OSPF expert--type 4 lost

thanks,

253
Views
5
Helpful
12
Replies
CreatePlease to create content