Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

need RDP to my internal server

hi

please help me in my config which is not working for RDP connection to my internal server.

I have 801 with DIAL UP ISDN connection i am using dynamic ip to connect. the config is below

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname DIAL-ISDN

!

enable secret level xxxx

!

!

!

!

!

ip subnet-zero

!

ip name-server x.x.x.x

ip name-server x.x.x.x

isdn switch-type basic-net3

!

!

!

interface Ethernet0

ip address 192.168.0.123 255.255.255.0

ip nat inside

!

interface BRI0

no ip address

ip nat outside

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

ppp authentication pap callin

!

interface Dialer1

ip address negotiated

ip nat outside

encapsulation ppp

dialer pool 1

dialer idle-timeout 500

dialer string 4004444

dialer hold-queue 10

dialer-group 1

ppp authentication pap callin

ppp pap sent-username xxxx password xxxxx

!

ip nat inside source list 101 interface Dialer1 overload

ip nat inside source static tcp 192.168.0.100 3389 interface Dialer1 3389

ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

!

access-list 101 permit ip any any

dialer-list 1 protocol ip permit

!

line con 0

password xxxx

login

transport input none

stopbits 1

line vty 0 4

password xxxx

login

length 100

!

no rcapi server

!

!

end

4 REPLIES
New Member

Re: need RDP to my internal server

Just a thought - is the default gateway of the server set to be 192.168.0.123 ?

New Member

Re: need RDP to my internal server

yes, the default gateway is 192.168.0.123

Re: need RDP to my internal server

Hi shoeb

From where you are trying to connect to your RDP server ? are you trying to connect from the outside world ? if thts the case which public ip you are using up to establish the RDP connectivity ?

regds

New Member

Re: need RDP to my internal server

if you type "sh int dialer1" and post the output. This should give you the dynamic address assigned. Check this is the address you are using.

Also, when you try and access the public address of the router/server on 3389 to access the server, where are you doing this from? Are you able to RDP to other "outside" servers - just wondering if your site is blocking RDP outbound.

There are no ACL lists so the NAT traslation should be sufficient.

204
Views
0
Helpful
4
Replies
CreatePlease to create content