Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k

Need to configure 1941 as dhcp from static ip

i need to Need to configure 1941 as dhcp from static reserve IP address :117.239.69.81/29, gateway:117.239.69.9/29 and DNS: 218.248.255.211 ,218.248.255.139 and connect to switch

interface GigabitEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$

ip address 10.10.10.1 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 117.239.69.81/29

duplex auto

speed auto

ip dhcp excluded-address 10.10.10.1

!

ip dhcp pool ccp-pool

import all

network 10.10.10.0 255.255.255.0

default-router 10.10.10.1

dns-server 218.248.255.211

dns-server 218.248.255.139

ip route 0.0.0.0 0.0.0.0 117.239.69.9

Kindly give solution or modified one/new wether any nat needed

6 REPLIES
Bronze

Need to configure 1941 as dhcp from static ip

! For the interface to use dhcp instead of fixed adress

interface GigabitEthernet0/1

no ip address 117.239.69.8/129

ip address dhcp

! set default route to interface instead of address

no ip route 0.0.0.0 0.0.0.0 117.239.69.9

ip route 0.0.0.0 0.0.0.0 Gi0/1

! even in this configuration the router probably will not route the private range 10.x.x.x

! out of the interface with public address 117.239.69.81  without NAT.

! you neet to specify wich direction to nat (private adresses to the inteface with public address)

int  Gig0/0

   ip nat inside

int Gig0/1

   ip nat outside

ip nat inside source interface Gi0/0 interface Gi0/1 overload

! or more flexible:

ip nat inside source route-map INTERNET interface Gi0/1 overload

route-map INTERNET permit 10

match ip address 101

access-list 101 permit ip 10.10.10 0.0.0.255 any

Re: Need to configure 1941 as dhcp from static ip

Thanks but customer is using static ip there is no dhcp server The isp directly terminated in a switch. so we need to connect user with router 1941 (may act as dhcp server) for user end to connect another switch from router 1941.pls give suggestion as if we use dhcp in gigaethernet 0/1.

        otherwise where  to use the isp static ip?

Bronze

Need to configure 1941 as dhcp from static ip

You got me confused now.

So you don't want the router configured as dhcp client, but as server?

but the router is allrady configured as dhcp server

ip dhcp pool ccp-pool
  network 10.10.10.0 255.255.255.0

will issue dhcp addresses on the interface in the same subnet

interface GigabitEthernet0/0

ip address 10.10.10.1 255.255.255.0

if you want this on the other interface (gi0/1)

than you may add another dhcp scope

ip dhcp pool second-pool

  network 10.10.20.0 255.255.255.0

(etc)

and change the address or add a secundary address to the gi0/1 interface

interface GigabitEthernet0/1

ip address 10.10.20.1 255.255.255.0 [secundary]

or configure a subinterface  ( eg for vlan 20)

interface GigabitEthernet0/1.20

encapsulation dot1Q 20

ip address 10.10.20.1 255.255.255.0

and configure the connected switchport as vlan-trunk for both untagged and vlan-20tagged  packets

and connect your clients to access-ports in vlan 20 on this switch

Re: Need to configure 1941 as dhcp from static ip

hi

thanks once again no need of secondary dhcp as they use static ip which means where to give isp address as they dont have modem they only have direct reserve ip 117.239.69.81/29, gateway:117.239.69.9/29. i connect in router whether it wont need to give isp ip address in the router.

Bronze

Re: Need to configure 1941 as dhcp from static ip

You got me very confused now.

I read in your post a question about dhcp, "i need to configure 1941 as dhcp...."

ans in your other post  "pls give suggestions as if we use dhcp in gigaethernet 0/1"

But both my answers (1941 as dhcp client or dhcp server) do not seem to answer your question?

Please clarfy what you want, maybe then i can give an answer thats is helpful to you.

Re: Need to configure 1941 as dhcp from static ip

hi

make as dhcp server and connect pc from router for internet. thanks its helpful and configured ok....

560
Views
3
Helpful
6
Replies
CreatePlease to create content