Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

New Cisco 1921 router, doesn't have a command that existed previously...?

Hi.  Hoping someone out there can help.  Our company had been buying Cisco 1841 routers for years and they have served us well.  The 1841 was discontinued and instead we have now purchased a Cisco 1921.  It is brand new, running "Version 15.0(1r)M15" of IOS ("usbflash0:c1900-universalk9-mz.SPA.151-4.M4.bin" file).

On our older Cisco 1841 routers, we would always prioritize certain TCP and UDP packets using the priority-list command.  However, I have suddenly discovered that priority-list is not available on this brand new router.  (?)  I am unsure why.  I did some reading and according to the document http://www.cisco.com/en/US/docs/switches/lan/catalyst3750x_3560x/software/release/15.0_1_se/configuration/guide/swuncli.pdf (page B-13) both priority-list and priority-group are unsupported in Cisco IOS 15.

It frustrates me that a later version of a product isn't as fully-featured as the earlier version, but I am wondering if anyone can assist me in accomplishing what I want to do.  I want to prioritize the following type of network traffic

UDP ports 8000 through 8063, 2427, 2727, 9300, 9301

TCP port 35300, 60001 through 60010, 2065, 33333, 3065

giving them a higher priority than the rest of other packets.  This is necessary for our vendor's VoIP implementation.  These packets should be "high" priority; everything else can be "medium."

Can someone point me in the right direction on this?  Thanks for any replies.

3 REPLIES

New Cisco 1921 router, doesn't have a command that existed previ

I'm facing the same situation with the Universal versions of IOS. They're license bound now, so if you need a feature that you had in the past, it may be that it's in a different Universal version and you need a license key to support it. Anyway, I digress. If you have QoS, you can do something like the following:

ip access-list ext UDP

permit udp any any range 8000 8063

permit udp any any range 9300 9301

permit udp any any eq 2427

permit udp any any eq 2727

ip access-list ext TCP

permit tcp any any range 60001 60010

permit tcp any any eq 35300

permit tcp any any eq 2065

permit tcp any any eq 33333

permit tcp any any eq 3065

class-map match-any HIGH

match access-group name TCP

match access-group name UDP

policy-map QOS

class HIGH

priority percent 75

class class-default

bandwidth percent 25

int s0/0 (outside interface)

service-policy output QOS

HTH,

John

HTH, John *** Please rate all useful posts ***
Community Member

New Cisco 1921 router, doesn't have a command that existed previ

Thanks for the reply and taking the time to create a solution for us. This appears to be what I am looking for. Just one follow-up question...

I am concerned about the bandwidth percent 25 line in your post above. Will this restrict total our bandwidth for non-QoS packets to only 25%? In other words, if we have no packets coming across the interface (which, for us, will be GigabitEthernet0/1) which are in the two (2) ip access-list specifications, are we still restricted to 25% of the total bandwidth anyway? This seems like it would be a big waste.

Thanks again for your reply and thanks for any follow-up replies.

New Cisco 1921 router, doesn't have a command that existed previ

Kevin,

The bandwidth percentage guarantees at least that much traffic is allowed through whenever there's congestion in the link. This config won't restrict anything, but priority percentage will guarantee 75% of the link if you need it. The priority queue will also cap at 75%, so on a T1 at 1544000, you're guaranteed 1.158 of bandwidth for your priority applications, but it also will police at 1.158 of bandwidth so it doesn't starve the other queues. I like to give a guarantee to the class default because whatever doesn't match your other policy will fall into the class default.

HTH,

John

Please rate useful posts...

HTH, John *** Please rate all useful posts ***
1066
Views
10
Helpful
3
Replies
CreatePlease to create content