Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

new cisco 887va Router installation

Dear all

I'll install a cisco 887va-k9 router next week. would you please tell me how to install it to act as  ADSL modem to my LAN  regarding blow informations:

adsl

pppoe

vpi/vci 0/35

username U

password P

kind regards

Mahmoud

16 REPLIES
Community Member

new cisco 887va Router installation

Dear Mahmoud,

You have to get the PVC, username, password informations from tour ISP, below would be typical configuration for ADSL interface and ethernet interface.

ADSL interface

--------------------

interface ATM0
no ip address
no atm ilmi-keepalive
pvc 0/35
  pppoe-client dial-pool-number 1


interface Dialer1
ip address negotiated
ip mtu 1452
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname xxxx
ppp chap password xxxx
ppp pap sent-username xxxx password xxxx

Ethernet Interface

-------------------------


interface GigabitEthernet0/0
no ip address
ip mtu 1492
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1


interface Dialer1
ip address negotiated
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
ppp chap hostname xxxx
ppp chap password xxxx
ppp pap sent-username xxxx password xxxx

Thanks *** please rate helpful posts***

Shanil

Community Member

new cisco 887va Router installation

Thank you Shanil for your replay ,I appreciate that.please tell me what is the difference between these two configurations

I need to connect the RJ11 coming from the wall outlet directly to the router (POTS port), is this connction correct ?

Community Member

Re: new cisco 887va Router installation

Yes in that case it's Adsl (ATM) interface you have to use the first configuration.

The difference is if you have rj-11 connection from provider you need an Adsl interface on the router. If it's rj-45 wan Ethernet interface is needed in router
Thanks
Shanil

Sent from Cisco Technical Support iPhone App

Community Member

new cisco 887va Router installation

Thank you Shanil

If I need t connect this 887va router with 1801 cisco router in anther area through site to site vpn

1- I'll use interface ATM0 as source in tunnel ,is that correct?

2- Do I need static public ip in both sites for the vpn ?

3-I saw another configuration for adsl in 887 ,thy use another sub-interface uder interface ATM0 like

#interface  ATM 0.1  point-to-poin

why tis command?

regards

MAhmoud

Community Member

new cisco 887va Router installation

Dear Mahmoud,

For site to site VPN you have to apply the crypto-map on Dialer interface not on physical interface ATM0

interface Dialer1

crypto map

atleast one side you need static public ip to configure site to site VPN

there is no need for subinterface point-topoint configuration 

Thanks

Shanil

Community Member

new cisco 887va Router installation

so many thanks to you shanil

I have in site A (Cisco router 1801 which connected to Internet by leased line and LAN is 10.0.0.0/24)

in site B (Cisco router 887va which connected with 4Mbps ADSL connection and LAN is 10.10.10.0/24)

do you provide me with the simplest way to configure  this vpn and prerequisites?

regards;

Mahmoud

Community Member

new cisco 887va Router installation

Dear Mahmoud,

Hopes both sides you have static ips.

On Cisco 1801

----------------------

---configure isakmp policy----
crypto isakmp policy 20
encr 3des
hash md5
authentication pre-share
group 2

---configure key ,(x.x.x.x would be public ip address of the other end )

crypto isakmp key 0 xxxxxxxxxxxxxxxx address x.x.x.x no-xauth

---configure ipsec policy -transformset----
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac


---configure cryptomap- to tie all the parameters transformset,peer address and acl)
crypto map MY-MAP 5 ipsec-isakmp
set peer x.x.x.x
set transform-set ESP-3DES-SHA
match address MY-ACL


---configure crypto acl-interesting traffic----
ip access-list extended MY-ACL
permit ip 10.0.0.0 0.0.0.255 10.10.10.0 0.0.0.255


---Apply the crypto map on outside interface, if dialer interface apply on dialer interface----
int fa4
ip address y.y.y.y 255.255.255.252
crypto map MY-MAP

The same need to configure the other end 887 router, peer ip and access-list will change as per.

please note that all other parameters used in crypto should be same including the key.

If you have to use internet need to excempt VPN traffic from nating

Hopes this help  ***please rate helpful posts***

Shanil

Community Member

new cisco 887va Router installation

Hi

I have one public ip address ,which interface I can use to configure it whith this public ip?

Community Member

Re: new cisco 887va Router installation

Hi any wan interafce . The cable has to connect to the wan interface or adsl interface and configure the static public ip.

Sent from Cisco Technical Support iPhone App

Community Member

new cisco 887va Router installation

shanilkumar2003 wrote:

Hi any wan interafce . The cable has to connect to the wan interface or adsl interface and configure the static public ip.

Sent from Cisco Technical Support iPhone App

so many thanks to you shanil

I tried to configure this real ip under the dialer interface

but it doesnt work

any help please

Community Member

Re: new cisco 887va Router installation

Hi if its ADSL you have to configure the public static ip on the Dialer only. As below


interface Dialer1
ip address 2.2.2.2 255.255.255.252
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
ppp chap hostname xxxx
ppp chap password xxxx
ppp pap sent-username xxxx password xxxx

***Please rate if helps****
Sent from Cisco Technical Support iPhone App

Community Member

new cisco 887va Router installation

shanilkumar2003 wrote:

Hi if its ADSL you have to configure the public static ip on the Dialer only. As below


interface Dialer1
ip address 2.2.2.2 255.255.255.252
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
ppp chap hostname xxxx
ppp chap password xxxx
ppp pap sent-username xxxx password xxxx

***Please rate if helps****
Sent from Cisco Technical Support iPhone App

I tried this solution before but doesn't worked

and tried to restart and ip routing again but without success

- I notice i got public ip under dialer interface in 62.x.x.x range by negotiation but ISP assigned 84.x.x.x as static real for me so when i use this static it doesn't work because of  differnt subnets.

Community Member

new cisco 887va Router installation

I would speak to your ISP to ensure they have actually configured your connection with the static IP address they provided. I have seen it many times where an order form will provide a static IP address but when the connection is configured by the ISP they fail to actually provide this.

Community Member

new cisco 887va Router installation

James Neilson wrote:

I would speak to your ISP to ensure they have actually configured your connection with the static IP address they provided. I have seen it many times where an order form will provide a static IP address but when the connection is configured by the ISP they fail to actually provide this.

thanks I will check it

Community Member

new cisco 887va Router installation

I checked with my ISP and find that

-my public range is working fine

-and I should use RFC 1483 Routed LLC

so now I have this info

vpi/vci:  8/35

For lan as they said

gateway: 84.x.x.x (public ip)

subnet: 255.255.255.240

Internet connection

Login Type:RFC 1483 Routed

Multiplexing:LLC

ADSL Modulation : Multimode

IP Address:10.84.44.226 (mine)

Subnet Mask: 255.255.255.252

Default Gateway: 10.84.44.225(isp)

how i can configure that on cisco 887va where i tried this configuration on adsl modem (tplink) it works fine

Community Member

Hi,I checked with my ISP and

Hi,

I checked with my ISP and found that my real ip pool is ok .

but i have new info :

vpi/vci:  8/35
Internet connection
RFC 1483 Routed
Multiplexing:LLC

IP Address:10.84.44.226 (mine)
Subnet Mask: 255.255.255.252
Default Gateway: 10.84.44.225(isp)

and for my lan (ISP said to use my real ip  in lan)

gateway: 84.x.x.x
subnet: 255.255.255.240

I tried with ADSL modem (tplink) it worked fine

can you help please to configure cisco 887va

997
Views
22
Helpful
16
Replies
CreatePlease to create content