Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Nexus 7000 Layer 3 QoS

has anyone seen a good Document on LAYER 3 QoS on a Nexus 7000? especially for LLQ

2 REPLIES
Cisco Employee

Nexus 7000 Layer 3 QoS

Hi

As I understand, You Need to implement a custom queuing policies based ACLs to provide LLQ/CWFQ functionality on a N7k.

Bandwidth and priority commands can only be implementing in queueing policies and queueing policies are restricted to system queueing class-maps which match only on CoS values.

To implement what you are trying to perform, you can use a QoS policy to mark the DSCP/CoS value.  The system queuing class-maps will dictate the queue the packet is sent to in outgoing interface. For example:

ip access-list test_ip_af2

  10 permit ip any 172.17.1.10/32

ip access-list test_ip_af4

  10 permit ip any 172.17.1.20/32

ip access-list test_ip_ef

  10 permit ip any 172.17.1.1/32

class-map type qos match-any test_input_ef

  match access-group name test_ip_ef

class-map type qos match-any test_input_af2

  match access-group name test_ip_af2

class-map type qos match-any test_input_af4

  match access-group name test_ip_af4

NOTE: Following system class-maps configuration can be done ony in default VDC and applies to all existong VDC:

class-map type queuing match-any 1p3q4t-out-pq1

    match cos 7

class-map type queuing match-any 1p3q4t-out-q2

    match cos 4

class-map type queuing match-any 1p3q4t-out-q-default

    match cos 1

policy-map type qos test_in

  class test_input_ef

    set cos 7

  class test_input_af4

    set cos 4

  class test_input_af2

    set cos 1

interface Ethernet X/Y

description -=incomming interface=-

service-policy type qos input test_in

interface Ethernet A/B

description -=outgoing interface=-

service-policy type queuing output test_shaping_out

Cisco Employee

Nexus 7000 Layer 3 QoS

Also please consider that each line-card type has it's own system class maps:

http://www.cisco.com/en/US/docs/switches/datacenter/sw/4_2/nx-os/qos/configuration/guide/cpl.html#wp1089686

933
Views
0
Helpful
2
Replies