Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Nexus 7010 NXOS 6.4 EIGRP Redistributing EIGRP

HI Friends,

I am finding difficulties as on Nexus 7010 Switch on my VDC for route redistribution where I have two instance for EIGRP

(1) EIGRP 110 for Internal LAN segment of DC

(2) EIGRP 1 for WAN links connecting to MPLS service provider.

How can redistribute routes of EIGRP 110 to EIGRP 1 ? On Cisco IOS it was quite simple , but in Nexus when I am trying redistribute it is asking for route-map ?

(a) I just want redistribute all my EIGRP 110 routes to  EIGRP 1 so MPLS can see my DC-LAN routes, and

(b) I just want redistribute EIGRP 1 routes in my DC LAN EIGRP 110 process.

(c) I also want filter my default route 0.0.0.0/0 of firewall going towards MPLS EIGRP process i.e. EIGRP 110.

Please help ...am stuck here.

!

router eigrp 110

redistribute eigrp 1 route-map ???

!

!

router eigrp 1

redistribute eigrp 110 route-map ???

!


2 ACCEPTED SOLUTIONS

Accepted Solutions
Hall of Fame Super Blue

Re: Nexus 7010 NXOS 6.4 EIGRP Redistributing EIGRP

Sushil

You need different sequence numbers in your prefix list per entry.

Apart from that it's fine although technically you are only filtering a default route one way but you can use the same prefix list for both if you want.

Edit - see last post on prefix list entry for all routes.

Jon

Community Member

Nexus 7010 NXOS 6.4 EIGRP Redistributing EIGRP

Hi John,

Sorry on that, that was just a typo error on sequence no. But I am using the same prefix list in both eigrp processes , so technicall now no default route 0.0.0.0/0 will be learned from EIGRP 1 and neither be propogated to EIGRP 1 neighbour.

!

prefix-list DC_ROUTE_110 seq 1 deny 0.0.0.0/0

prefix-list DC_ROUTE_110 seq 2 permit 0.0.0.0/32

route-map DC_ROUTE permit 10

match ip address prefix-list DC_ROUTE_110

!

router eigrp 110

default-information originate

redistribute eigrp 1 route-map DC_ROUTE

!

!

router eigrp 1

redistribute eigrp 110 route-map DC_ROUTE

!

14 REPLIES
Hall of Fame Super Blue

Nexus 7010 NXOS 6.4 EIGRP Redistributing EIGRP

Sushil

With Nexus you need to use route maps together with prefix lists so -

a)  ip prefix-list permit 0.0.0.0/0 le 32   <-- this allows all routes

route-map permit 10

match ip address prefix-list

then apply route map within your EIGRP configuration as you show in your post

b) same logic as above

c)  can you clarify exactly what you mean ie. you say in a) and b) you want all routes redistributed between both processes so what exactly are you trying to filter.

Note depending on the answer to c) you may need to modify the prefix lists.

Jon

Community Member

Nexus 7010 NXOS 6.4 EIGRP Redistributing EIGRP

Hi John,

Thanks a lot for response, Point-C , I will detail.

(c) I have firewall External Interface connected to Internet and FIrewall internal interface connecting Nexus, so on my nexus I have default route presented as ip route 0.0.0.0/0 towards firewall as next hop. I have also propogated the this default route in my EIGRP 110, for other EIGRP 110  neighbours to know the default route, so I have reditributed the default route as followed. So here I do want to filter my default route i.e. 0.0.0.0/0 being propogated to EIGRP 1 , so MPLS service provider should not learn any default route from me.

Request if you can suggest some solution for me here.

!

router eigrp 110

default-information originate

redistribute eigrp 1 route-map ???

!

!

router eigrp 1

redistribute eigrp 110 route-map ???

!

Hall of Fame Super Blue

Nexus 7010 NXOS 6.4 EIGRP Redistributing EIGRP

Sushil

Okay for a) then you need to modify the prefix list and add an entry in the prefix list before the permit any line eg.

prefix-list deny 0.0.0.0/0

prefix-list permit 0.0.0.0/0 le 32

Jon

Community Member

Nexus 7010 NXOS 6.4 EIGRP Redistributing EIGRP

Hi John,

Thanks so I am understanding correct than following would be the configuration ?

!

prefix-list DC_ROUTE_110 seq 1 deny 0.0.0.0/0

prefix-list DC_ROUTE_110 seq 1 permit 0.0.0.0/32

route-map DC_ROUTE permit 10

match ip address prefix-list DC_ROUTE_110

!

router eigrp 110

default-information originate

redistribute eigrp 1 route-map DC_ROUTE

!

!

router eigrp 1

redistribute eigrp 110 route-map DC_ROUTE

!

Hall of Fame Super Blue

Re: Nexus 7010 NXOS 6.4 EIGRP Redistributing EIGRP

Sushil

You need different sequence numbers in your prefix list per entry.

Apart from that it's fine although technically you are only filtering a default route one way but you can use the same prefix list for both if you want.

Edit - see last post on prefix list entry for all routes.

Jon

Community Member

Nexus 7010 NXOS 6.4 EIGRP Redistributing EIGRP

Hi John,

Sorry on that, that was just a typo error on sequence no. But I am using the same prefix list in both eigrp processes , so technicall now no default route 0.0.0.0/0 will be learned from EIGRP 1 and neither be propogated to EIGRP 1 neighbour.

!

prefix-list DC_ROUTE_110 seq 1 deny 0.0.0.0/0

prefix-list DC_ROUTE_110 seq 2 permit 0.0.0.0/32

route-map DC_ROUTE permit 10

match ip address prefix-list DC_ROUTE_110

!

router eigrp 110

default-information originate

redistribute eigrp 1 route-map DC_ROUTE

!

!

router eigrp 1

redistribute eigrp 110 route-map DC_ROUTE

!

Hall of Fame Super Blue

Re: Nexus 7010 NXOS 6.4 EIGRP Redistributing EIGRP

Sushil

Apologies but can you just confirm that you have modfiied the prefix list for all routes -

0.0.0.0/32  sgould be  0.0.0.0/0 le 32

Jon

Community Member

Nexus 7010 NXOS 6.4 EIGRP Redistributing EIGRP

Got you...Please confirm.

!

prefix-list DC_ROUTE_110 seq 1 deny 0.0.0.0/32

prefix-list DC_ROUTE_110 seq 2 permit 0.0.0.0/0

route-map DC_ROUTE permit 10

match ip address prefix-list DC_ROUTE_110

!

router eigrp 110

default-information originate

redistribute eigrp 1 route-map DC_ROUTE

!

!

router eigrp 1

redistribute eigrp 110 route-map DC_ROUTE

!

Hall of Fame Super Blue

Nexus 7010 NXOS 6.4 EIGRP Redistributing EIGRP

Sushil

Not quite right. Your prefix list should look like -

prefix-list DC_route_110 deny 0.0.0.0/0

prefix-list DC_route_110 permit 0.0.0.0/0 le 32

Jon

Community Member

Nexus 7010 NXOS 6.4 EIGRP Redistributing EIGRP

Hey Sorry John, seems I was misunderstanding so far....Sorry for it..Sorry for all this confusion.

!

prefix-list DC_ROUTE_110 seq 1 deny 0.0.0.0/0

prefix-list DC_ROUTE_110 seq 2 permit 0.0.0.0/0 Ie 32

route-map DC_ROUTE permit 10

match ip address prefix-list DC_ROUTE_110

!

router eigrp 110

default-information originate

redistribute eigrp 1 route-map DC_ROUTE

!

!

router eigrp 1

redistribute eigrp 110 route-map DC_ROUTE

!

Hall of Fame Super Blue

Nexus 7010 NXOS 6.4 EIGRP Redistributing EIGRP

Sushil

No problem at all.  It now looks correct.

Basically the first entry matches the specifc route only ie. the default route. The second route then matches every single IPv4 address which matches all your routes. This would also match the default route but because you have already denied it in the first line it is not redistributed.

Any other queries just ask.

Jon

Community Member

Nexus 7010 NXOS 6.4 EIGRP Redistributing EIGRP

Hey thanks a lot jon. You realy helped me and guided me here...Cheers..Have great time.

How can I add you to my friend list on Cisco community.

Hall of Fame Super Blue

Nexus 7010 NXOS 6.4 EIGRP Redistributing EIGRP

Sushil

I'll tidy up this thread a bit for others to read.

If you click on my username you should see on the right hand side just under the Actions box an "Add as a friend". Click on that and i should get a request to add you as a friend.

Jon

Hall of Fame Super Blue

Nexus 7010 NXOS 6.4 EIGRP Redistributing EIGRP

Sushil

Just seen request and approved.

Jon

197
Views
0
Helpful
14
Replies
CreatePlease to create content