Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Nexus 7K NX-OS upgradation - Incompatible image error

Hi

We have Nexus 7018 with version

Software

  BIOS:      version 3.22.0

  kickstart: version 4.2(6)

  system:    version 4.2(6)

  BIOS compile time:       02/20/10

  kickstart image file is: bootflash:/n7000-s1-kickstart.4.2.6.bin

   system image file is:    bootflash:/n7000-s1-dk9.4.2.6.bin

Since N7K-M108X2-12L module required version 5.1

we are upgrading to n7000-s1-kickstart.5.2.3a.bin,n7000-s1-dk9.5.2.3a.bin

during show install image system/kickstart impact, we are getting below error,

Compatibility check is done:

Module  bootable          Impact  Install-type  Reason

------  --------  --------------  ------------  ------

     2       yes  non-disruptive          none 

     3       yes  non-disruptive          none 

     4       yes  non-disruptive          none 

     5       yes  non-disruptive          none 

     6       yes  non-disruptive          none 

     9        no             n/a           n/a  Incompatible image

    10        no             n/a           n/a  Incompatible image

This means Supervisor module-1X  N7K-SUP1 is not compatible with version 5.2.3a? which version we can upgrade inoder to support module

N7K-M108X2-12L

I have attached the full output log file.

Pls.suggest. 

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
VIP Super Bronze

Nexus 7K NX-OS upgradation - Incompatible image error

Hi Rajesh,

Correct, you can do everything else, except the module does not operate in XL mode.  So, once you are done with the upgrade, you should be able to use the module.  VPC is just an Etherchannel with multiple 10Gig interfaces.

Good Luck

6 REPLIES
VIP Super Bronze

Nexus 7K NX-OS upgradation - Incompatible image error

Hi

Cisco NX-OS Release 5.0(2) through 5.0(5)Support

Have a look at table-2 in this link:

http://www.cisco.com/en/US/docs/switches/datacenter/sw/5_x/nx-os/release/notes/50_nx-os_release_note.html#wp186822

HTH

New Member

Nexus 7K NX-OS upgradation - Incompatible image error

Hi Reza

This means, present Nexus 7018 with N7K-SUP1 will not support N7K-M108X2-12L ?

N7K-M108X2-12L - require 5.1 and N7K-SUP1 can go upto 5.0(5).

This means we cant have N7K-M108X2-12L module on this nexus switch.

Pls. clarify

New Member

Nexus 7K NX-OS upgradation - Incompatible image error

Hi Reza

Would you pls. calrify N7K-M108X2-12L require 5.1 or 5.0.

If I upgrade NX-OS to 5.0(5) will it support module N7K-M108X2-12L ?

Any EPLD upgrade required along with this?

Rgds

Rajesh

VIP Super Bronze

Nexus 7K NX-OS upgradation - Incompatible image error

Hi,

According to the link I provided, if you upgrade to 5.0(5) then you should be fine provided you have the correct license installed.   Look at the bottom of  table-2, it says:

Requires the Cisco Nexus 7010 Scalable Feature  Package license (N7K-C7010-XL) or the Cisco Nexus 7018 Scalable Feature  Package license (N7K-C7018-XL), depending on the chassis, to enable all  XL-capable I/O modules to operate in XL mode.

HTH

New Member

Nexus 7K NX-OS upgradation - Incompatible image error

Hi Reza

We have only N7K-LAN1K9 license for NX 7018.

Now documentation says - Cisco Nexus 7018 Scalable Feature Package license (N7K-C7018-XL) to enable all XL-capable I/O modules to operate in XL mode.

Incase if we dont have this Feature Package license (N7K-C7018-XL), if we upgrade NX-OS to 5.0(5), module will be recognised and we can use this 10Gig module right ? only what we loose is module will not operate in XL mode.

We can use it for vPC peer link etc. right ?

Pls. clarify.

Rgds

Rajesh

VIP Super Bronze

Nexus 7K NX-OS upgradation - Incompatible image error

Hi Rajesh,

Correct, you can do everything else, except the module does not operate in XL mode.  So, once you are done with the upgrade, you should be able to use the module.  VPC is just an Etherchannel with multiple 10Gig interfaces.

Good Luck

1807
Views
0
Helpful
6
Replies
CreatePlease to create content