Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Nexus 7K NX-OS upgrade error- Incompatible image

Hi,

We got a Nexus 7010 wich software version below

  BIOS:      version 3.22.0

  kickstart: version 5.1(1)

  system:    version 5.1(1)

  kickstart image file is: bootflash:///n7000-s1-kickstart.5.1.1.bin

  system image file is:    bootflash:///n7000-s1-dk9.5.1.1.bin

Since we try to upgrade the software version to n7000-s1-dk9.5.2.1.bin

and run the show  install  all  impact  kickstart  bootflash:n7000-s1-kickstart.5.2.1.bin  system  bootflash:n7000-s1-dk9.5.2.1.bin

Compatibility check is done:
Module  bootable          Impact  Install-type  Reason
------  --------  --------------  ------------  ------
     1       yes      disruptive         reset  Incompatible image
     5       yes      disruptive         reset  Incompatible image
     6       yes      disruptive         reset  Incompatible image
     9       yes      disruptive         reset  Incompatible image
    10       yes      disruptive         reset  Incompatible image

All the line card and supervisor are incompatible.

But I check the release note, it shows N7K-SUP1 supported since ver 4.0(1)

http://www.cisco.com/en/US/docs/switches/datacenter/sw/5_x/nx-os/release/notes/50_nx-os_release_note.html#wp288801

Is there something I miss?!

1 ACCEPTED SOLUTION

Accepted Solutions

Nexus 7K NX-OS upgrade error- Incompatible image

Hi,

What this message is telling you is that an In Service Software Upgrade (ISSU) is not supported and so the impact of the upgrade will be disruptive. If you look at the General Upgrade/Downgrade Caveats in the Cisco Nexus 7000 Series NX-OS 5.2 Release Notes you'll see that ISSU to 5.2(x) is only supported when upgrading from NX-OS release 5.1(1a), 5.1(3) or 5.1(4).

If you don't need ISSU then you can simply do a disruptive upgrade, or if ISSU to NX-OS 5.2 is required, then you should perform an ISSU to one of 5.1(1a), 5.1(3) or 5.1(4) and then upgrade to NX-OS 5.2(1).

As an aside is there any particular reason you've chosen NX-OS 5.2(1)? The NX-OS 5.2 release currently has maintenance releases up to and including NX-OS 5.2(9) and choosing a later release would be preferable. Cisco provide some guidance as to the release in the Minimum Recommended Cisco NX-OS Releases for Cisco Nexus 7000 Series Switches  document.

Regards

2 REPLIES

Nexus 7K NX-OS upgrade error- Incompatible image

Hi,

What this message is telling you is that an In Service Software Upgrade (ISSU) is not supported and so the impact of the upgrade will be disruptive. If you look at the General Upgrade/Downgrade Caveats in the Cisco Nexus 7000 Series NX-OS 5.2 Release Notes you'll see that ISSU to 5.2(x) is only supported when upgrading from NX-OS release 5.1(1a), 5.1(3) or 5.1(4).

If you don't need ISSU then you can simply do a disruptive upgrade, or if ISSU to NX-OS 5.2 is required, then you should perform an ISSU to one of 5.1(1a), 5.1(3) or 5.1(4) and then upgrade to NX-OS 5.2(1).

As an aside is there any particular reason you've chosen NX-OS 5.2(1)? The NX-OS 5.2 release currently has maintenance releases up to and including NX-OS 5.2(9) and choosing a later release would be preferable. Cisco provide some guidance as to the release in the Minimum Recommended Cisco NX-OS Releases for Cisco Nexus 7000 Series Switches  document.

Regards

New Member

Nexus 7K NX-OS upgrade error- Incompatible image

Steve,

Thanks for your reply, and I'll try to upgrade it.

1529
Views
5
Helpful
2
Replies
CreatePlease to create content