Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Nexus EIGRP route filtering.

Hi Friends,

Current Config.

!

prefix-list DC_ROUTE_110 seq 1 deny 0.0.0.0/0

prefix-list DC_ROUTE_110 seq 2 permit 0.0.0.0/0 Ie 32

route-map DC_ROUTE permit 10

match ip address prefix-list DC_ROUTE_110

!

router eigrp 110

default-information originate

redistribute eigrp 1 route-map DC_ROUTE_110

!

!

router eigrp 1

redistribute eigrp 110 route-map DC_ROUTE

!

So following is my observation after implementation.

EIGRP 1 is running with service provider and EIGRP 110 is running within my DC. With above configuration, on EIGRP 110 " redistribute eigrp 1 route-map DC_ROUTE_110" , this is preventing any default route being to get redistribute on EIGRP-110. But I am having chllange as am still learning default route 0.0.0.0/0 from service provider on EIGRP-1 which I dont want at all. How can I prevent my network from learning default route from service provider on EIGRP-1 ? Is there any other mechanism to filter default route being learned from Service Provider ? I also want to filter 192.168.0.0/16 route being learned from service provider on EIGRP-1.

1 REPLY
Hall of Fame Super Blue

Re: Nexus EIGRP route filtering.

Sushil

You need to use a distribute list to filter those routes so you need to define your prefix list as before -

ip prefix-list deny 0.0.0.0/0

ip prefix-list deny 192.168.0.0/16

ip prefix-list permit 0.0.0.0/0 le 32

note you only need the last line if you are receiving other routes from the SP that you want.

Then you need to apply it to the interface connecting to the SP on which you are running EIGRP.

The syntax of the command for this on the Nexus is -

ip distribute-list eigrp prefix-list in

where is the AS you are  filitering routes in.

Jon

184
Views
0
Helpful
1
Replies
CreatePlease login to create content