Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

NHRP Encapsulation failed

Hi Team,

I’ve been interested in learning Dynamic Multipoint VPN (DMVPN). So i tried configuring NHRP between two routers. One as the Hub router with a staic IP and the other is a spoke with dynamic IP. The GRE tunnel is up and i can ping the other end of the tunnel. But my issue is i can't ping any LAN interface on the Spoke router. I enabled debugging on the Hub and i am getting the below message when i tried to ping the LAN IP 192.168.1.253 [Spoke router etherent interafce Ip address]. I am not sure what is the issue, any assistance much appreciated.

Jan 20 04:43:07.964: NHRP: Encapsulation failed for destination 192.168.1.253 out Tunnel1111

Jan 20 04:43:08.784: NHRP: MACADDR: if_in null netid-in 0 if_out Tunnel1111 netid-out 1111

Jan 20 04:43:08.784: NHRP: Checking for delayed event /192.168.1.253 on list (Tunnel1111).

Jan 20 04:43:08.784: NHRP: No node found.

Jan 20 04:43:10.785: NHRP: MACADDR: if_in null netid-in 0 if_out Tunnel1111 netid-out 1111

Jan 20 04:43:10.785: NHRP: Checking for delayed event /192.168.1.253 on list (Tunnel1111).

Jan 20 04:43:10.785: NHRP: No node found.

Please find my config below:

Hub Router:

interface Tunnel1111

ip address 10.0.0.2 255.255.255.252

no ip redirects

ip mtu 1400

ip nhrp authentication xxxx

ip nhrp map multicast dynamic

ip nhrp network-id 1111

ip nhrp holdtime 600

delay 1000

tunnel source Dialer1

tunnel mode gre multipoint

tunnel key 2222

ip route 192.168.1.0 255.255.255.0 Tunnel1111

sh dmvpn

Legend: Attrb --> S - Static, D - Dynamic, I - Incomplete

        N - NATed, L - Local, X - No Socket

        # Ent --> Number of NHRP entries with same NBMA peer

        NHS Status: E --> Expecting Replies, R --> Responding

        UpDn Time --> Up or Down Time for a Tunnel

==========================================================================

Interface: Tunnel1111, IPv4 NHRP Details

Type:Hub, NHRP Peers:1,

# Ent  Peer NBMA Addr Peer Tunnel Add State  UpDn Tm Attrb

----- --------------- --------------- ----- -------- -----

     1  xx.xx.xx.xx        10.0.0.1    UP    4d13h     D

Spoke Router

interface Tunnel0

ip address 10.0.0.1 255.255.255.252

no ip redirects

ip mtu 1400

ip nhrp authentication xxxx

ip nhrp map multicast dynamic

ip nhrp map 10.0.0.2 xx.xx.xx.xx

ip nhrp map multicast xx.xx.xx.xx

ip nhrp network-id 1111

ip nhrp holdtime 600

ip nhrp nhs 10.0.0.2

delay 1000

tunnel source Dialer1

tunnel mode gre multipoint

tunnel key 2222

sh ip nhrp detail

10.0.0.2/32 via 10.0.0.2, Tunnel0 created 4d13h, never expire

  Type: static, Flags: authoritative used

  NBMA address: xx.xx.xx.xx

Thanks

Nachi

1 REPLY

NHRP Encapsulation failed

Hi Guys,

I managed to got it working. I changed the below static route to point to the tunnel destination IP instead of tunnel interface.

ip route 192.168.1.0 255.255.255.0 10.0.0.1

Thanks for your help.

Thanks

Nachi

910
Views
5
Helpful
1
Replies