Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

NLB problems

Hello. I need help.

I have a cluster running windows 2003 server which are in a Catalyst 3750 stack and belong to VLAN 6 named "servers".The Network Load Balancing cluster hosts are connected to the Ethernet stack switch (3750)

which is connected to a centralized Ethernet Routing Switch (Catalyst 4510R)using a interface port-channel. Clients are connected to Catalyst 4510R directly and others layer 2 swichtes Catalyst. I want to deploy Microsoft Network Load Balancing using mode Multicast. How can I do it?. What configuration have I to do in the switches (Catalyst 4510R and 3750)?.

I configurated in Catalyst 4510R:

-----------------------------------

arp 10.60.6.30 03bf.0ac8.c8c8 ARPA

mac-address-table static 03bf.0ac8.c8c8 vlan 6 interface port-channel 1

-------------------------------------

03bf.0ac8.c8c8 is a virtual multicast MAC address that I read in a document about NLB.

But this configuration is wrong.Really I do something bad but I don?t know it.

Also I don?t know if I had to configure something in stack catalyst 3750 or only in catalyst 4510R which do routing.

Thanks

4 REPLIES
Community Member

Re: NLB problems

Hi... I have not worked with Microsoft NLB, but I have worked on a network that required clustered servers using Multicast MAC address connected to Cisco switches. I found that the only way we could make it work was to create static MAC/CAM entries for the Multicast MAC on all switches that need to connect to the clustered hosts. Pain the backside! Furthermore, we also found that we even had to create static ARP entries for the clustered hosts on the Multilayer switches.

Due to the political nature of the network, we had not tried setting up a Multicast tree to see if it could help...

Community Member

Re: NLB problems

Thank you very much for your help. I solved the problem.

Regards

Community Member

Re: NLB problems

Alfredo,

I'm currently faced with the same issue. How did you solve it?

Thanks in advance,

-Brad

Community Member

Re: NLB problems

Excuse me, could you kindly tell me how you went about fixing this problem? Thank you.

296
Views
0
Helpful
4
Replies
CreatePlease to create content