Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

NME-16ES-1G-P

I have a 2811 router. I am trying to get the NME to connect through the router. I have tried just about everything. I can access the switch and the router but I can't get the network that is connected to the switch to go out the router interfaces. I have configured vlan interfaces and sub interfaces on the router.

3 REPLIES

Re: NME-16ES-1G-P

Can you post your running configuration here? Maybe show where the host are connected, their ip address, and their gateway, what network and where these hosts connected to the NME is trying to get to? The NME is a switch module and needs to be configured as if it's an external switch.

Maybe this link will be of some help:

http://www.cisco.com/en/US/products/hw/modules/ps2797/products_feature_guide09186a0080415bae.html

Please rate helpful posts.

New Member

Re: NME-16ES-1G-P

I can post the configuration that I have on there now but it would be one of many. I don't have a set config yet. Right now I am doing a prof of concept.

hostname

!

boot-start-marker

boot system flash:c2800nm-advipservicesk9-mz.124-7.bin

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

!

!

ip cef

!

interface FastEthernet0/0

ip address 192.168.0.1 255.255.255.252

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.1.2 255.255.255.252

duplex auto

speed auto

!

interface GigabitEthernet1/0

ip address 172.1.1.1 255.255.255.0

(I had to assign an address to the G1/0 so I could access the switch portion)

!

interface GigabitEthernet1/0.200

encapsulation dot1Q 200

ip address 10.10.10.1 255.255.255.0

no snmp trap link-status

!

router ospf 1

log-adjacency-changes

network 192.168.0.1 0.0.0.0 area 0.0.0.0

network 192.168.1.2 0.0.0.0 area 0.0.0.0

network 10.10.10.1 0.0.0.0 area 0.0.0.0

!

!

ip http server

no ip http secure-server

!

!

!

!

!

control-plane

!

!

!

voice-port 0/0/0

!

Here is the switch config

! Last configuration change at 17:57:37 UTC Wed May 31 2006

! NVRAM config last updated at 18:00:57 UTC Wed May 31 2006

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Switch

!

!

no aaa new-model

switch 1 provision NME-16ES-1G-P

ip subnet-zero

!

!

!

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface FastEthernet1/0/1

switchport access vlan 200

!

interface FastEthernet1/0/2

!

interface FastEthernet1/0/3

!

interface FastEthernet1/0/4

!

interface FastEthernet1/0/5

!

interface FastEthernet1/0/6

interface Vlan1

no ip address

shutdown

!

interface Vlan200

no ip address

!

ip classless

ip http server

ip http secure-server

!

!

control-plane

--More--

ip classless

ip http server

ip http secure-server

!

!

control-plane

!

!

line con 0

line vty 5 15

!

!

end

Switch#

Switch#

If there is a config that I could follow. I can modify as I need. I just wanted to get the data/voice to go through the router. Thanks for the help.

New Member

Re: NME-16ES-1G-P

It works!!! The switch card has two virtual gig interfaces g1/0 and g1/0/2. I had to put a ip address on the g1/0 in order to access the switch module. I created a vlan with an ip address that was in the same subnet that the ip address of g1/0 was in. I then placed the g1/0/2 and all other switch ports in this vlan. I know "duu" everyone can't be router gods!! I am sure there are cleaner ways to do this without using two ip address. Thanks to Tim.

443
Views
0
Helpful
3
Replies