Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

No DHCP and no mannual config?

 

If a device wants to communicate with another device, and if there is no DHCP server in the network and if the manual configuration of the address is not possible, how will the two devices on the same link communicate?

2 ACCEPTED SOLUTIONS

Accepted Solutions

For IPv4, many DHCP-enabled

For IPv4, many DHCP-enabled devices will auto-configure a 169.254.0.0/16 address when they can't get a DHCP lease. This is enough for them to have basic connectivity on a single subnet for peer-to-peer networking.

For IPv6, all devices will auto-configure an fe80::/16 link-local address which will allow for basic connectivity on the same subnet regardless of whether DHCP is enabled or not. If IPv6 is enabled at all, this option will be available.

I'm happy to hear that. If

I'm happy to hear that. If you found our comments useful, please rate them and mark one of them correct.

14 REPLIES
Bronze

It depends on the device. 

It depends on the device.  PCs will use other broadcast-based applications like NETBIOS.

Switches and routers will use CDP to at least discover one another.

Sounds like this would be a pretty rare situation.  What do you have going on?

Ven Taylor
New Member

Thank you for the reply..!!It

Thank you for the reply..!!

It was helpful

For IPv4, many DHCP-enabled

For IPv4, many DHCP-enabled devices will auto-configure a 169.254.0.0/16 address when they can't get a DHCP lease. This is enough for them to have basic connectivity on a single subnet for peer-to-peer networking.

For IPv6, all devices will auto-configure an fe80::/16 link-local address which will allow for basic connectivity on the same subnet regardless of whether DHCP is enabled or not. If IPv6 is enabled at all, this option will be available.

New Member

Thank you...!!It was helpful

Thank you...!!

It was helpful

I'm happy to hear that. If

I'm happy to hear that. If you found our comments useful, please rate them and mark one of them correct.

New Member

Can you help me with one

Can you help me with one doubt i have, i am designing a network for a organization in packet tracer (for practice). It has 3 locations and each office should have 200 employees with 65% redundancy (For IP address)....i am confused with 65% redundancy term...is this means we need to use CARP protocol...

 

Thanks

CARP, VRRP and HSRP provide

CARP, VRRP and HSRP provide redundancy for individual hosts and gateways, but there's really no concept of a percentage in that. At a guess, I would suggest that it's asking for 65% expansion room on the subnets, so 200*1.65=330 node addresses, but it's hard to tell from the description that you've been given.

New Member

Thanks, I have two

Thanks,

 

I have two departments HR and finance in my office, the finance department (170.10.1.0/24) can access HR (170.10.0.128/25) but the HR cannot access Finance. I have DHCP server (170.10.0.129/28) in HR department for assigning ip to both departments.

I have used two access list

1) one on the inteface facing Finance department as

  permit udp host 0.0.0.0 host 255.255.255.255 eq bootps 
  deny ip any any

2) I have used following access list on the interface which facing to HR department as

    permit icmp any any echo-reply 
    permit icmp any any unreachable

Now i am stuck with the issue that DHCP server is not assigning the ip address to Finance department

could you suggest me what should i add in the access list at the HR interface so that the udp packet (DHCP offer) from server can cross the network to Finance.

i have tried

permit udp host 170.10.0.129 host 255.255.255.255

 

it is not working...can you suggest how to get this done

Thanks

For this, you're going to

For this, you're going to need to make sure your inbound ACLs on both interfaces are agreeing with each other. You're also going to need to make them less specific.

On the inbound ACL facing the Finance network, try this:

permit udp any any eq bootps

On the inbound ACL facing the HR network, go with this:

permit udp any eq bootps any
permit icmp any any echo-reply
permit icmp any any unreachable

After that, because DHCP doesn't cross subnets on its own, you're going to need to configure a helper address on the Finance interface in order to forward DHCP requests to the server.

ip helper-address x.x.x.x

Substitute x.x.x.x with the address of your DHCP server.

New Member

Thank you..!!Do HSRP work on

Thank you..!!

Do HSRP work on vlan?

i have made a topology and in which i have 3 Vlan and i am not able to ping the virtual ip address from any of the hosts in any vlan's. 

Is the configuration for vlan some different than n/w without vlan

 

HSRP works on VLAN interfaces

HSRP works on VLAN interfaces and is very commonly used. Its configuration isn't any different than it is on non-VLAN interfaces.

New Member

Also do it works on

Also do it works on subinterface of a router as an gig0/0.1?

Yes, it works on those too.

Yes, it works on those too.

New Member

Ok,I have two vlans, vlan 100

Ok,

I have two vlans, vlan 100 (170.10.0.0/25) and vlan 200 (170.10.0.128/25)

Vlan 100 is connected to router in interface gig0/0.1 and Vlan 200 is connected to router on interface gig0/0.2

Now consider only for vlan 100

i have a host with ip 170.10.0.1/25 and i have used a virutual ip as 170.10.0.100 and configured both the HSRP routers as 

Router1(config)#int gigabitEthernet 0/0.1
Router1(config-subif)#standby 1 ip 170.10.0.100
Router1(config-subif)#standby 1 priority 200
Router1(config-subif)#standby 1 preempt 
Router1(config-subif)#exit
 %HSRP-6-STATECHANGE: GigabitEthernet0/0.1 Grp 1 state Standby -> Active
Router1(config-subif)#standby 1 track gigabitEthernet 0/1

 

Router2(config)#int gigabitEthernet 0/0.1
Router2(config-subif)#standby 1 ip 170.10.0.100
Router2(config-subif)#standby 1 priority 210
Router2(config-subif)#standby 1 preempt 
Router2(config-subif)#exit
 %HSRP-6-STATECHANGE: GigabitEthernet0/0.1 Grp 1 state Standby -> Active
Router2(config-subif)#standby 1 track gigabitEthernet 0/1

 

Now when i try to ping the virtual ip from my host 170.10.0.1, it gives me request time out.

Are my config right? 

379
Views
8
Helpful
14
Replies