Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

No DSCP packets matched at one end - QoS on Multilink PPP (Bonded T1)

The issue is DSCP is preserved from SiteA to SiteB whereas DSCP marking is not preseved from SiteB to SiteA.

  (Site A) Phone----Cisco 3560 SW----Cisco 1921 Router========(Bonded T1)=========Cisco 1921 Router-----Cisco 2960 SQ---Phone (Site B)

Site A Config (on 1921 Router):==========

controller T1 0/0/0
 cablelength short 110
 channel-group 0 timeslots 1-24
!
controller T1 0/0/1
 cablelength short 110
 channel-group 0 timeslots 1-24
!
!
class-map match-all SiteA-CLASS-VOICE
 match ip dscp ef
!
!
policy-map SiteA-POLICY-VOICE
 class SiteA-CLASS-VOICE
    priority percent 35
!
!
interface Multilink1
 ip address 10.10.10.2 255.255.255.252
 no ip redirects
 no ip unreachables
 ppp multilink
 ppp multilink group 1
 ppp multilink fragment disable
 no cdp enable
 service-policy output SiteA-POLICY-VOICE
!
interface GigabitEthernet0/0
 ip address 192.168.1.49 255.255.255.0
 no ip redirects
 no ip unreachables
 duplex auto
 speed auto
 service-policy output SiteA-POLICY-VOICE
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0:0
 no ip address
 encapsulation ppp
 ppp multilink
 ppp multilink group 1
!
interface Serial0/0/1:0
 no ip address
 encapsulation ppp
 ppp multilink
 ppp multilink group 1
!
!

***************************************************************************************

Site B Config (on 1921 Router):=======

controller T1 0/0/0
 clock source internal
 cablelength short 110
 channel-group 0 timeslots 1-24
!
controller T1 0/0/1
 clock source internal
 cablelength short 110
 channel-group 0 timeslots 1-24
!
!
class-map match-all SiteB-CLASS-VOICE
 match ip dscp ef
!
!
policy-map SiteB-POLICY-VOICE
 class SiteB-CLASS-VOICE
    priority percent 35
 class class-default
    fair-queue
!
!
interface Tunnel1
 no ip address
!
interface Multilink1
 ip address  10.10.10.1 255.255.255.252
 no ip redirects
 no ip unreachables
 ppp multilink
 ppp multilink group 1
 ppp multilink fragment disable
 no cdp enable
 service-policy output SiteB-POLICY-VOICE
!
interface GigabitEthernet0/0
 ip address  10.20.30.1 255.255.255.0
 no ip redirects
 no ip unreachables
 ip flow ingress
 ip flow egress
 duplex auto
 speed auto
 service-policy output SiteB-POLICY-VOICE
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0:0
 no ip address
 encapsulation ppp
 ppp multilink
 ppp multilink group 1
!
interface Serial0/0/1:0
 no ip address
 encapsulation ppp
 ppp multilink
 ppp multilink group 1
!
!

***************************************************************************************

Output of "show policy-map interface Multilink1" on Cisco 1921 Router at SiteB:

====>>>>>>>>>>>>>>>>>

 Multilink1

  Service-policy output: SiteA-POLICY-VOICE

    queue stats for all priority classes:

      queue limit 64 packets
      (queue depth/total drops/no-buffer drops) 0/0/0
      (pkts output/bytes output) 462007/93479526

    Class-map: SiteA-CLASS-VOICE (match-all)
      462007 packets, 93479526 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: ip dscp ef (46)
      Priority: 35% (1075 kbps), burst bytes 26850, b/w exceed drops: 0


    Class-map: class-default (match-any)
      31243043 packets, 4643228349 bytes
      5 minute offered rate 6000 bps, drop rate 0 bps
      Match: any

      queue limit 64 packets
      (queue depth/total drops/no-buffer drops) 0/7/0
      (pkts output/bytes output) 31243036/4431006764

***********************************************************************************************************

Output of "show policy-map interface Multilink1" on Cisco 1921 Router at SiteB:

====>>>>>>>>>>>>>>>>>
 Multilink1

  Service-policy output: SiteB-POLICY-VOICE

    queue stats for all priority classes:

      queue limit 64 packets
      (queue depth/total drops/no-buffer drops) 0/0/0
      (pkts output/bytes output) 0/0

    Class-map: SiteB-CLASS-VOICE (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: ip dscp ef (46)
      Priority: 35% (1075 kbps), burst bytes 26850, b/w exceed drops: 0


    Class-map: class-default (match-any)
      36561971 packets, 31606577408 bytes
      5 minute offered rate 6000 bps, drop rate 0 bps
      Match: any
      Queueing
      queue limit 64 packets
      (queue depth/total drops/no-buffer drops/flowdrops) 0/70746/0/70720
      (pkts output/bytes output) 36491225/31471175701
      Fair-queue: per-flow queue limit 16


******************************************************************************

 

Can anyone figure out what is wrong with this config ?

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions

Hi,You should look at the

Hi,

You should look at the phone and Switch @ Site B to check if the phone is setting the correct DSCP to EF and whether switch is honoring the dscp values marked by the phone.

 

By default Cisco switch has got QOS disabled. you should enable it and using below commands

<config>mls qos

on the port connected to phone

<config>mls qos trust dscp

 

HTH 

 

Hitesh

 

2 REPLIES

Hi,You should look at the

Hi,

You should look at the phone and Switch @ Site B to check if the phone is setting the correct DSCP to EF and whether switch is honoring the dscp values marked by the phone.

 

By default Cisco switch has got QOS disabled. you should enable it and using below commands

<config>mls qos

on the port connected to phone

<config>mls qos trust dscp

 

HTH 

 

Hitesh

 

New Member

I had to enter QoS command on

I had to enter QoS command on trunk port on 2960 Switch at Site B and that solved the problem. Thank you.

141
Views
0
Helpful
2
Replies