Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

No fast- or CEF switching occurring

I have a 3560 switch which has CEF enabled on all routed interfaces. Output from show ip interfaces shows the following:

IP fast switching is enabled

IP CEF switching is enabled

IP CEF switching turbo vector

IP multicast fast switching is enabled

IP multicast distributed fast switching is enabled

IP route-cache flags are Fast, CEF

for Vlan3, Fa0/11, Fa0/24.

However, a show interface stats shows all packets being switched by the processor, zero by the Route cache. My understanding is that CEF and fast-switched packets should show up here. I also see a relatively high utilization on CPU on the IP input process. For example, I see this:

Vlan3

Switch path Pkts In Chars In Pkts Out Chars Out

Processor 8032 544231 5958 777174

Route cache 0 0 0 0

Total 8032 544231 5958 777174

Applicable portions of my current config:

!

version 12.2

no service pad

!

no aaa new-model

ip subnet-zero

ip routing

no ip domain-lookup

!

ip multicast-routing distributed

!

!

!

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

interface FastEthernet0/2

switchport access vlan 3

!

interface FastEthernet0/4

switchport access vlan 3

duplex full

!

interface FastEthernet0/5

switchport access vlan 3

!

interface FastEthernet0/6

switchport access vlan 3

speed 100

no cdp enable

!

interface FastEthernet0/7

switchport access vlan 3

duplex full

!

interface FastEthernet0/11

no switchport

ip address 1.2.3.4 255.255.255.0

!

interface FastEthernet0/24

no switchport

ip address 5.6.7.8 255.255.255.0

ip pim sparse-mode

duplex full

speed 100

!

interface Vlan3

description Order Subnet and Unicast

ip address 9.10.11.12 255.255.255.0 secondary

ip address 13.14.15.16 255.255.255.0

ip pim sparse-mode

!

!

end

I initially concentrated on the multicast portion, since that's the majority of my data, but realized that no packets, not even TCP, were being fast- or CEF switched. Any suggestions would be appreciated.

7 REPLIES
Bronze

Re: No fast- or CEF switching occurring

Hi

Just remembering read somewhere that "locally originated traffics are processes switched"..

but ur case u are mentioning that packets are getting traverse across the switch..???

lets see what experts says..

arun

Re: No fast- or CEF switching occurring

Hi,

Fast Switching is a feature that rely on (Route-Cache). On routers when you enable (Ip route-cache) per interface , its just stores the recent routes used by the router for fast Switching process.

In a Multicast environment, it has the same logic, If you want to enable it, you should configure (IP mroute-cahe) for any pim interface enabled.

verify: (sh ip mroute-cache) after configuring it.

HTH

Mohamed

Silver

Re: No fast- or CEF switching occurring

Try enabling Route-Cache on each interface that you are running (ip route-cache). This will start the cache switching on the interfaces...

New Member

Re: No fast- or CEF switching occurring

Thanks for the responses. As you've seen from my initial output, ip route-cache is already enabled (it's enabled by default so you don't see it in the config), and ip mroute-cache distributed is also enabled on all interfaces. ip mroute-cache distributed is automatically enabled when you enable ip pim *. The only time you'd see ip route-cache or ip mroute-cache in this config is if it were preceded by a "no".

New Member

Re: No fast- or CEF switching occurring

The reason CEF packets weren't showing in "show interface stats" is that they are not included in "Route Cache" output on switch platforms. You can use "ip cef accounting per-prefix" and then "show adjacencies" to see CEF hit counts. In fact, we were not process switching most packets.

Re: No fast- or CEF switching occurring

Hi,

Fine if you solved it, but have point to add:

You said you are not process switching any packet, while at your previous post you also mentioned it's enabled. u are process switching here since you dont manually disabled (mroute-Cache) per the interface.

Its clear from the config output that both (Fast Switching) & (CEF) are operational.

HTH

Mohamed

Silver

Re: No fast- or CEF switching occurring

This is normal. The 3750 doesn't keep statistics for "Distributed Cache", which is what is handling nearly all of these packets.

As long as your CPU stays down, you can be assured the box is doing its job.

413
Views
5
Helpful
7
Replies
CreatePlease to create content