Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

No internet access through ASA 5505

Hi 

Apologies in advance for my lack of knowledge on this subject, I have a cisco ASA 5505 running software version 8.0 (2)

I am attempting to gain a WAN connection for clients on the LAN behind the ASA, the ASA will sit behind the primary router and assigned a external IP from a range on a leased line connection.

Could someone please have a skim over the below config and see if I have missed anything blatantly obvious.

Thank you in advance

 

ASA Version 8.0(2) 
!
hostname ciscoasa
domain-name ciscoasa.domain.com
enable password **********
names
!
interface Vlan1
 description Internal Interfaces
 nameif inside
 security-level 90
 ip address 192.168.11.1 255.255.255.0 
 ospf cost 10
 ospf authentication null
!
interface Vlan2
 description External Interface
 nameif outside
 security-level 0
 ip address 123.456.789.111 255.255.255.240 
 ospf cost 10
 ospf authentication null
!
interface Ethernet0/0
!
interface Ethernet0/1
 switchport access vlan 2
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
 switchport access vlan 12
!
interface Ethernet0/7
 switchport access vlan 12
!
passwd **********
banner motd ***This is a private router - ALL access is logged***
banner motd If you do not have permission to access this router please disconnect now...
boot system disk0:/asa802-k8.bin
ftp mode passive
clock timezone GMT/BST 0
clock summer-time GMT/BDT recurring last Sun Mar 1:00 last Sun Oct 2:00
dns server-group DefaultDNS
 domain-name ciscoasa.domain.com
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object-group network ***********
 network-object 192.168.2.0 255.255.255.0
object-group network **********
 network-object 192.168.20.0 255.255.255.0
object-group network **********
 network-object 192.168.11.0 255.255.255.0
object-group network **********
 network-object 10.10.1.0 255.255.255.0
object-group network **********
 group-object **********
 group-object **********
access-list abcde_splitTunnelAcl standard permit 192.168.11.0 255.255.255.0 
access-list abcde_splitTunnelAcl standard permit 192.168.111.0 255.255.255.0 
access-list inside_nat0_outbound extended permit ip 192.168.11.0 255.255.255.0 object-group ********** 
access-list inside_nat0_outbound extended permit ip object-group Local_Subnets object-group ********** 
access-list inside_nat0_outbound extended permit ip object-group Local_Subnets object-group *********
access-list inside_nat0_outbound extended permit ip 192.168.11.0 255.255.255.0 192.168.1.0 255.255.255.0 
access-list inside_nat0_outbound extended permit ip 192.168.11.0 255.255.255.0 any 
access-list outside_2_cryptomap extended permit ip 192.168.11.0 255.255.255.0 object-group abcde_NETWORK_1 
access-list inside_access_in extended permit ip any any 
access-list inside_access_in_1 extended permit ip any any 
access-list inside_access_out extended permit ip any any 
access-list outside_access_in extended permit ip any any 
access-list outside_1_cryptomap extended permit ip 192.168.11.0 255.255.255.0 192.168.1.0 255.255.255.0 
access-list abcde_access_in extended permit ip any 192.168.2.0 255.255.255.0 
access-list outside_3_cryptomap extended permit ip 192.168.11.0 255.255.255.0 any 
pager lines 24
logging enable
logging asdm informational
logging from-address ciscoasa.domain.com
mtu inside 1500
mtu outside 1500
ip local pool abcde 192.168.11.201-192.168.11.249 mask 255.255.255.0
ip verify reverse-path interface outside
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
icmp permit 192.168.2.0 255.255.255.0 inside
icmp permit any outside
asdm image disk0:/asdm-602.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 192.168.11.0 255.255.255.0
access-group inside_access_in_1 in interface inside
access-group inside_access_out out interface inside
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 123.456.789.111 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
aaa authentication enable console LOCAL 
aaa authentication http console LOCAL 
aaa authentication serial console LOCAL 
aaa authentication ssh console LOCAL 
aaa authentication telnet console LOCAL 
http server enable
http 192.168.111.0 255.255.255.0 inside
http 192.168.2.0 255.255.255.0 inside
http 0.0.0.0 0.0.0.0 outside
http 192.168.11.0 255.255.255.0 inside
snmp-server host outside 192.168.2.0 community public version 2c
no snmp-server location
no snmp-server contact
snmp-server community public
snmp-server enable traps snmp authentication linkup linkdown coldstart
snmp-server enable traps ipsec start stop
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs 
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs 
crypto map outside_map 1 set peer 987.654.321.111 
crypto map outside_map 1 set transform-set ESP-AES-256-SHA
crypto map outside_map 2 match address outside_2_cryptomap
crypto map outside_map 2 set pfs 
crypto map outside_map 2 set peer 987.654.321.222 
crypto map outside_map 2 set transform-set ESP-AES-256-MD5
crypto map outside_map 2 set security-association lifetime seconds 86400
crypto map outside_map 2 set nat-t-disable
crypto map outside_map 3 match address outside_3_cryptomap
crypto map outside_map 3 set peer 987.654.321.333
crypto map outside_map 3 set transform-set ESP-AES-128-SHA
crypto map outside_map 3 set security-association lifetime seconds 14400
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto map inside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map inside_map interface inside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption aes-256
 hash md5
 group 5
 lifetime 86400
crypto isakmp policy 30
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 50
 authentication pre-share
 encryption aes-256
 hash sha
 group 5
 lifetime 86400
crypto isakmp policy 70
 authentication pre-share
 encryption aes
 hash sha
 group 2
 lifetime 86400
no crypto isakmp nat-traversal
crypto isakmp ipsec-over-tcp port 10000 
telnet 0.0.0.0 0.0.0.0 inside
telnet 192.168.11.0 255.255.255.0 inside
telnet 192.168.2.0 255.255.255.0 inside
telnet 0.0.0.0 0.0.0.0 outside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 inside
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd dns 8.8.8.8 interface inside
dhcpd domain ciscoasa.domain.com interface inside
!

threat-detection basic-threat
threat-detection scanning-threat shun except ip-address 192.168.11.0 255.255.255.0
threat-detection scanning-threat shun except object-group Darwen
threat-detection statistics access-list
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny  
  inspect sunrpc 
  inspect xdmcp 
  inspect sip  
  inspect netbios 
  inspect tftp 
!
service-policy global_policy global
ntp server 195.59.148.18 source outside prefer
username admin password Zwm6x2/.rYVMR79L encrypted privilege 15
username 5isecurity password BPjPjI3YdMrP/vTY encrypted privilege 15
username root password 9ld8Dj89hxWRDVjR encrypted privilege 15
tunnel-group 987.654.321.222 type ipsec-l2l
tunnel-group 987.654.321.222 ipsec-attributes
 pre-shared-key *
tunnel-group 987.654.321.111 type ipsec-l2l
tunnel-group 987.654.321.111 ipsec-attributes
 pre-shared-key *
tunnel-group 987.654.321.333 type ipsec-l2l
tunnel-group 987.654.321.333 ipsec-attributes
 pre-shared-key *
prompt hostname context 
Cryptochecksum:**********
: end

3 REPLIES

can you ping this

can you ping this addres

interface Vlan2
 description External Interface
 nameif outside
 security-level 0
 ip address 123.456.789.111 255.255.255.240 

 

from router?

 

can you ping this address from asa?

route outside 0.0.0.0 0.0.0.0 123.456.789.111 

 

 

it looks like internal computers from network

interface Vlan1
 description Internal Interfaces
 nameif inside
 security-level 90
 ip address 192.168.11.1 255.255.255.0 

 

must have access into internet

New Member

Hi I cannot ping 123.456.789

Hi 

I cannot ping 123.456.789.111 from inside 192.168.11.1.

Thanks

 

hi,could you do put the cross

hi,

could you put the cross-connect between router and ASA on E0/0?

interface Ethernet0/1
no switchport access vlan 2

interface Ethernet0/0
 switchport access vlan 2

 

is the default route on ASA correct? it's the same as your vlan 2 IP address. 

try to configure the correct next hop IP and try to ping again.

route outside 0.0.0.0 0.0.0.0 123.456.789.111 1

62
Views
0
Helpful
3
Replies