Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

NO internet connection

all interface are up but i can not connect to interne.

can you help please.

the below is my configurartion.

Router#sh run
Building configuration...

Current configuration : 2408 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
crypto pki trustpoint TP-self-signed-4161185151
enrollment selfsigned
ip-address admission max-nodata-conns 3
subject-name cn=IOS-Self-Signed-Certificate-4161185151
revocation-check none
rsakeypair TP-self-signed-4161185151
!
!
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.0 192.168.1.99
!
ip dhcp pool lan-pool
import all
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
!
vtp domain SKYBB
vtp mode transparent
!
!
archive
log config
hidekeys
!
!
!
bridge irb
!
!
interface ATM0
no ip address
ip policy route-map voip
atm vc-per-vp 64
no atm ilmi-keepalive
pvc 0/38
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
dsl operating-mode auto
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Dot11Radio0
no ip address
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Vlan1
no ip address
bridge-group 1
!
interface Dialer0
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
fair-queue
no cdp enable
ppp authentication chap callin
ppp chap hostname ma@plusdsl.net
ppp chap password 0 rground1
ppp pap sent-username ma@plusdsl.net password 0 round1
ppp ipcp dns request
!
interface BVI1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
!
ip http server
ip http secure-server
ip nat inside source list any interface Dialer0 overload
!
ip access-list extended any
permit ip any any
!
!
!
!
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
!
line con 0
no modem enable
line aux 0
line vty 0 4
login
!
scheduler max-task-time 5000
end

6 REPLIES
VIP Purple

Has Dialer0 managed to get an

Has Dialer0 managed to get an IP address ("show interface Dialer0")?

New Member

HI Philip

HI Philip

I managed to make it work with these commands

no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.0 192.168.1.99
!
ip dhcp pool vlan1
import all
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 212.159.13.49 212.159.13.50
lease 0 12

but the proplem i loose them when i reboot the router and i get these errors

import all
^
% Invalid input detected at '^' marker.

network 192.168.1.0 255.255.255.0
^
% Invalid input detected at '^' marker.

default-router 192.168.1.1
^
% Invalid input detected at '^' marker.

dns-server 212.159.13.49 212.159.13.50
^
% Invalid input detected at '^' marker.

lease 0 12
^
% Invalid input detected at '^' marker.

Press RETURN to get started!

can you help with this please ?

VIP Purple

It sounds like you have a had

It sounds like you have a had IOS version on that router.  If you have a Cisco maintenance contract like a SmartNet I would upgrade the IOS to something a bit more recent.  12.x code is getting pretty old now.  15.x is the mainstream now.

New Member

I have been  using same

I have been  using same configuration before and it was working.

thanks

VIP Purple

Hello,

Hello,

I have made a few adjustments to your configuration (in bold), can you try if you get it to work with these changes ?

Current configuration : 2408 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
crypto pki trustpoint TP-self-signed-4161185151
enrollment selfsigned
ip-address admission max-nodata-conns 3
subject-name cn=IOS-Self-Signed-Certificate-4161185151
revocation-check none
rsakeypair TP-self-signed-4161185151
!
ip cef
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.0 192.168.1.99
!
ip dhcp pool lan-pool
import all
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
vtp domain SKYBB
vtp mode transparent
!
archive
log config
hidekeys
!
bridge irb
!
interface ATM0
no ip address
ip policy route-map voip
atm vc-per-vp 64
no atm ilmi-keepalive
pvc 0/38
encapsulation aal5mux ppp dialer
pppoe-client dial-pool-number 1
!
dsl operating-mode auto
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Dot11Radio0
no ip address
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Vlan1
no ip address
bridge-group 1
!
interface Dialer0
ip address negotiated
ip mtu 1460
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1420
dialer pool 1
dialer-group 1
fair-queue
no cdp enable
ppp authentication chap callin
ppp chap hostname ma@plusdsl.net
ppp chap password 0 rground1
ppp pap sent-username ma@plusdsl.net password 0 round1
ppp ipcp dns request
!
interface BVI1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1420
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip http server
ip http secure-server
!
route-map TO_ISP permit 10
 match ip address any
 match interface Dialer 0
!
ip nat inside source route-map TO_ISP interface Dialer0 overload
!
ip access-list extended any
permit ip 192.168.1.0 0.0.0.255 any
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
!
line con 0
no modem enable
line aux 0
line vty 0 4
login
!
scheduler max-task-time 5000
end

New Member

Hi george

Hi george

I got erro with pppoe-client dial-pool-number 1 and did not work with the other adjustments.

I managed to make it work with these commands

no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.0 192.168.1.99
!
ip dhcp pool vlan1
import all
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 212.159.13.49 212.159.13.50
lease 0 12

but the proplem i loose them when i reboot the router and i get these errors

import all
^
% Invalid input detected at '^' marker.

network 192.168.1.0 255.255.255.0
^
% Invalid input detected at '^' marker.

default-router 192.168.1.1
^
% Invalid input detected at '^' marker.

dns-server 212.159.13.49 212.159.13.50
^
% Invalid input detected at '^' marker.

lease 0 12
^
% Invalid input detected at '^' marker.

Press RETURN to get started!

can you help with this please ?

11
Views
0
Helpful
6
Replies
CreatePlease to create content