Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

No Mac Address on Switch port

Is it possible for a server not to advertise its mac address?

The reason I ask is that we have

a tumbleweed server attatched to our

switch..

The gig port shows up up

however no mac-address is being displayed

when issue the command sh-mac-address int gig 0/3

GigabitEthernet0/3 is up, line protocol is up (connected)

Hardware is Gigabit Ethernet, address is 0018.b985.c403 (bia 0018.b985.c403)

Description: "connection to tumbleweed"

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, media type is 10/100/1000BaseTX

MC5.1#sh mac-address-table interface gigabitEthernet 0/3

Mac Address Table

-------------------------------------------

Vlan Mac Address Type Ports

---- ----------- -------- -----

MC5.1#

At this point..we can not ping the server..but i can ping the gateway of the server from the switch

21 REPLIES

Re: No Mac Address on Switch port

This may be a stupid question, but do you have an IP address on the server? Can you ping it from the switch and then do your "sh mac add int g0/3?"

HTH,

John

HTH, John *** Please rate all useful posts ***
Community Member

Re: No Mac Address on Switch port

yep..we have the ip configured on the server..had them verify configuration

no ping.

Re: No Mac Address on Switch port

You can't ping the server from the switch? Can you ping the server from anything? If not, you won't get an address in your mac table.

HTH,

John

HTH, John *** Please rate all useful posts ***
Community Member

Re: No Mac Address on Switch port

hmm i should be able to get at least a mac-address on the switch..its a layer 2 function..

i am not even getting the mac address

Re: No Mac Address on Switch port

I don't believe your mac address is going to show up in the cam table just because you connect the cable. There needs to be some sort of traffic going to that device, and then it will be added after the address is arp'd for. I could be wrong, but I would fix the "not being able to ping" problem, and your other problem should fix itself.

HTH,

John

HTH, John *** Please rate all useful posts ***

Re: No Mac Address on Switch port

Hi,

the switch is learning the MAC address from frames received on the port.

And there is 5 minutes age timer.

So if your server was not sending any frame within last 5 minutes, you will not see any MAC address on the port.

I'd try to force the server to send some broadcast (Ping form the server should send an ARP request, e.g.).

If doesn't work, I'd suggest checking duplex/speed on your server NIC, cable (might be a cross) and the NIC finally.

BR,

Milan

Hall of Fame Super Gold

Re: No Mac Address on Switch port

Richard

John got it slightly wrong and Milan provides the correction. The switch does not learn the MAC address when something goes to the device. The switch learns the MAC address when something comes from the device.

Milan's advice about trying to get the server to send something is good. If some device in the same VLAN (and same subnet) sends an ARP request (which it should do if you enter the ping command to the server on that device) then the server should respond to the ARP and the switch should learn the MAC address.

If you try the ping and the switch is still not learning the MAC address of the server then I would suggest that you look for why the server is not responding to the ARP request. You should check carefully the configuration of the server: make sure that the IP address is correctly in the subnet and make sure that the mask of the server matches the mask for the subnet.

HTH

Rick

Re: No Mac Address on Switch port

This may be a stupid question, but do you have an IP address on the server? Can you ping it from the switch and then do your "sh mac add int g0/3?"

My original post suggested that the device needs to have some sort of L3 connectivity in order to show up in the table. True that it will learn the address when it "comes from the device", but when the address is arp'd for, it floods the switch to see who owns it. When it gets a response, it will add it to the mac table. Therefore, you're sending something TO the device, and the device then sends something in return having the switch learn the mac address. I wouldn't say that I was slightly wrong; it's all how you look at it.

Either way, without pointing fingers, the device needs to be able to communicate with other devices for the switch to add it to the table.

John

HTH, John *** Please rate all useful posts ***
Hall of Fame Super Gold

Re: No Mac Address on Switch port

John

I do not want to be overly picky - but the switch learns nothing when it sends. It only learns when the device sends.

Your position is basically that if you send an ARP then the device should respond and the switch will learn the MAC. But the switch does not learn anything from sending, it only learns when the device sends. So from my perspective to say that the switch learns when you send is slightly wrong (not entirely wrong but not quite right).

HTH

Rick

Re: No Mac Address on Switch port

Rick,

I understand where you are coming from, but it almost sounds like you're saying:

If I connect a new system into the switch, and I ping that new system from another device that is connected into the switch, I'll never see that new system unless I go to the new system and ping from it outbound. That's not the case.

The switch will then arp for the device, and the device will respond to the system that is requesting the response. I'm not seeing where I'm incorrect in this, other than maybe we are explaining this two different ways and coming to the same conclusion.

John

HTH, John *** Please rate all useful posts ***
Hall of Fame Super Gold

Re: No Mac Address on Switch port

John

Tell me how the switch learns when you send the ARP request. Do not tell me how it learns from the ARP response, but tell me how it learns while it is sending the request.

It is a fundamental concept of layer 2 switching that the switch looks at incoming frames, examines the source MAC address, and places the source MAC address in the MAC address table (or CAM) associated with the incoming port. There is no other way that the switch learns MAC addresses. To say that the switch learns when you send the ARP request is to mis-represent this concept.

HTH

Rick

Re: No Mac Address on Switch port

You're correct, BUT you leave out the part that when the switch receives a frame for an unknown destination, it floods out all ports to find the destination. When the destination responds, it adds the learned mac address to the table creating communication between those two hosts.

Again, the server that he's having problems with does NOT have to be the one to send traffic for the mac address to be learned. It will be learned as long as L3 is working.

HTH,

John

HTH, John *** Please rate all useful posts ***
Hall of Fame Super Gold

Re: No Mac Address on Switch port

John

Flooding to an unknown destination has nothing to do with how the switch learns MAC addresses. It may help with how we get the server to send something. But flooding to unknown destination does not, by itself, help the switch learn the MAC address.

And you paint yourself further into a corner when you say:"the server that he's having problems with does NOT have to be the one to send traffic for the mac address to be learned". In fact the ONLY way the switch will ever learn the MAC address is for the server to send something.

You seem to be starting from the point of how can we get the server to send something (respond to ARP) and then confusing how we ask the server to do something with what happens IF the server does respond.

[edit] I am not saying that the server has to be the one that first initiates traffic. But I am saying that the only way that the switch will learn the MAC address is when the server DOES send something. It does not matter at all what we send to the server. The only way the switch learns the MAC address is when the server sends something to the switch.

HTH

Rick

Re: No Mac Address on Switch port

Rick

We're talking about exactly the same thing, but we're not conveying it the same way.

Here's a link that I found (because I was questioning what I was saying):

http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.2SX/configuration/guide/layer2.html#wp1020399')">http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.2SX/configuration/guide/layer2.html#wp1020399

So yes, the switch learns from the source address, but in one of my posts above I did say that they should be able to ping from another server and, when the server replies, the mac address would be added, therefore fixing the problem with the missing mac address on that port. They still need to get the L3 fixed.

Have a good day,

John

HTH, John *** Please rate all useful posts ***
Hall of Fame Super Gold

Re: No Mac Address on Switch port

John

I have looked at the link that you posted and here is the very first sentence:"The address table is built by using the source address of the frames received."

Everything else was about how we might get the destination station to send something. The only way the switch learns the MAC is when the host on the port sends something. To say anything different is to be at least slightly wrong.

HTH

Rick

Community Member

Re: No Mac Address on Switch port

this has turned into a very good thread..

Here is the config on the switch

10.1.13.30

255.255.252.0

10.1.12.1

Here is the config for the port it is connected to

interface GigabitEthernet0/3

description "connection to tumbleweed"

switchport access vlan 12

speed 100

duplex full

there is a trunk back to the router

this is the config on the router

interface FastEthernet0/0.12

encapsulation dot1Q 12

ip address 10.1.14.3 255.255.254.0 secondary

ip address 10.1.12.3 255.255.254.0

no snmp trap link-status

standby 12 ip 10.1.12.1

standby 12 ip 10.1.14.1 secondary

standby 12 preempt

the only issue i see is diff. subnet mask.

Hall of Fame Super Gold

Re: No Mac Address on Switch port

Richard

It is a little ambiguous where this comes from:

10.1.13.30

255.255.252.0

10.1.12.1

I would assume that it is the address of the management interface for the switch, its mask, and its default gateway. Can you confirm that (or providing the configuration detail of it might be even better)?

The apparent mismatch in mask between the switch and the router may or may not be a problem. They both describe an address space that starts at 10.1.12.0 and extends through 10.1.15.255. We would need some additional details, especially of how hosts in the VLAN were configured to know if the mask is part of the problem.

The main thing that we do not have yet is the config details of the server. Can you get the server folks to provide the output of ipconfig (or similar command if the server is not Windows)?

The previous suggestion about checking for possible mismatch in speed or duplex is a good suggestion.

If attempts to get the server MAC address by ping have not been successful, you might try something different to see if we can get it. If the server folk would disable the NIC/interface and then re-enable it, then the server might send a gratuitous ARP from which the switch might learn the MAC. Or perhaps having the server attempt to ping to some destination would cause it to send a frame to the switch.

HTH

Rick

Re: No Mac Address on Switch port

Is the 10.1.13.30 the address for the server? If so, it should be changed to 10.1.12.30.

HTH,

John

HTH, John *** Please rate all useful posts ***
Hall of Fame Super Gold

Re: No Mac Address on Switch port

What's the IP config of the server?

What is the configuration for VLAN 12 on the switch?

Has this Tumbleweed server ever worked before? If so, what changes were done that broke it?

Can you try the command "sh controller ethernet GigabitEthernet0/3"?

Thanks.

Community Member

Re: No Mac Address on Switch port

well it turned out to be a server issue..we think..

we got a separate hub....placed a laptop on it and the server...

the laptop was able to ping the server

so we placed the laptop on the switchport with the config of the server

10.1.13.30

255.255.252.0

10.1.12.1

and the switch config being

interface Vlan1

ip address 10.1.1.35 255.255.255.0

no ip route-cache

!

ip default-gateway 10.1.1.1

and WE WERE able to ping the laptop

Community Member

A possible consideration:

A possible consideration:

You will need to verify the configuration of both the server and the VLAN gateway. If the subnet mask does not match then the ARPs will not be sent to the correct address. If the server receives a packet addressed to an address that is not it's address or it's broadcast address (based on the subnet mask) it will ignore the packet and therefore not respond to ARP requests. Without that response, the CAM table will not be updated.

13137
Views
0
Helpful
21
Replies
CreatePlease to create content