Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

No matches on priority and enhanced classes on ppp multilink

Hi

Appreciate some advise on one.  I have a ppp multilink with QoS applied however I do not see any matches apart from in the standard class.  The router is a 10k PE router running engineering special of 12.0-30 I have tried the following with no success:

- removed the QoS and reapplied

- created new QoS policy

- created new Class-maps

- i have tried configuring priority using "priority 128" and also "priority with police" as it should be on a 10k to use pxf at line rate

- I have bounced the multilink

- I have deleted the multilink and recreated

- I have deleted the multilink and recreated new multilink with different number

I have confirmed with verbose cache flow that traffic is reaching CE router marked as EF but if I ping the CE attached from within the vrf on another PE I never see any matches in the premium or enhanced classes outbound from the egress PE.  All the traffic is falling within either standard or class default as show on "show policy-map int" and on a "show hardware pxf interface".

Any ideas appreciated I think I am hitting bug but can not see anything on bug tool kit. Below is config in questions:

class-map match-any PREMIUM

  match  dscp 46

class-map match-any ENHANCED1

  match ip dscp 34  36  38

class-map match-any ICG_STANDARD

  match ip dscp 10  12  14

policy-map POLICYOUT

class PREMIUM

priority

    police 128000 16000 24000 conform-action transmit exceed-action drop violate-action drop 

class ENHANCED1

    bandwidth 256

    random-detect dscp-based

    random-detect dscp 34 22 66 1

    random-detect dscp 36 14 44 1

    random-detect dscp 38 7 22 1

  class STANDARD

    bandwidth 1533

    random-detect dscp-based

    random-detect dscp 10 171 513 1

    random-detect dscp 12 103 342 1

    random-detect dscp 14 52 171 1

!

interface Multilink1

ip vrf forwarding CUSTOMER

ip address 192.168.1.1 255.255.255.252

no ip redirects

no ip directed-broadcast

no ip proxy-arp

ip pim sparse-mode

ppp multilink

ppp multilink fragment-delay 8

ppp multilink interleave

multilink-group 3002231

service-policy input POLICYIN

service-policy output POLICYOUT

end

!

interface Serial3/0/1.1/3/5/1:0

no ip address

no ip directed-broadcast

encapsulation ppp

ppp multilink

multilink-group 1

end

Everyone's tags (5)
5 REPLIES
Hall of Fame Super Gold

Re: No matches on priority and enhanced classes on ppp multilink

Just to begin with, since you have a single interface, why are you using MLPPP ?      

New Member

Re: No matches on priority and enhanced classes on ppp multilink

Hi, thanks for responding. This is to allow us to add further serials as bandwidth upgrade at a later date with no service disruption I believe.. I will have to configure without the multilink if I am unable to get the other classes to match.

Hall of Fame Super Gold

Re: No matches on priority and enhanced classes on ppp multilink

Yes I would start without multilink first and then provide the various show output that you mentioned, as well the show interface for that one.

New Member

Re: No matches on priority and enhanced classes on ppp multilink

Got to the bottom of this. The premium had been configured with 'match dscp 46' I amended to 'match ip dscp 46' and all working.

Adding the 'ip' to match means it is specific to ipv4. If not used (like it was originally configured) it should match both ipv4 and ipv6 but this was not happening. Smells like a bug

Thanks

Sent from Cisco Technical Support iPad App

Super Bronze

Re: No matches on priority and enhanced classes on ppp multilink

Disclaimer

The  Author of this posting offers the information contained within this  posting without consideration and with the reader's understanding that  there's no implied or expressed suitability or fitness for any purpose.  Information provided is for informational purposes only and should not  be construed as rendering professional advice of any kind. Usage of this  posting's information is solely at reader's own risk.

Liability Disclaimer

In  no event shall Author be liable for any damages whatsoever (including,  without limitation, damages for loss of use, data or profit) arising out  of the use or inability to use the posting's information even if Author  has been advised of the possibility of such damage.

Posting

I'm unfamiliar with the 10K series, but was just wondering whether any type of "trust" has to be configured on ingress interfaces (similar to 6500s).

273
Views
0
Helpful
5
Replies
CreatePlease to create content