Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

No multicast Registration message received at the RP

Hi

I have 3 routers, in series, configured for Auto-RP SM, with two hosts directly connected at each end. The hosts can ping end-end and each router has the correct RP info.

Now, when I ping from the source to some multicast address I see the expected results at the RP i.e. the Register message and the corresponding (S,G) and (*,G) entries.

The problem I have is when I repeat this process using VLC media player to stream a video to a multicast address. I do not receive the (S,G) entry or the Register message at the RP - I only see a Join/Prune message and only have a (*,G) entry.

Can someone please explain why I do not get this expected Register message and why there is no (S,G)entry???

This is driving me crazy!

Thank you very much

STEP1 - Send a multicast ping (224.2.2.2) from the source.

STEP2 - Check the RP has a (*,G) entry and a (S,G) entry

R4#sh ip mroute

(*, 224.2.2.2), 00:00:11/stopped, RP 150.1.4.4, flags: SP

Incoming interface: Null, RPF nbr 0.0.0.0

Outgoing interface list: Null

(171.68.37.122, 224.2.2.2), 00:00:12/00:02:47, flags: P

Incoming interface: FastEthernet0/1, RPF nbr 171.68.28.137

Outgoing interface list: Null

STEP 3 - Check the RP debugs to see the register message from the DR to the RP.

R4#debug ip pim

*Mar 1 00:45:44.967: PIM(0): Building Periodic Join/Prune message for 224.2.2.2

R4#

*Mar 1 00:45:47.255: PIM(0): Received v2 Register on FastEthernet0/1 from 171.68.28.189

*Mar 1 00:45:47.255: (Data-header) for 171.68.37.122, group 224.2.2.2

*Mar 1 00:45:47.255: PIM(0): Send v2 Register-Stop to 171.68.28.189 for 171.68.37.122, group 224.2.2.2

STEP4 - Repeat using VLC to multicast a video stream from the source this time

STEP5 - Check the RP has a (*,G) entry and a (S,G) entry. THERE IS NO (S,G) ENTRY !!!!!!!

R4#sh ip mroute

(*, 224.3.3.3), 00:14:26/00:02:51, RP 150.1.4.4, flags: S

Incoming interface: Null, RPF nbr 0.0.0.0

Outgoing interface list:

FastEthernet0/1, Forward/Sparse, 00:14:26/00:02:51

STEP6 - Check the RP debugs to see the register message from the DR. THERE IS NO REGISTER MESSAGE !!!!!!!!!!!

R4#

*Mar 1 00:49:06.147: PIM(0): Received v2 Join/Prune on FastEthernet0/1 from 171.68.28.137, to us

*Mar 1 00:49:06.147: PIM(0): Join-list: (*, 224.3.3.3), RPT-bit set, WC-bit set, S-bit set

*Mar 1 00:49:06.147: PIM(0): Update FastEthernet0/1/171.68.28.137 to (*, 224.3.3.3), Forward state, by PIM *G Join

R4#

1 REPLY
Cisco Employee

Re: No multicast Registration message received at the RP

Walter,

VLC sets the TTL to 1 by default. Make sure you increase that value so that traffic can propagate end to end.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
227
Views
0
Helpful
1
Replies
CreatePlease to create content