Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

No network on Computer - 2 routers, 1 none CISCO router.

Hi guys!

I hope someone can help me on this.
First some information about what hardware i got.
I got a Cisco Router 860VAE, i got no console cable(so i'm connected to telnet), i got a home router too(Got it from my ISP).

I'm using my router i got from my ISP to the television so i can't just remove it.. anoying..
I was getting the Cisco router because i'm studying Cisco CCNA at my school(first year) and i thought it could be cool to make NetFlow

The router i got from my ISP is not advanced at all so not many options here. Anyway it use the IP range 10.0.0.0/8
Then my CISCO router use the ip range 192.168.1.0/24

The problem is that i can't get connection to the internet from my computer(I know...)

Let me show my running-config(remember I'm NEW):

Current configuration : 2500 bytes
!
! Last configuration change at 18:04:48 UTC Wed Jan 15 2014 by admin
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no logging buffered
enable secret 4 tnhtc92DsfdXBhelxjLWJy3243i4ntXrpb4RdfFmfqY
!
no aaa new-model
wan mode ethernet
!
!
!
ip dhcp pool ccp_pool
import all
network 192.168.1.0 255.255.255.0
dns-server 8.8.8.8 8.8.4.4
!
!
!
!
ip flow-cache timeout active 1
ip name-server 8.8.8.8
ip name-server 8.8.4.4
ip cef
no ipv6 cef
!
!
!
!
!
username admin privilege 15 secret 4 lUgFIkgcrt4SYXMq7jZtxq52lwdfgkj238
!
!
controller VDSL 0
shutdown
!
!
!
!
!
interface Loopback0
ip address 11.0.0.1 255.255.255.0
ip flow ingress
ip flow egress
!
interface Loopback1
no ip address
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
!
interface Ethernet0
no ip address
ip flow ingress
ip flow egress
shutdown
!
interface FastEthernet0
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
switchport access vlan 2
no ip address
spanning-tree portfast
!
interface GigabitEthernet0
description $ETH-WAN$
ip address 10.0.0.1 255.0.0.0
ip flow ingress
ip flow egress
duplex auto
speed auto
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
ip flow ingress
ip flow egress
!
interface Vlan2
no ip address
ip flow ingress
ip flow egress
!
interface Dialer0
no ip address
ip flow ingress
ip flow egress
!
router rip
version 2
network 10.0.0.0
network 192.168.1.0
no auto-summary
!
ip default-gateway 10.0.0.100
ip forward-protocol nd
ip http server
ip http authentication local
no ip http secure-server
ip flow-capture vlan-id
ip flow-export source Vlan1
ip flow-export version 9
ip flow-export destination 192.168.1.3 9991
!
ip route 0.0.0.0 0.0.0.0 10.0.0.100
ip route 10.0.0.0 255.0.0.0 GigabitEthernet0
ip route 192.168.1.0 255.255.255.0 Vlan1
!
mac-address-table aging-time 15
!
snmp-server community public RW
snmp-server community publics RO
snmp-server ifindex persist
snmp-server enable traps config
snmp-server host 10.0.0.3 version 2c public
!
control-plane
!
banner login ^C** CISCO **^C
!
line con 0
no modem enable
line aux 0
line vty 0 4
exec-timeout 60 0
password cisco
logging synchronous
login local
transport input telnet
!
scheduler allocate 60000 1000
!
end


I've not CHANGED anything!
Some of it was just guesswork..

When i try to PING googles DNS(IP: 8.8.8.8) from the router i get
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/39/40 ms

When i try to PING googles DNS from my own computer i get
Request timed out.
Request timed out.
Request timed out.


My CISCO router ip: 192.168.1.1(vlan1) 10.0.0.1(gigabitethernet/WAN)
My ISP router ip: 10.0.0.100
My computer ip: 192.168.1.3 Gateway: 192.168.1.1

Trying to make a Topology of text MY ISP -> ISP Router -> Switch -> CISCO Router -> My Computer

It's not like i can configure RIP on my ISP router so..? And BTW, my cisco router only support RIP as a routing protocol
So what do i do?

Everyone's tags (6)
1 ACCEPTED SOLUTION

Accepted Solutions

Re: No network on Computer - 2 routers, 1 none CISCO router.

You'll need to configure nat on the Cisco. I'm assuming that the ISP router connects to G0 on the Cisco. The ISP router doesn't know about your 192.168.1.0/24 subnet, and you probably can't nat multiple subnets in their router anyway. You'll need to nat with the Cisco to the 10.0.0.0/8 address on the Cisco side.

access-list 100 permit ip 192.168.1.0 0.0.0.255 any

ip nat inside source list 100 interface g0 overload

int g0

ip nat outside

int vlan 1

ip nat inside

Get rid of these:

ip route 10.0.0.0 255.0.0.0 GigabitEthernet0

ip route 192.168.1.0 255.255.255.0 Vlan1

You don't need them because these two subnets are going to be seen as connected routes.


You're also going to need to add a default router to your dhcp pool:

ip dhcp pool ccp_pool

default-router 192.168.1.1

And you can get rid of this line as well:

ip default-gateway 10.0.0.100


HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
16 REPLIES

Re: No network on Computer - 2 routers, 1 none CISCO router.

You'll need to configure nat on the Cisco. I'm assuming that the ISP router connects to G0 on the Cisco. The ISP router doesn't know about your 192.168.1.0/24 subnet, and you probably can't nat multiple subnets in their router anyway. You'll need to nat with the Cisco to the 10.0.0.0/8 address on the Cisco side.

access-list 100 permit ip 192.168.1.0 0.0.0.255 any

ip nat inside source list 100 interface g0 overload

int g0

ip nat outside

int vlan 1

ip nat inside

Get rid of these:

ip route 10.0.0.0 255.0.0.0 GigabitEthernet0

ip route 192.168.1.0 255.255.255.0 Vlan1

You don't need them because these two subnets are going to be seen as connected routes.


You're also going to need to add a default router to your dhcp pool:

ip dhcp pool ccp_pool

default-router 192.168.1.1

And you can get rid of this line as well:

ip default-gateway 10.0.0.100


HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Re:No network on Computer - 2 routers, 1 none CISCO router.

Firs tconfigure nlr (network layer reachibility)
From cisco to isp router
And cisco to your desktop

Then create dhcp pool and with gw , dns
Then nat the pool as described on cisco or isp router

Make sure isp router reaches to your desktop and vice versa over cisco

Thdn you should be good




Sent from Cisco Technical Support Android App

New Member

No network on Computer - 2 routers, 1 none CISCO router.

Firs tconfigure nlr (network layer reachibility)?

     I'm not in to this? Do you just mean configure interface?

And my FastEthernet is L2 switch.

conf t

     interface vlan1

          ip address 192.168.1.1 255.255.255.0

          no shutdown

     interface gigabitethernet0

          ip address 10.0.0.99 255.0.0.0

          no shutdown
     ip route 0.0.0.0 0.0.0.0 10.0.0.100

     router rip

          version 2

          network 192.168.1.0

          network 10.0.0.0

          no auto-summary

     ip dhcp pool classc_pool

          network 192.168.1.0 255.255.255.0

          dns-server 8.8.8.8

          default-router 192.168.1.1

     service dhcp

     access-list 100 permit ip 192.168.1.0 0.0.0.255 any

     ip nat inside source list 100 interface gigabitethernet0 overload

     interface gigabitethernet0

          ip nat outside

     interface vlan1

          ip nat inside

So my Config could look like this?

Anything i need to add?

New Member

No network on Computer - 2 routers, 1 none CISCO router.

are you sure your subnet is classful?

     interface gigabitethernet0

          ip address 10.0.0.99 255.0.0.0

you have to match the subnet with your isp router.

i d use /24 instead of /8 on both devices

yeah with NLR , i mean configure interface IP addresses, do simple connection from p2p links

ping 10.0.0.100 source 10.0.0.99

ping desktop source vlan1

New Member

No network on Computer - 2 routers, 1 none CISCO router.

My ISP router got the IP 10.0.0.100 255.0.0.0

If i use the same subnet on both my routers the cisco router won't work as a router but as a switch or something(Can't track anything in netflow except like 20 bits..)

So i would happy if my cisco router and my ISP router can be on 2 different net and i still can connect to the internet from my desktop

Cisco Employee

Re: No network on Computer - 2 routers, 1 none CISCO router.

Oliver,

As per the very good suggestion made on the above post , Your Cisco wouldn't be on the same network. Cisco is now on the 192.168.1.0/24 network.

As i assumed the setup :-

TV(2)----------------------{modem}

Cisco(1)--------------(1)(2){modem-------Telco

there are two ways to establish it, one has been suggested by John and other is as follow:-

As i am seeing your router can support DSL and in case if you provider is giving DSL modem , you can remove the modem and plug the line directly to the Cisco and configure the DSL controller.

controller VDSL 0
no shut

operating mode auto

interface ATM0
no ip address
no shutdown
no atm ilmi-keepalive


Interface atm0.1 point-to-point

pvc 0/32

pppoe-client dial-pool-member 1    ------Please hit question mark in case this syntax is not valid(depends on the IOS ver)

Interface dialer 1

Encapsulation ppp

ip nat outside

dialer pool 1

dialer group 1

ppp authentication pap chap callin

ppp chap hostname

ppp chap password

Ip route 0.0.0.0 0.0.0.0 dialer 1

interface vlan 1

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip nat inside source list 100 interface dialer 1 overload

You can use the same access-list above.

3. Now, you need to connect the TV to any of the switch port of the cisco and i am hoping that TV will fetch IP dynamically.

4. Once you will connect the Computer , it will fetch IP address dynamically from the Pool and it should work good.

5. In case if there is any issue with the TV, then you need to speak to your provider , if they suggest not to use cisco due to any properitery reasons , then you always need to use the configuration provided above by john.(As there is no other way to use Dual nat).

THis way you configure both your devices on same subnets and i am hoping everything will be good to go.

In case if you feel any problem , Please share show tech support output from the router.

CLI show tech-support.

-Ashish Arora

New Member

No network on Computer - 2 routers, 1 none CISCO router.

Okay thanks i'll try to remove my ISP router.

But as i understand it should be possible to have both routers if you just configure NAT on the cisco router?

No network on Computer - 2 routers, 1 none CISCO router.

Oliver,

From the Cisco router, can you ping the ISP router on the 10.0.0.100 address? If so, you can do what Ashish is stating or my original post with natting on the Cisco router. If you can't hit the 10.0.0.100, that's going to be a problem that you'll need to figure out first. You could also change your Cisco interface to get dhcp from the ISP router:

int g0/0

ip address dhcp

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Re: No network on Computer - 2 routers, 1 none CISCO router.

Hi John.

Yes i could ping the ISP router(10.0.0.100) from my cisco router before i reset my router

I just couldn't ping it from my computer.

@all

I've not tried any of the config yet i got from you. I'll try it as soon i'm coming home

My plan is to make a startup-config and load it from an USB - So i'll configure everything. Is that a stupid idea?

So actually a totally fresh starup-config. If anyone want to make one i'll be happy(That match my cisco router and ISP router). Do not feel any pressure I'll proporly edit something myself

Re: No network on Computer - 2 routers, 1 none CISCO router.

I don't think creating a new startup config is necessary. If you can ping the ISP router from your router, and you can ping your router from the PC that's attached to it, half of the config is already done. You just need to tweak a few settings and then save that as your startup.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Re: No network on Computer - 2 routers, 1 none CISCO router.

Hi John.

Problem is i already did reset my router I was too fast there. I thought my config was too confusing

Cisco Employee

Re: No network on Computer - 2 routers, 1 none CISCO router.

Oliver,

Nice suggestion by John.

Also, Can you please log the session in the putty(go to change settings >> logging>>save file.txt) and collect output of show run and share it here.

I want to see if there is any configuration mismatch in it.

* Please make sure you are able to ping the next hop form the cisco to make the things more better for us to isolate it.

THank you

Ashish

New Member

Re: No network on Computer - 2 routers, 1 none CISCO router.

Well Ashish that was a good idea.

One problem is that i'm at work and i won't be home before 9 PM(Cest +01.00)

And yes, i am allowed to do some private stuff at work

New Member

Re: No network on Computer - 2 routers, 1 none CISCO router.

I did not have time to configure the router today because i need an USB flash drive or a console cable

I will borrow an USB flash drive from work tommorow, so my configuration will begin there!

If anyone has any other ideas of what i could config(other then already posted on this forum) then please leave a comment

- I'll track my config tommorow and post it here too

New Member

No network on Computer - 2 routers, 1 none CISCO router.

It worked!

I did a reset of my router and loaded this conf:

conf t

     interface vlan1

          ip address 192.168.1.1 255.255.255.0

          no shutdown

     interface gigabitethernet0

          ip address 10.0.0.99 255.0.0.0

          no shutdown
     ip route 0.0.0.0 0.0.0.0 10.0.0.100

     router rip

          version 2

          network 192.168.1.0

          network 10.0.0.0

          no auto-summary

     ip dhcp pool classc_pool

          network 192.168.1.0 255.255.255.0

          dns-server 8.8.8.8

          default-router 192.168.1.1

     service dhcp

     access-list 100 permit ip 192.168.1.0 0.0.0.255 any

     ip nat inside source list 100 interface gigabitethernet0 overload

     interface gigabitethernet0

          ip nat outside

     interface vlan1

          ip nat inside

Cisco Employee

No network on Computer - 2 routers, 1 none CISCO router.

Oliver,

Correct your configuration is correct and you can use the same

Hope you will mark this thread as marked and rate your experience.

-Ashish

564
Views
11
Helpful
16
Replies
CreatePlease to create content