Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

No packets matched by QoS CBWFQ Policy

Please please please...

Could someone offer me some advice on the following configuration?

I have a 3640 router with an ADSL interface, configured as part of a dialer interface. As you can see from the "show policy interface" output, no packets are matched, and hence the traffic from subnet 10.10.200.0 is not prioritised.

Can you tell me where I may be going wrong?

Your help is most graciously appreciated!! ;-)

Best wishes

Hal

class-map match-any voip-internal

description match voip traffic from voip subnet

match access-group 100

policy-map voip-adsl

class voip-internal

priority 56

class class-default

fair-queue

Interface dialer 2

service-policy output voip-adsl

access-list 100 permit ip 10.10.200.0 0.0.0.255 any

3640_1#show policy-map int dial2

Dialer2

Service-policy output: voip-adsl

Class-map: voip-internal (match-any)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: access-group 100

0 packets, 0 bytes

5 minute rate 0 bps

Queueing

Strict Priority

Output Queue: Conversation 136

Bandwidth 56 (kbps) Burst 1400 (Bytes)

(pkts matched/bytes matched) 0/0

(total drops/bytes drops) 0/0

Class-map: class-default (match-any)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: any

Queueing

Flow Based Fair Queueing

Maximum Number of Hashed Queues 128

(total queued/total drops/no-buffer drops) 0/0/0

9 REPLIES

Re: No packets matched by QoS CBWFQ Policy

hi

can u revert whether you use some voice device out there in that particular subnet or whts voice source and destination points ? are they configured with the ip which you are using here for classification ?

can u also try matching based on the port numbers too which proved to be a good and common method being implemented ..

if u have nbar support too in ur box then u can do the classification based on the RTP port nos too..

you can always check out this link too which discuss the same in broader vision...

http://cisco.com/en/US/partner/tech/tk652/tk698/technologies_tech_note09186a0080094660.shtml

regds

New Member

Re: No packets matched by QoS CBWFQ Policy

Thank you very much for your response, spremkumar.

Yes, the subnet contains voice devices. I understand that it is best to classify based upon something more specific like port number, but I changed this to make it simpler. However, neither the previous access-list or this more general access list works.

I have had a thought - our ADSL internet connection is configured with nat. At what point in the routing process is the service-policy parsed? Do I need to specify the ouside source address in access-list 100?

Also, although my intension by using this method is to ensure that voice has 56Kb of the bandwidth, can you tell me if other traffic will be able to utilise this 56Kb when no voice is being transmitted?

Do you think that ubar is a better method of prioritisation and, if so, would you tell me why?

With your help, I'm looking forward to getting this working!! ;-)

Best regards

Re: No packets matched by QoS CBWFQ Policy

hi

The configs related to QOS has to be there in all the boxes throughout the network which is being used by your location to reach the remote location.

if theres any config mismatch or no config at all the priority path or the priority given to the particular traffic pattern will become invalid.

Since you are connecting to a internet backbone where you cant or never expect some kinda priority assigned to your traffic pattern i dont think it will be viable or will be able to achieve the kinda priroity you are checking out for voice.The priority path will be broken out there in SP network once your traffic enters and travrese the SP backbone..

if both of your locations connected on the SP backbone and if your SP agrees for the similar kinda markings or qos configs as you do in your sites you will be able to achieve the end to end priority.

The unused b/w alloted for the specific class can be used by other traffic patterns.

i was mentioning NBAR which makes your work quite easy during the classification stage .(which you do under your class-maps)

do revert if you require more info on the same..

regds

New Member

Re: No packets matched by QoS CBWFQ Policy

Hi spremkumar

I agree with you that sending TOS-marked packets over networks with which you have no control can not be guaranteed to work as required. Howeverm as we have limited bandwidth to the internet (256/512) I wish to simply prioritise the classified traffic when it reaches the outgoing Internet interface, so that it leaves in the quickest possible time.

Thank you for the other info. I'm particularly relieved to hear that the bandwidth earmarked for priority traffic can be used by other traffic too. This wasn't clear to me in the documentation before.

Best wishes

Hal

Bronze

Re: No packets matched by QoS CBWFQ Policy

What is the config on the dialer interface? Is it an internet link or a private DSL? Are you performing NAT on the dialer interface?

Daniel

New Member

Re: No packets matched by QoS CBWFQ Policy

Hi Daniel

That is correct. It is a DSL dialer interface to the Internet. Yes, I am performing NAT on the dialer interface too.

Are there any caveats regarding this configuration?

Thanks a lot

Bronze

Re: No packets matched by QoS CBWFQ Policy

That could be the problem, I think the service policy gets checked after NAT.

You might be able to do some thing like this.

class-map voip-internal

match access-group 100

!

class-map ef

match ip dscp ef

!

policy-map tag-voice

class voip-internal

set ip dscp ef

!

policy-map voip-adsl

class ef

priority 56

!

interface fa 0/0 (or whatever your LAN interface the voip comes in on is)

service-policy input tag-voice

!

interface dialer 2

service-policy output voip-adsl

!

This will tag the voip packets as they come in, I'm not sure if NAT will keep the dscp value because I can't test this right now. But if it does than the output policy should match those packets and use CBWFQ.

Daniel

New Member

Re: No packets matched by QoS CBWFQ Policy

Thank you both for your help so far. I'm afraid that I'm making no progress with this.

I have received the following error (or message) when applying the service-policy command to the dialer interface:

Class Based Weighted Fair Queueing will be applied only to the Virtual-Access interfaces associated with an MLP bundle

I'm not sure what this means. I'm not using a Virtual-Access interface.

Hope you can help

Hal

New Member

Re: No packets matched by QoS CBWFQ Policy

Hi,

I have resolved similar issue by configuring service-policy only on physical interface not logical.

Regards,

Brane

206
Views
0
Helpful
9
Replies