Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

no route to server

Hello,

I have two devices on our network.  With the first device namely Sw-ArbgeTelemL3-01 i have a route back to a server namely 10.218.34.5 - but with the second device i do not have a route back.

I have a route back to 10.218.34.5 from Sw-ArbgeTelemL3-01

Sw-ArbgeTelemL3-01#sh ip route 10.218.34.5
Routing entry for 10.218.32.0/22
  Known via "ospf 1", distance 110, metric 20, type extern 2, forward metric 1015
  Last update from 172.19.254.65 on FastEthernet0/23, 1d04h ago
  Routing Descriptor Blocks:
  * 172.19.254.65, from 172.18.47.152, 1d04h ago, via FastEthernet0/23
      Route metric is 20, traffic share count is 1


But i dont have a route back from Rtr-ClakeTelem-01


Rtr-ClakeTelem-01#sh ip route 10.218.34.5
% Network not in table


Any ideas.  I have attached the configs from both devices.

Kevin

1 ACCEPTED SOLUTION

Accepted Solutions

no route to server

Hi ,

10.218.32.0/22 is an External route (LSA5), Rtr-ClakeTelem-01  is a ospf stub ( no LSA5 allowed )  - you will have a default route (LSA3) on this router.

> Rtr-ClakeTelem-01

router ospf 1

log-adjacency-changes

area 66 stub

area 72 stub no-summary

network 172.21.98.0 0.0.0.255 area 72

network 172.21.111.0 0.0.0.3 area 72

Dan

10 REPLIES

no route to server

Hi ,

10.218.32.0/22 is an External route (LSA5), Rtr-ClakeTelem-01  is a ospf stub ( no LSA5 allowed )  - you will have a default route (LSA3) on this router.

> Rtr-ClakeTelem-01

router ospf 1

log-adjacency-changes

area 66 stub

area 72 stub no-summary

network 172.21.98.0 0.0.0.255 area 72

network 172.21.111.0 0.0.0.3 area 72

Dan

Community Member

no route to server

Dan,

Any ideas why i cant ping 10.218.34.5 from Rtr-ClakeTelem-01 which as you say has the default route but i can ping it from Sw-ArbgeTelemL3-01.

thanks

Kevin

no route to server

Hi Kevin ,

- Does it respond from Rtr-ClakeTelem-01

- Does the server have a default gw ?

- Is the default gw the Rtr-ClakeTelem-01

Dan

Community Member

no route to server

Dan,

I cant ping 10.218.34.5 from Rtr-ClakeTelem-01 (172.21.111.2)

The server gateway is 10.218.35.0

The server is on a different subnet from Rtr-ClakeTelem-01 but its all allowed through the firewalls.

Sw-ArbgeTelemL3-01 (172.19.255.211) which is the next hop from Rtr-ClakeTelem-01 can ping it ok

Kevin

no route to server

Hi Kevin,

- Do you run ospf with your firewall ?

- Sw-ArbgeTelemL3-01 : show ip ospf int b

- you should also check the firewall's routing table and permited flows

Dan

Community Member

no route to server

Dan,

We dont run OSPF on firewalls.  But firewall isnt the problem because Sw-ArbgeTelemL3-01 is working.

Sw-ArbgeTelemL3-01#sh ip ospf int brief

Interface    PID   Area            IP Address/Mask    Cost  State Nbrs F/C

Fa0/11       1     72              172.21.111.1/30    1     DR    1/1

Kevin

Re: no route to server

Hi Kevin ,

Sorry , I did saw afterwards that you had those details attached in your initial post.

I didn't saw any of the prefixes announced by Rtr-Clake on the Sw-ArbgeTelecom

interface Vlan1 ip address 172.21.98.254 255.255.255.224

interface Vlan61  ip address 172.21.98.62 255.255.255.192

interface Vlan62  ip address 172.21.98.190 255.255.255.192

Although I do belive that when you are pinging from Rtr-Clake the source IP used is 172.21.111.1

From your "show ip ospf int b" there is only one neighbour, but from the initial output you receive the prefix from another neighbor :

Sw-ArbgeTelemL3-01#sh ip route 10.218.34.5

Routing entry for 10.218.32.0/22

  Known via "ospf 1", distance 110, metric 20, type extern 2, forward metric 1015

  Last update from 172.19.254.65 on FastEthernet0/23, 1d04h ago

  Routing Descriptor Blocks:

  * 172.19.254.65, from 172.18.47.152, 1d04h ago, via FastEthernet0/23

      Route metric is 20, traffic share count is 1

What is the neighour's ospf config ?

Dan

Community Member

no route to server

Dan,

The neighbour (Rtr-Clake) is 172.21.111.2.  Its is a serial link over to Sw-ArbgeTelemL3-01.  I have listed the full output from the sh ip ospf int brief command

Sw-ArbgeTelemL3-01#sh ip ospf int brief

Interface    PID   Area            IP Address/Mask    Cost  State Nbrs F/C

Lo0          1     0               172.19.255.211/32  1     LOOP  0/0

Fa0/24       1     0               172.19.254.69/30   4000  DR    1/1

Fa0/23       1     0               172.19.254.66/30   1000  DR    1/1

Vl98         1     72              172.21.108.254/24  1     DR    0/0

Vl28         1     72              172.21.100.254/24  1     DOWN  0/0

Fa0/12       1     72              172.21.111.5/30    1     BDR   1/1

Fa0/11       1     72              172.21.111.1/30    1     DR    1/1

no route to server

Yes , 172.21.111.2 will be the source of the icmp packets generated from Rtr-Clake.

From your first output Rtr-Clake :

show ip route

C       172.21.111.0/30 is directly connected, FastEthernet0

C       172.21.98.128/26 is directly connected, Vlan62

Running config

interface Vlan1

  ip address 172.21.98.254 255.255.255.224

interface Vlan61

  ip address 172.21.98.62 255.255.255.192

interface Vlan62

  ip address 172.21.98.190 255.255.255.192

There are some connected vlans missing. Which one is your current config ?

- Could you check the router 172.19.254.66 for the 172.21.111.0/30

- Paste please the output for your Rtr-Clake : ping 10.218.34.5

Dan

Community Member

no route to server

Dan,

This is the current config.

hostname Rtr-ClakeTelem-01

ip cef

ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3

multilink bundle-name authenticated

interface FastEthernet0
ip address 172.21.111.2 255.255.255.252
duplex auto
speed auto

interface Vlan1
ip address 172.21.98.254 255.255.255.224

interface Vlan61
ip address 172.21.98.62 255.255.255.192

interface Vlan62
ip address 172.21.98.190 255.255.255.192

router ospf 1
log-adjacency-changes
area 66 stub
area 72 stub no-summary
network 172.21.98.0 0.0.0.255 area 72
network 172.21.111.0 0.0.0.3 area 72

ip forward-protocol nd

no ip http server
no ip http secure-server
ip tacacs source-interface FastEthernet0

tacacs-server host 10.218.34.5
tacacs-server directed-request
tacacs-server key 50ftw4r3
tacacs-server administration

control-plane

Ping ping 10.218.34.5 doesnt work from this rtr

Kevin

330
Views
0
Helpful
10
Replies
CreatePlease to create content