Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

No WAN Connection through inside interface

Hi 

 

Apologies in advance for my lack of knowledge on this subject, I have a cisco 2800 router running software version 12.4.

 

I am attempting to gain a WAN connection for clients on the LAN behind the router, the router will sit behind the primary router and assigned a external IP from a range on a leased line connection. I have tested the theory by putting my laptop behind the router assigning it the external IP, subnet mask and default gateway with 8.8.8.8 and 4.2.2.2 as the DNS and I successfully got a WAN connection and was able to browse the web.

 

I attempted the same with the router but at the moment am struggling getting out on to the internet when behind the 2800. Maybe I am missing something blatantly obvious, here's my running config. It would be hugely appreciated if someone could give me a nudge in the right direction.

 

When I run a test on the external interface it completes successfully, however when I run a test on internal interface it returns "checking exit interface select user-specified option or add a host specific/network specific/default route through this interface and retest connection"

 

Here is my running config below

 

Thanks in advance.

 

Building configuration...

Current configuration : 3765 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ************
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
no logging buffered
enable secret 5 ************
enable password ************
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local
!
!
aaa session-id common
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
ip name-server 8.8.8.8
ip name-server 4.2.2.2
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
!
!
crypto pki trustpoint TP-self-signed-2983870642
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2983870642
 revocation-check none
 rsakeypair TP-self-signed-2983870642
!
!
crypto pki certificate chain TP-self-signed-2983870642
 certificate self-signed 01

*
*
*
*
*
*
*
*

        quit
!
!
username ******** privilege 15 password 0 ********
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.110.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet0/1
 description $ETH-WAN$
 ip address 88.88.88.88 255.255.255.240
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet0/1/0
 switchport mode trunk
!
interface FastEthernet0/1/1
 switchport mode trunk
!
interface FastEthernet0/1/2
 switchport mode trunk
!
interface FastEthernet0/1/3
 switchport mode trunk
 no mop enabled
!
interface ATM0/0/0
 no ip address
 shutdown
 no atm ilmi-keepalive
!
interface Vlan1
 no ip address
 shutdown
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 88.88.88.89
ip http server
ip http authentication local
ip http secure-server
!
!
ip nat pool IP_Pool 192.168.110.1 192.168.110.10 netmask 255.255.255.0
ip nat inside source list 2 pool IP_Pool overload
!
access-list 1 remark INSIDE_IF=FastEthernet0/0
access-list 1 remark CCP_ACL Category=2
access-list 1 permit 192.168.110.0 0.0.0.255
access-list 2 remark CCP_ACL Category=2
access-list 2 permit 192.168.110.0 0.0.0.255
snmp-server community public RO
!
!
!
!
!
!
!
control-plane
!
!
!
ccm-manager fax protocol cisco
!
mgcp fax t38 ecm
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 password **************
 transport input telnet ssh
!
scheduler allocate 20000 1000
end

3 REPLIES

Hello Is this the running

Hello

 

Is this the running config of the primary router or the router that is behind it - ( i assume its the primary?)

 

If so what port are you attaching the "other" router siting behind the primary  and can you post the running config that router also.

 

res

Paul

Please don't forget to rate any posts that have been helpful. Thanks.
New Member

Hi Paul  Thanks for the

Hi Paul 

 

Thanks for the prompt reply, I have managed to correct the issue by adding the line.

ip routing

 

I am not sure what this has done but appears to have rectified my problem.

 

FYI this is the router that will sit behind the primary router.

 

Thanks again for your reply, is very much appreciated.

 

Regards 

New Member

Bizarre! considering IP

Bizarre! considering IP Routing is automatically enabled in the Cisco ios. Even if it was disabled it should have showed as 'no ip routing' in the config.

Essentially, this command enables the router to 'route' IP packets :)

137
Views
10
Helpful
3
Replies