Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

not able to configure EtherChannel on

I tried to configure EthernChannel on Cat2948 L3 switch, but failed. Not sure it is because of the limitation of the paltform or configuration problem, I post the "show version" and "show config" here:

sw#sh ver

Cisco Internetwork Operating System Software

IOS (tm) L3 Switch/Router Software (CAT2948G-IN-M), Version 12.0(25)W5(27b) RELEASE SOFTWARE

Copyright (c) 1986-2004 by cisco Systems, Inc.

Compiled Tue 11-May-04 18:45 by integ

Image text-base: 0x60010928, data-base: 0x6060A000

ROM: System Bootstrap, Version 12.0(7)W5(15) RELEASE SOFTWARE

sw-sgdc-3rdflr uptime is 1 year, 27 weeks, 5 days, 7 hours, 31 minutes

System restarted by power-on at 02:31:36 UTC Fri Nov 26 2004

System image file is "bootflash:cat2948g-in-mz.120-25.W5.27b.bin"

cisco Cat2948G (R5000) processor with 49152K/16384K bytes of memory.

R5000 processor, Implementation 35, Revision 2.1

....

show config (configuration is the same for all the interface):

interface FastEthernet1

no ip address

no ip directed-broadcast

bridge-group 1

interface BVI1

ip address 10.10.10.1 255.255.255.0

no ip directed-broadcast

And if i want to add 1 more connection to implement load-sharing, how to do that?

5 REPLIES

Re: not able to configure EtherChannel on

Just curious, do you really need bridging in this network?

your post title states etherchannel ?

where are these configs?

anyway check the following link for etherchannel configs for CAT2948

http://www.cisco.com/warp/public/473/172.html#configs

HTH,

if it does please rate this post.

vlad

New Member

Re: not able to configure EtherChannel on

is it because of the bridging, that i am not able to config EtherChannel? It was configured by someone else and I don't want to change that. there are only 1 vlan on that.

Re: not able to configure EtherChannel on

when confiugrin make sure that your all port should have same characteristics like duplex speed and i think your all ports should be in the same VLAN. so first of all check it out that.

rate this post if it helps

regards

Devang

Re: not able to configure EtherChannel on

Hello,

there's no problem to put bridge-group on your configuration.

Please take a look on the link I've posted, you'll see etherchannel using bridge-group.

But again, could you give us the complete etherchannel configuration?

to have etherchannel running you need similar configs in all the interfaces under the same channel-group (in both switches), assuming that you are using a etherchannel to link 2 switches together.

Please give us more information about your actual problem and configs.

and dont forget to rate any helpful posts (grades range from 1 to 5 - from not helpful to really helpful).

Vlad

"!--- Configure a logical interface for the EtherChannel.

interface Port-channel1

no ip address

no ip directed-broadcast

hold-queue 300 in

!

!--- Create a subinterface for each VLAN on the port channel.

!

interface Port-channel1.1

!--- Specify the encapsulation and VLAN number.

encapsulation dot1Q 1

no ip redirects

no ip directed-broadcast

!--- Add the subinterface to the appropriate bridge group.

!--- All the interfaces (and subinterfaces) that belong to the

!--- same VLAN (network or subnet) should be configured to fall

!--- in the same bridge group.

bridge-group 1

!

!--- Configure a subinterface for the second VLAN.

!--- This procedure must be repeated for every VLAN.

!

interface Port-channel1.2

encapsulation dot1Q 2

no ip redirects

no ip directed-broadcast

bridge-group 2

!

!--- Configure a subinterface for the native VLAN.

!

interface Port-channel1.99

encapsulation dot1Q 99 native

no ip redirects

no ip directed-broadcast

!--- Note in this case you do not put any bridge group

!--- statements under this subinterface. A dummy VLAN has been chosen

!--- as the native VLAN on which you do not put any traffic,

!--- so there is no need to have this routed.

!

interface FastEthernet1

no ip address

no ip directed-broadcast

!--- Configure the port to channel 1.

channel-group 1

!

interface FastEthernet2

no ip address

no ip directed-broadcast

!--- Configure the port to channel 1.

channel-group 1

!

interface FastEthernet3

no ip address

no ip directed-broadcast

!--- The device connected on this interface belongs

!--- to the same subnet (VLAN 1) as subinterface 1 on

!--- the port channel, so this interface has to be added to

!--- bridge-group 1.

bridge-group 1

!

!--- If there are any other interfaces that belong to

!--- the same VLAN (subnet), they all have to be added to

!--- the respective bridge group.

( .... Output is suppressed)

!

!

! a routed interface for bridge-group 1

interface BVI1

ip address 1.1.1.1 255.255.255.0

no ip directed-broadcast

no ip route-cache cef

!

! a routed interface for bridge-group 2

interface BVI2

ip address 2.2.2.1 255.255.255.0

no ip directed-broadcast

no ip route-cache cef

"

Re: not able to configure EtherChannel on

Hello,

Usually, when you channel two or more interfaces, is because you are connecting those interface to another switch. With your example above, it looks like you have a fastethernet that you might be connecting to a host, channeling will not work and it's not for that purpose, if however, I am wrong with my assumption, the following link should help you configure it:

http://www.cisco.com/univercd/cc/td/doc/product/l3sw/2948g-l3/rel_12_0/7wx515a/config_g/ether_ch.htm

Remember this is a router/bridge device not a switch like Cat2948G or Cat4000.

Please rate helpful post.

110
Views
0
Helpful
5
Replies
CreatePlease login to create content