Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Not able to ping / route to different network

Hi,

I configured two router one router is connect to internet (config which i showed below) from that router I can able to ping google or any website. that is going through ip 10.31.72.41 and another one router (network) is connected to this router with MPLS line that network is connected to G0/1 (192.168.0.2) on that router have another one local network 10.31.74.0 is connected.

R1

GEth 0/0 - 10.31.72.41                              R1 having internet on GEth 0/0

GEth 0/1 -  192.168.0.2

R2

GEth 0/0 - 10.31.74.55    

GEth 0/1 - 192.168.0.10

                  

both these router is connected via MPLS line and R2 need to get internet from R1.

when I trying to ping 10.31.72.41 from R2 its pinging and trying to ping 10.31.74.55 from R1 also pinging.

but when I'm trying to ping 10.31.72.250 from R2 is not pinging and showing request timed out. 10.31.72.250 is the IP which providing internet and that link is connected 10.31.72.41

and when i'm trying to ping 10.31.74.1 from R1 is not pinging and showing request timed out

both router have Gigabyte Ethernet

and its connected to Fast ethernet is there any problem with that? Can you please guide me any problem is there in the configuration, or connection. I didn't understand. Please help. Thank you in advance.

Current configuration : 1541 bytes

!

! Last configuration change at 09:43:39 UTC Wed Aug 1 2012

! NVRAM config last updated at 09:00:01 UTC Wed Aug 1 2012

! NVRAM config last updated at 09:00:01 UTC Wed Aug 1 2012

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

!

no ipv6 cef

ip source-route

ip cef

!

!

!

!

ip name-server 195.229.241.222

ip name-server 213.42.20.20

multilink bundle-name authenticated

!

crypto pki token default removal timeout 0

!

!

license udi pid CISCO1941/K9 sn FCZ161190K5

!

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

ip address 10.31.72.41 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 192.168.0.2 255.255.255.252

ip ospf network point-to-point

duplex auto

speed auto

!

router ospf 91

redistribute connected

network 10.31.0.0 0.0.255.255 area 0

network 192.168.0.0 0.0.0.3 area 0

network 192.168.0.8 0.0.0.3 area 0

!

ip default-gateway 10.31.72.250

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 10.31.72.250

ip route 10.31.74.0 255.255.255.0 192.168.0.9

!

!

!

!

control-plane

!

!

!

line con 0

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

login

transport input all

!

scheduler allocate 20000 1000

end

Router#

Current configuration : 1541 bytes

!

! Last configuration change at 09:43:39 UTC Wed Aug 1 2012

! NVRAM config last updated at 09:00:01 UTC Wed Aug 1 2012

! NVRAM config last updated at 09:00:01 UTC Wed Aug 1 2012

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

!

no ipv6 cef

ip source-route

ip cef

!

!

!

!

ip name-server 195.229.241.222

ip name-server 213.42.20.20

multilink bundle-name authenticated

!

crypto pki token default removal timeout 0

!

!

license udi pid CISCO1941/K9 sn FCZ161190K5

!

!

!

!

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

ip address 10.31.72.41 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 192.168.0.2 255.255.255.252

ip ospf network point-to-point

duplex auto

speed auto

!

router ospf 91

redistribute connected

network 10.31.0.0 0.0.255.255 area 0

network 192.168.0.0 0.0.0.3 area 0

network 192.168.0.8 0.0.0.3 area 0

!

ip default-gateway 10.31.72.250

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 10.31.72.250

ip route 10.31.74.0 255.255.255.0 192.168.0.9

!

!

!

!

control-plane

!

!

!

line con 0

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

login

transport input all

!

scheduler allocate 20000 1000

end

Router#

3 REPLIES

Not able to ping / route to different network

Hi Renyadoor,

i guess you need a redistribute static below your OSPF process. By the way you can check this on your routing table.

Don't forget the keyword subnet... It could be helpful in the future for a different garnularity and route control.

HTH

Alessio

Community Member

Not able to ping / route to different network

Dear Alessio,

Thank you very much for quick response.

I tried to put redistribute, but its showing "only classful networks will be redistributed" i don't know this is correct or not. please guide me to put redistribute....for static to ospf

Router#config t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#router ospf 91

Router(config-router)#re

Router(config-router)#redistribute sta

Router(config-router)#redistribute static metr

Router(config-router)#redistribute static metric 2

% Only classful networks will be redistributed

Router(config-router)#

Not able to ping / route to different network

Hi Renyadoor,

this is the correct natural behavior of this kind of redistribution ... unless using the keyword subnet:

redistribute static subnet

Try and let me know

Alessio

297
Views
0
Helpful
3
Replies
CreatePlease to create content