Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Not Recieving RIP Updates on 3750

Hello

I have a problem where I don't receive RIP Updates from upstream devices 192.168.x.20 and 192.168.x.21.  This is on a 3750 L2 Switch with IOS c3750-ipservices-mz.122-25.SEB4.  RIP only seems to be Sent/Recieved on one Interface (VLAN 4).  Basic config, debugging and show output below.

interface Vlan2

ip address 192.168.x.1 255.255.255.128

!

interface Vlan3

ip address 192.168.x.129 255.255.255.128

!

interface Vlan4

ip address 10.111.x.252 255.255.255.240

!

router rip

version 2

network 10.0.0.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.111.x.254

ip route 10.11.x.0 255.255.254.0 192.168.x.124

ip route 10.x.165.0 255.255.255.224 192.168.x.20

ip route 10.x.11.0 255.255.255.0 192.168.118.124

ip route 10.x.23.0 255.255.255.0 192.168.118.124

ip route 10.111.0.0 255.255.0.0 192.168.118.20

ip route 10.254.0.0 255.255.240.0 192.168.x.20

!

!

!

debug ip rip

1y6w: RIP: sending v2 update to 224.0.0.9 via Vlan4 (10.111.254.252)

1y6w: RIP: build update entries - suppressing null update

sho ip rip database

10.0.0.0/8    auto-summary

10.111.x.240/28    directly connected, Vlan4

sho ip protocols

*** IP Routing is NSF aware ***

Routing Protocol is "rip"
  Sending updates every 30 seconds, next due in 27 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface                 Send  Recv  Triggered RIP  Key-chain
    Vlan4                     2     2
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    10.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 120)

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Not Recieving RIP Updates on 3750

You need to configure VLAN2 and VLAN3 for RIP routing.

If you look under 'show ip protocols' you will see that the router is only routing for the 10.0.0.0 network with RIP.

I would also do a 'no auto-summary' as well.

router rip

network 192.168.x.0

network 192.168.x.128

1 REPLY

Re: Not Recieving RIP Updates on 3750

You need to configure VLAN2 and VLAN3 for RIP routing.

If you look under 'show ip protocols' you will see that the router is only routing for the 10.0.0.0 network with RIP.

I would also do a 'no auto-summary' as well.

router rip

network 192.168.x.0

network 192.168.x.128

240
Views
0
Helpful
1
Replies
CreatePlease to create content