Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

null interface caused floating static route issue

I build two GRE tunnel with keepalive, and use floating static route for backup purpose. But i found it works improperly due to a route point to null0.

ip route 10.20.1.0 255.255.255.0 1.2.4.6

ip route 10.20.1.0 255.255.255.0 1.2.4.10 200

ip route 1.2.0.0 255.255.0.0 null0 --->this route caused floating static route works improperly. Even if the Tunnel500 is down, the route 10.20.1.0 to 1.2.4.6 will keeping active. But if i remove the route 1.2.0.0 to null0, it works fine. I got little confuse, anyone would help will be much appreciated.

!

interface Tunnel500

ip address 1.2.4.5 255.255.255.252

ip mtu 1500

ip tcp adjust-mss 1350

keepalive 5 1

tunnel source 10.86.2.2

tunnel destination 10.90.10.194

!

interface Tunnel501

ip address 1.2.4.9 255.255.255.252

ip mtu 1476

ip tcp adjust-mss 1436

keepalive 5 1

tunnel source 10.86.4.2

tunnel destination 10.90.10.198

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Gold

Re: null interface caused floating static route issue

Hi,

What is happening, is that in presence of "ip route 1.2.0.0 255.255.0.0 null0", the router is trying recursive routing, because the routing information for 1.2.4.6 is derived from the said static route.

To work around this, either use dynamic routing over tunnel, or point the static route to the interface and not IP address, or both IP address AND interface.

A good discussion is presented at:

http://www.cisco.com/en/US/customer/tech/tk365/technologies_tech_note09186a00800ef7b2.shtml

Hope this helps, please rate post if it does!

5 REPLIES
Hall of Fame Super Gold

Re: null interface caused floating static route issue

Can you send output of "show ip route 10.20.1.0 255.255.255.0" when tunnel500 is up, and again when it is down ?

And again the above, when "ip route 1.2.0.0 255.255.0.0 null0" is not configured.

New Member

Re: null interface caused floating static route issue

r1#sh ip route 10.20.1.0 -------When "ip route 1.2.0.0 255.255.0.0 null0" is configured, no matter the tunnel500 is up or down, the "sh ip route 10.20.1.0" output will be the same

Routing entry for 10.20.1.0/24

Known via "static", distance 1, metric 0

Redistributing via ospf 1

Routing Descriptor Blocks:

* 1.2.4.6

Route metric is 0, traffic share count is 1

!

r1#sh ip route 10.20.1.0 ------- When tunnel500 is up and "ip route 1.2.0.0 255.255.0.0 null0" is not configured.

Routing entry for 10.20.1.0/24

Known via "static", distance 1, metric 0

Redistributing via ospf 1

Routing Descriptor Blocks:

* 1.2.4.6

Route metric is 0, traffic share count is 1

!

r1#sh ip route 10.20.1.0 ------- When tunnel500 is down and "ip route 1.2.0.0 255.255.0.0 null0" is not configured.

Routing entry for 10.20.1.0/24

Known via "static", distance 200, metric 0

Redistributing via ospf 1

Routing Descriptor Blocks:

* 1.2.4.10

Route metric is 0, traffic share count is 1

!

Hall of Fame Super Gold

Re: null interface caused floating static route issue

Hi,

What is happening, is that in presence of "ip route 1.2.0.0 255.255.0.0 null0", the router is trying recursive routing, because the routing information for 1.2.4.6 is derived from the said static route.

To work around this, either use dynamic routing over tunnel, or point the static route to the interface and not IP address, or both IP address AND interface.

A good discussion is presented at:

http://www.cisco.com/en/US/customer/tech/tk365/technologies_tech_note09186a00800ef7b2.shtml

Hope this helps, please rate post if it does!

New Member

Re: null interface caused floating static route issue

p.bevilacqua,

It's greatly helpful. Thank you so much!!

I point the static route to IP address AND interface, it works fine.

ip route 10.20.1.0 255.255.255.0 Tunnel500 1.2.4.6

ip route 10.20.1.0 255.255.255.0 Tunnel501 1.2.4.10 200

Hall of Fame Super Gold

Re: null interface caused floating static route issue

In reality, the IP address is redundant, as your tunnel interfaces are point-to-point. But, it doesn't harm neither.

Thanks for the nice rating and good luck!

199
Views
5
Helpful
5
Replies
CreatePlease to create content