cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
525
Views
4
Helpful
3
Replies

NxT1 Config (MLPPP help)

quikcheck
Level 1
Level 1

Hello everyone,

I need some help configuring MLPPP for an NxT1 (3MB) for internet access. My ISP will not support me with the config unless they supply the router and I don't know anything about MLPPP configs except for what I can find on the cisco support site, etc. They haven't installed the circuit yet, so this is obviously just a pre-configuration, but does it look like this should work? Obviously, I am making a couple of assumptions (no CHAP, etc).

This is what I have come up with so far:

Building configuration...

Current configuration : 1657 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname router

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

!

no aaa new-model

!

resource policy

!

ip subnet-zero

!

!

ip cef

!

!

!

username *** privilege 15 secret 5 ***

!

!

!

interface Multilink1

ip address 1.2.3.4 255.255.255.252

ppp multilink

ppp multilink group 1

!

interface FastEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$

ip address 10.10.10.1 255.255.255.248

duplex auto

speed auto

!

interface FastEthernet0/1

description $ETH-LAN$

ip address 1.2.3.5 255.255.255.224

duplex auto

speed auto

!

interface Serial0/0/0

bandwidth 1536

no ip address

encapsulation ppp

shutdown

no fair-queue

pulse-time 6

service-module t1 timeslots 1-24

ppp multilink

ppp multilink group 1

!

interface Serial0/1/0

bandwidth 1536

no ip address

encapsulation ppp

shutdown

no fair-queue

pulse-time 6

service-module t1 timeslots 1-24

ppp multilink

ppp multilink group 1

!

interface Virtual-Template1

no ip address

ppp multilink group 1

!

ip classless

ip route 0.0.0.0 0.0.0.0 Multilink1

!

ip http server

ip http access-class 23

ip http authentication local

ip http timeout-policy idle 60 life 86400 requests 10000

!

access-list 23 permit 10.10.10.0 0.0.0.7

!

control-plane

!

!

line con 0

login local

line aux 0

line vty 0 4

access-class 23 in

privilege level 15

login local

transport input telnet

line vty 5 15

access-class 23 in

privilege level 15

login local

transport input telnet

!

scheduler allocate 20000 1000

!

end

router#

Thanks everyone for your help and patience.

1 Accepted Solution

Accepted Solutions

Jonathan

Since we do not know what router platform or what card is being used, it is difficult to comment on specifics of what is required. If you found a reference on the Cisco site that indicates that you need it, then perhaps you should leave it in - at least until you have a chance to bring up the circuit. If there appears to be anything strange about the operation of the circuit removing that statement would be one of the first things that I would do.

I can also say that I have configured a number of routers with service-module commands under the serial interface and I do not believe that I have needed to code pulse time on any of them.

HTH

Rick

HTH

Rick

View solution in original post

3 Replies 3

Richard Burts
Hall of Fame
Hall of Fame

Jonathan

Just to clarify a bit, the provider is willing to supply a router to do multilink and would do configs for it, but they are not willing to help with configs if it is not their router. Is this a correct understanding? If it is your router and you have done the configs, will they do multilink (they just take no responsibility for your side)?

I have looked through the config - looking harder at the serial and multilink parts. I think that mostly it looks reasonable. I do not usually use the command pulse-time 6. I am not sure why you need it. Otherwise it looks ok to me. And I certainly agree with your assumption about not doing CHAP. I see little point in authenticating a point to point private circuit.

HTH

Rick

HTH

Rick

Rick,

You are correct about the ISP. I am sure they will give me the specifics regarding ISP-specific settings once the circuit is installed, but they just won't help me do the initial config of the router. They will do multilink (I bought a 3MB circuit, and they said it uses MLPPP).

As far as pulse-time 6, the cisco site I saw indicated that i needed to put that. If you don't think it's necessary, I am going to remove it.

Thank you VERY much for your help!

Jonathan

Jonathan

Since we do not know what router platform or what card is being used, it is difficult to comment on specifics of what is required. If you found a reference on the Cisco site that indicates that you need it, then perhaps you should leave it in - at least until you have a chance to bring up the circuit. If there appears to be anything strange about the operation of the circuit removing that statement would be one of the first things that I would do.

I can also say that I have configured a number of routers with service-module commands under the serial interface and I do not believe that I have needed to code pulse time on any of them.

HTH

Rick

HTH

Rick
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card