Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Object Tracking

I am trying to configure Object tracking on an interface. Currently I am tracking IP SLA, and because the primary line is bouncing (loosing LMI, and constantly going up/down state) it?s not effective. I am looking in configuring a tracked list and threshold percentage. Any suggestions what would be the best option for me in a situation when my Primary line is bouncing?

I appreciate any help in this matter.

-Fasih

9 REPLIES
Bronze

Re: Object Tracking

When a serial line does not wqorkfine as it must, the best way to troubleshoot the circuit is to perform loopback tests. Loopback tests allow you to isolate pieces of the circuit, and test them separately.Refer URL

http://cisco.com/en/US/tech/tk713/tk628/technologies_tech_note09186a00800a754b.shtml#csudsu

Silver

Re: Object Tracking

Hello,

You can increase the frequency and timeout value of the IP SLA if you want. Below you can find the link that explains how to do that:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios124/124cg/hsla_c/hsicmp.htm

Another option to consider is using dynamic routing. Since you have a serial your dyanmic routing protocol can failover between different route options withouth the need for tracking objects.

Let me know if you need further clarification,

Appreciate your rating,

Regards,

Community Member

Re: Object Tracking

m-haddad,

Could you send me more information as to how I can use Dynamic Routing in this situation.

Thank you

Silver

Re: Object Tracking

Hello,

Is this Router connected to ISP or Internal WAN? Can you give me some information about the topology? What type of encapsulation your are using on the Serial?

Waiting for your feedback,

Regards,

Community Member

Re: Object Tracking

The router is connected to a CSU and which is connected to an MPLS network. Below is the config:

ip sla 10

icmp-echo 152.162.251.133 source-interface FastEthernet0

timeout 1000

verify-data

tag PrimaryConnection

frequency 5

history lives-kept 2

ip sla schedule 10 life forever start-time now

ip sla 20

icmp-echo 167.156.189.134 source-interface FastEthernet1

timeout 1000

verify-data

tag SecondaryConnection

frequency 5

history lives-kept 2

ip sla schedule 20 life forever start-time now

!

chat-script DialAccess ABORT ERROR ABORT BUSY ABORT NO "" AT+MS=V34 OK AT+DS44=0 OK ATDT\T TIMEOUT 9

0 CONNECT

modemcap entry modem:MSC=S0=8

!

!

!

!

track 100 rtr 10 reachability.

!

tack 200 rtr 20 reachability

.

.

.

interface FastEthernet0

description Primary Connection

bandwidth 1536000

ip address 172.20.254.2 255.255.255.0

duplex auto

speed auto

service-policy output PrimaryQoS

!

interface FastEthernet1

description Secondary Connection

bandwidth 300000

ip address 192.162.2.50 255.255.255.0

duplex auto

speed auto

crypto ipsec client ezvpn ToCorpHubSecondary

service-policy output SecondaryQoS

.

.

.

.

ip route 0.0.0.0 0.0.0.0 152.162.251.133 track 100

ip route 0.0.0.0 0.0.0.0 192.162.2.1 50 track 200

ip route 152.162.251.133 255.255.255.255 FastEthernet0 172.20.254.1 permanent

ip route 167.156.189.134 255.255.255.255 FastEthernet1 192.162.2.1 50 permanent

Thank you for your help in advance.

Silver

Re: Object Tracking

Hello,

What you can do is run EIGRP on f0 the primary interface with the remote host. THe remote host should send you a default route. Therefore, you will get the default route from the remote host with Admin distance of 90.

Also, add another static default route for the secondary connection with admin distance 190.

In the above situation, when the primary link goes down you router will no more see the primary default route via EIGRP. Therefore, it will fall back to the static default route which has admin distance 190.

When the primary links goes back up, EIGRP session will be re-established and you will receive the dynamic default route via EIGRP and your router will shift back to use the primary link.

Hope this clarifies your question,

Let me know if you have other questions as well,

Regards,

Community Member

Re: Object Tracking

I am running OSPF, and it would require a design change to run EIGRP. I am using delay statements in track. I will update you with what I find.

Silver

Re: Object Tracking

Hello Fasih,

OSPF or EIGRP will do the same job. Just make sure the backup static route has an admin distance higher than 110.

Regards,

Community Member

Re: Object Tracking

Can you delay the reporting of the "down" state? That way, if it comes back "up" before the delay has expired, it will never get reported.

track 1 rtr 100 reachability

delay down

http://www.cisco.com/en/US/products/ps6350/products_configuration_guide_chapter09186a008042fbeb.html#wp1184072

254
Views
3
Helpful
9
Replies
CreatePlease to create content