Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

OER/Pfr load balance problem

Hi All

     ,, Actually I have problem in OER configuration .. Setup is I have single router acting as master controller and border router at same time , and this router is connected to two ISP routers .... The problem that load balancing is not hapenning even if the link utilization has exceed the configured percentage .. It still sending and revieving from one link only  ... See below configuration it might be helpful .. and thanks in advance ..

R1#sh running-config

Building configuration...

Current configuration : 2633 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R1

!

boot-start-marker

boot-end-marker

!

logging buffered 4096 debugging

!

no aaa new-model

!

resource policy

!

memory-size iomem 5

!

!

ip cef

no ip domain lookup

!

!

ip sla monitor 1

type echo protocol ipIcmpEcho 10.82.56.1 source-interface Loopback0

threshold 1

frequency 5

!

!

!

key chain key1

key 1

  key-string oer

!

!

oer master

policy-rules cisco

max-range-utilization percent 2

!

border 10.99.99.99 key-chain key1

  interface FastEthernet1/0 internal

  interface Serial0/1 external

   max-xmit-utilization percentage 5

  interface Serial0/0 external

   max-xmit-utilization percentage 2

!

learn

  throughput

  periodic-interval 0

  monitor-period 1

  aggregation-type bgp

backoff 90 90

mode route metric bgp local-pref 222

mode select-exit best

resolve range priority 1

resolve utilization priority 2 variance 1

!

oer border

logging

local Loopback0

master 10.99.99.99 key-chain key1

!

!

!

!

!

!        

!

!

!

!

!

!

!

!

!

!

!

interface Loopback0

ip address 10.99.99.99 255.255.255.255

!

interface Serial0/0

bandwidth 90

ip address 10.11.12.1 255.255.255.0

load-interval 30

serial restart-delay 0

no dce-terminal-timing-enable

!

interface Serial0/1

bandwidth 90

ip address 10.11.14.1 255.255.255.0

load-interval 30

serial restart-delay 0

no dce-terminal-timing-enable

!

interface Serial0/2

no ip address

shutdown

serial restart-delay 0

no dce-terminal-timing-enable

!

interface Serial0/3

no ip address

shutdown

serial restart-delay 0

no dce-terminal-timing-enable

!

interface FastEthernet1/0

ip address 10.222.32.2 255.255.255.0

ip flow ingress

duplex auto

speed auto

!        

interface FastEthernet2/0

no ip address

shutdown

duplex auto

speed auto

!

router ospf 1

log-adjacency-changes

redistribute bgp 650 subnets

network 10.11.12.0 0.0.0.255 area 0

network 10.11.14.0 0.0.0.255 area 0

network 10.222.32.0 0.0.0.255 area 0

!

router bgp 650

no synchronization

bgp log-neighbor-changes

redistribute connected

redistribute ospf 1

neighbor 10.11.12.2 remote-as 999

neighbor 10.11.14.2 remote-as 999

maximum-paths 2

no auto-summary

!        

no ip http server

no ip http secure-server

!

!

!

!

!

!

!

oer-map cisco 1

set mode select-exit best

!

oer-map OEr 10

!

control-plane

!        

!

!

!

!

!

!

!

!

!

line con 0

exec-timeout 0 0

logging synchronous

line aux 0

line vty 0 4

login

!

!

end

R1#

8 REPLIES
New Member

OER/Pfr load balance problem

Result of   #show oer master :

R1#sh oer master

OER state: ENABLED and ACTIVE

  Conn Status: SUCCESS, PORT: 3949

  Number of Border routers: 1

  Number of Exits: 2

  Number of monitored prefixes: 0 (max 5000)

  Max prefixes: total 5000 learn 2500

  Prefix count: total 0, learn 0, cfg 0

Border           Status   UP/DOWN             AuthFail

10.99.99.99      ACTIVE   UP       00:19:07          0

Global Settings:

  max-range-utilization percent 2

  mode route metric bgp local-pref 222

  mode route metric static tag 5000

  trace probe delay 1000

  no logging

Default Policy Settings:

  backoff 90 90 90

  delay relative 50

  holddown 300

  periodic 0

  mode route observe

  mode monitor both

  mode select-exit best

  loss relative 10

  unreachable relative 50

  resolve range priority 1 variance 0

  resolve utilization priority 2 variance 1

  resolve delay priority 11 variance 20

Learn Settings:

  current state : STARTED

  time remaining in current state : 101 seconds

  throughput

  no delay

  no protocol

  monitor-period 1

  periodic-interval 0

  aggregation-type bgp

  prefixes 100

  expire after time 720

R1#

Re: OER/Pfr load balance problem

If the logging enabled and you go over the link utilization specified percentage do you see any log saying OOP out of policy ?

In other word is the router detecting out of policy situation ?

Sent from Cisco Technical Support iPhone App

New Member

Re: OER/Pfr load balance problem

Hi,

Can you past the output of  "show oer master traffic-class" ?

Thanks

New Member

Re: OER/Pfr load balance problem

See this below logs while pinging high packet size ..

*Mar  1 01:21:59.583: %OER_MC-5-NOTICE: Range OOP BR 10.99.99.99, i/f Se0/0, percent 3

*Mar  1 01:21:59.583: %OER_MC-5-NOTICE: Load OOP BR 10.99.99.99, i/f Se0/0,  load 3 policy 1

*Mar  1 01:21:59.583: %OER_MC-5-NOTICE: Exit 10.99.99.99 intf Se0/0 OOP, Tx BW 3, Rx BW 3, Tx Load 3, Rx Load 3

R1#

*Mar  1 01:22:19.851: %OER_MC-5-NOTICE: Range OOP BR 10.99.99.99, i/f Se0/0, percent 6

*Mar  1 01:22:19.855: %OER_MC-5-NOTICE: Load OOP BR 10.99.99.99, i/f Se0/0,  load 6 policy 1

*Mar  1 01:22:19.859: %OER_MC-5-NOTICE: Exit 10.99.99.99 intf Se0/0 OOP, Tx BW 6, Rx BW 6, Tx Load 6, Rx Load 6

R1#

*Mar  1 01:22:23.099: %OER_MC-5-NOTICE: Discovered Exit for prefix 10.82.51.1/32, BR 10.99.99.99, i/f Se0/0

R1#

*Mar  1 01:22:40.531: %OER_MC-5-NOTICE: Range OOP BR 10.99.99.99, i/f Se0/0, percent 6

*Mar  1 01:22:40.531: %OER_MC-5-NOTICE: Load OOP BR 10.99.99.99, i/f Se0/0,  load 6 policy 1

*Mar  1 01:22:40.531: %OER_MC-5-NOTICE: Exit 10.99.99.99 intf Se0/0 OOP, Tx BW 6, Rx BW 6, Tx Load 6, Rx Load 6

R1#

*Mar  1 01:22:57.087: %OER_BR-5-NOTICE: Prefix Learning STOPPED

*Mar  1 01:22:57.099: %OER_MC-5-NOTICE: Prefix Learning WRITING DATA

*Mar  1 01:22:57.259: %OER_MC-5-NOTICE: Prefix Learning STARTED

*Mar  1 01:22:57.471: %OER_BR-5-NOTICE: Prefix Learning STARTED

R1#

R1#

*Mar  1 01:23:26.443: %OER_MC-5-NOTICE: NO route change, Observe mode, 10.82.51.1/32, BR 10.99.99.99, i/f Se0/1, Reason Range, OOP reason Range

Note :: show oer master traffic-class is not supported in my platform .. I have below command which indicate for policy setting :

R1#sh oer master policy

Default Policy Settings:

  backoff 90 90 90

  delay relative 50

  holddown 300

  periodic 0

  mode route observe

  mode monitor both

  mode select-exit best

  loss relative 10

  unreachable relative 50

  resolve range priority 1 variance 0

  resolve utilization priority 2 variance 1

  resolve delay priority 11 variance 20

oer-map cisco 1

  match ip prefix-lists:

  backoff 90 90 90

  delay relative 50

  holddown 300

  periodic 0

  mode route observe

  mode monitor both

*mode select-exit best

  loss relative 10

  unreachable relative 50

  resolve range priority 1 variance 0

  resolve utilization priority 2 variance 1

  resolve delay priority 11 variance 20

* Overrides Default Policy Setting

R1#

New Member

OER/Pfr load balance problem

Please .. need a reply on this ..

Thank you ..

New Member

Re: OER/Pfr load balance problem

based on your Logs and config, i see that your mode route is "OBSERVE". Change it to "mode route control"

oer master

mode route control

HTH.

Thanks-

Gerard

New Member

Re: OER/Pfr load balance problem

Thank you Gerard for your reply ... I'm still facing issue that is not getting balanced .. now traffic should move from se1/1 to se1/2 .. but i don't now where is the problem .. See latest log and some modification rectified .

*Apr 20 18:36:32.367: OER MC EXIT: 10.99.99.99, intf Se1/2 INPOLICY

*Apr 20 18:36:32.371: %OER_MC-5-NOTICE: Load OOP BR 10.99.99.99, i/f Se1/1,  load 197 policy 67

*Apr 20 18:36:32.375: %OER_MC-5-NOTICE: Exit 10.99.99.99 intf Se1/1 OOP, Tx BW 197, Rx BW 196, Tx Load 96, Rx Load 95

R1#             

*Apr 20 18:36:32.379: OER MC EXIT: 90 kbps should be moved from 10.99.99.99, intf Se1/1

R1#

R1#

*Apr 20 18:36:38.759: %OER_MC-5-NOTICE: Uncontrol prefix 10.82.51.1/32, Couldn't find the best exit

*Apr 20 18:36:38.763: %OER_MC-5-NOTICE: Uncontrol prefix 10.82.51.1/32, Couldn't choose exit in prefix timeout

R1#

*Apr 20 18:36:44.111: %OER_MC-5-NOTICE: Discovered Exit for prefix 10.82.51.1/32, BR 10.99.99.99, i/f Se1/1

R1#

Global Settings:

  max-range-utilization percent 40

  mode route metric bgp local-pref 222

  mode route metric static tag 5000

  trace probe delay 1000

  logging

Default Policy Settings:

  backoff 90 90 90

  delay relative 50

  holddown 300

  periodic 180

  mode route control

  mode monitor passive

  mode select-exit best

  loss relative 10

  unreachable relative 50

  resolve range priority 1 variance 0

  resolve utilization priority 2 variance 1

  resolve delay priority 11 variance 20

Learn Settings:

  current state : STARTED

  time remaining in current state : 87 seconds

  throughput

  delay

  no protocol

  monitor-period 1

  periodic-interval 0

  aggregation-type bgp

  prefixes 100

  expire after time 720

key chain key1

key 1

   key-string oer

oer master

policy-rules cisco

max-range-utilization percent 40

logging

!

border 10.99.99.99 key-chain key1

  interface FastEthernet0/0 internal

  interface Serial1/1 external

  interface Serial1/2 external

!

learn

  throughput

  delay

  periodic-interval 0

  monitor-period 1

  aggregation-type bgp

backoff 90 90

mode route control

mode monitor passive

mode route metric bgp local-pref 222

mode select-exit best

periodic 180

resolve range priority 1

resolve utilization priority 2 variance 1

!        

oer border

logging 

local Loopback0

master 10.99.99.99 key-chain key1

!        

oer-map cisco 1

set mode select-exit best

New Member

Re: OER/Pfr load balance problem

Try this .. you may need to learn your Inside Prefs..either manual or dynamic method.

Dynamic:

     oer master

      learn

        inside bgp

        no aggregation-type bgp

       oer-map cisco 1

      match oer learn inside

Manual:

  oer master

    policy-rule cisco

  ip prefix-list MYNET permit 4.5.6.0/24 (inside network for example)

  oer-map cisco 1

   ip address prefix-list MYNET inside

1108
Views
0
Helpful
8
Replies